Need a generic method for interacting with AUS/Balrog

RESOLVED DUPLICATE of bug 1277871

Status

Taskcluster
Task Configuration
RESOLVED DUPLICATE of bug 1277871
2 years ago
4 months ago

People

(Reporter: selenamarie, Assigned: mtabara)

Tracking

(Blocks: 2 bugs)

Details

We have several issues with builds that have an AUS/Balrog component failing. Several were disabled in November and more will be disabled soon. 

This bug is for creating a generic AUS task that can be used as a consistent interface to balrog. A docker image with the necessary config and/or credentials is also needed. A few options exist: 

* using a private docker image
* using a public docker image with encrypted secrets
* using a public docker image, deployed in a VPC that has access to AUS

Use of this task probably should be constrained by a set of scopes administrated by RelEng.
After talking with Selena who talked with Rail... and I ended up talking to Rail as well... 
I think if funsize image was moved over, we could just use the image to set up the tasks?

Marking bug 1217130 as a blocker, if I'm wrong please undo.
Depends on: 1217130
I don't think this depends on putting funsize images into the tree.
No longer depends on: 1217130

Updated

2 years ago
Assignee: nobody → aksasaki

Comment 3

2 years ago
There isn't a hard dependency on bug 1245837, but my current approach will involve fixing that bug first.
Depends on: 1245837

Comment 4

2 years ago
Most likely I'm going to be focused on signing with the new worker lib, and this bug will be for someone else.

Comment 5

2 years ago
catlee: is this the piece we're considering having Ben mentor Varun with?
Flags: needinfo?(catlee)
I'm not sure that Varun will be able to get to it if we're aiming for mid-Q2. When do we think we need this by?
Flags: needinfo?(catlee)

Updated

2 years ago
Assignee: aki → mtabara

Updated

2 years ago
Blocks: 1277682

Updated

2 years ago
Blocks: 1282187
(Assignee)

Comment 7

2 years ago
I'd like to get my hands dirty on this bug as it seems to block a bunch of other people's work.

@Aki:
* in the lights of MozLondon conversations and direction shifts, is this something we want in the current form or are there any new ideas to take into consideration?
* with respect to the options selena mentioned in the description, is there a preferred one I should consider?

I'm trying to enrich the context here so any other piece of information is appreciated.
Thanks!
Flags: needinfo?(aki)
This would probably be a great use of scriptworker, where that scriptworker runs somewhere with network access to balrog.

Comment 9

2 years ago
This is scriptworker, which isn't finished (needs chain of trust support) but is usable.  I think that's enough to resolve this bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(aki)
Resolution: --- → FIXED

Comment 10

2 years ago
Hm, the generic tool is scriptworker, but it doesn't handle balrog atm.
This should be open for the script portion of balrog.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

2 years ago
No longer blocks: 1253309

Comment 11

2 years ago
:mtabara - :fkang is working on balrog-in-scriptworker; maybe talk with him to make sure you're not duplicating effort?
(Assignee)

Comment 12

2 years ago
Thanks for the heads-up Aki! I've got my hands dirty in some other stuff this week but I'll double check with :fkang before I'll jump back here. Thanks again for the update

Updated

2 years ago
Blocks: 1277871
Francis is working on this in bug 1277871 now, so this is effectively a dupe.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1277871
Blocks: 1306635

Updated

4 months ago
Blocks: 1411358

Updated

4 months ago
No longer blocks: 1411358
You need to log in before you can comment on or make changes to this bug.