Blackconnect doesn't build with mozilla trunk

RESOLVED WONTFIX

Status

Core Graveyard
Java to XPCOM Bridge
--
blocker
RESOLVED WONTFIX
17 years ago
4 years ago

People

(Reporter: Marcus Fellinger, Assigned: Igor Kushnirskiy)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Due to the following changes in mozilla, blackconnect currently doesn't build
with the trunk. The attached patch fixes these problems:

1. Use of REQUIRES in Makefile's
2. NS_IMPL_THREADSAFE_ISSUPORTS replaced by NS_IMPL_THRADSAFE_ISUPPORTS[0-9]
3. nsIEnumerator replaced with nsISimpleEnumerator
4. nsIComponentRegistrar interface
5. XPCOM-initialization changed (NS_InitXPCOM/NS_InitXPCOM2)
5. GetLastModificationDate changed to GetLastModifiedTime

The attached patch fixes these problems
(Reporter)

Comment 1

17 years ago
Created attachment 68726 [details] [diff] [review]
Patch to fix build problems for blackconnect

This patch fixes the build problems for the Java-to-XPCOM bridge. It depends on
the fixes to the xpidl-compiler in Bug #123651
(Reporter)

Updated

17 years ago
Depends on: 123651
-> NEW (contains a Patch)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

17 years ago
Blocks: 124610
(Reporter)

Updated

17 years ago
Blocks: 125593
(Reporter)

Updated

17 years ago
Keywords: patch
Keywords: review
(Reporter)

Updated

17 years ago
Blocks: 125652
Marcus: AFAIK you must mail the reviewers....
(Reporter)

Comment 4

17 years ago
Matti: I've now put it unto netscape.public.mozilla.java, and mailed
reviewers@mozilla.org, contributor-help@mozilla.org and drivers@mozilla.org.
I've also asked for help on #mozilla, and gervase markham said he would look
after it.

Do you think that would be enough?
that should be enough at the moment :-)

(Reporter)

Comment 6

17 years ago
CC'ing ashuk@eng.sun.com and joe.chou@eng.sun.com, as they are working on
blackwood and might be able to review the bug.
(Reporter)

Updated

17 years ago
Blocks: 128787
(Reporter)

Updated

17 years ago
Depends on: 127917

Comment 7

16 years ago
*** Bug 135348 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

16 years ago
Hi Ed,

After reading in n.p.m.java that you got webclient to build with the 0.9.9
branch, I decided to cc you to these bugs, because they are affected by your
changes.

Comment 9

15 years ago
Just posted a significant patch on bug 189098 addressing these issues.
Blackconnect no longer builds and hasn't been worked on since 2001.  -> WONTFIX
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.