TB 45.0b1 beta. Unable to "paste" text into the composition window. W7.32. V44.0b1 is fine

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
major
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Dickel, Unassigned)

Tracking

45 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:QuoteAndComposeManager])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

Copied text and link from web page.  Unable to paste either text or link into new email in Write window.  Control V does not paste either.


Actual results:

Nothing.  No further indication at all.


Expected results:

The text and/or link should have been pasted into the new email.  It pastes OK into other apps - Notepad, Word.
(Reporter)

Updated

2 years ago
Severity: normal → major
OS: Unspecified → Windows 7
Hardware: Unspecified → x86

Comment 1

2 years ago
I'm running 45. no trouble here.

does it happen for both plain text and formatted compose?  (hold SHIFT, click "write message")
does it also happen in safe mode?
 https://support.mozilla.org/en-US/kb/safe-mode-thunderbird?redirectlocale=en-US&redirectslug=safe-mode
anything in Tools | Error Console?
Component: Untriaged → Message Compose Window
Flags: needinfo?(jrichardnickel)
(Reporter)

Comment 2

2 years ago
Yes, it happens for both plain text and formatted compose.

It appears to work normally in safe mode.

(How do I copy/paste Error Console entries to you?)
Flags: needinfo?(jrichardnickel)
(Reporter)

Comment 3

2 years ago
Further.  After a message has been composed, clicking on "Sent" has no effect whatsoever - nothing happens.

Comment 4

2 years ago
Not happening in safe mode is an indicator that some addon or some setting is inteferring
(Reporter)

Comment 5

2 years ago
I now note that Lightning "is incompatible with Thunderbird 44.0" and has been disabled.  I'm certain that it was working prior to the installation of TB45.0b1.
Here's another user reporting problems with paste in TB 45 due to an add-on (QuoteAndComposeManager):
Bug 1247516 comment #12.
Please give us a list of all the add-ons you're using.

As for Lightning: It should have automatically updated to the version compatible with TB 45, that is Lightning 4.7. If not, download it here:
https://addons.mozilla.org/thunderbird/downloads/file/395996/lightning-4.7b1-sm+tb-windows.xpi?src=version-history or visit:
https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/?page=1#version-4.7b1
Summary: TB 45.0b1 beta. Unable to "paste" text into the "Write" window. W7.32. V44.0b1 is fine. Reverting. → TB 45.0b1 beta. Unable to "paste" text into the composition window. W7.32. V44.0b1 is fine
(Reporter)

Comment 7

2 years ago
(In reply to Jorg K (GMT+1) from comment #6)
> Here's another user reporting problems with paste in TB 45 due to an add-on
> (QuoteAndComposeManager):
> Bug 1247516 comment #12.
> Please give us a list of all the add-ons you're using.
> 
> As for Lightning: It should have automatically updated to the version
> compatible with TB 45, that is Lightning 4.7. If not, download it here:
> https://addons.mozilla.org/thunderbird/downloads/file/395996/lightning-4.7b1-
> sm+tb-windows.xpi?src=version-history or visit:
> https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/
> ?page=1#version-4.7b1

Disaabled all add-ons then added them back one at a time with restarts each time - leaving "QuoteAndComposeManager" until the last.  All previous add-ons worked normally - except QuoteAndComposeManager - which therefore appears to be the culprit.  Thanks for your assistance.

Do you still want a list of my add-ons?
No, thank you. Please contact the add-on author.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Updated

2 years ago
Whiteboard: [add-on:QuoteAndComposeManager]
Whiteboard: [add-on:QuoteAndComposeManager] → [addon:QuoteAndComposeManager]
You need to log in before you can comment on or make changes to this bug.