Closed Bug 1248465 Opened 4 years ago Closed 4 years ago

Restored chat tab may not have its tabmonitor set

Categories

(Thunderbird :: Instant Messaging, defect)

defect
Not set

Tracking

(thunderbird45 fixed, thunderbird46 fixed, thunderbird47 fixed)

RESOLVED FIXED
Thunderbird 47.0
Tracking Status
thunderbird45 --- fixed
thunderbird46 --- fixed
thunderbird47 --- fixed

People

(Reporter: aleth, Assigned: aleth)

References

Details

(Keywords: regression)

Attachments

(1 file)

Regression.
Blocks: 789450
Keywords: regression
Only part of this if clause depends on core.initialized.
Attachment #8719567 - Flags: review?(clokep)
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8719567 - Flags: review?(clokep) → review+
https://hg.mozilla.org/comm-central/rev/f4535b73ac7a8705c1370ef6f9bd4db05c0096ab
Bug 1248465 - Ensure chat tab monitor is registered even if chat core is not initialized yet. r=clokep
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 47.0
Comment on attachment 8719567 [details] [diff] [review]
Ensure chat tab monitor is registered even if chat core is not initialized yet

[Approval Request Comment]
Regression caused by (bug #): 789450
User impact if declined: potential glitches when switching to/from a chat tab restored on startup
Testing completed (on c-c, etc.): manual
Risk to taking this patch (and alternatives if risky): low
Attachment #8719567 - Flags: approval-comm-beta?
Attachment #8719567 - Flags: approval-comm-aurora?
Attachment #8719567 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 8719567 [details] [diff] [review]
Ensure chat tab monitor is registered even if chat core is not initialized yet

http://hg.mozilla.org/releases/comm-esr45/rev/915be9eb4ebd
Attachment #8719567 - Flags: approval-comm-beta? → approval-comm-beta+
Attachment #8719567 - Flags: approval-comm-beta+ → approval-comm-esr45+
You need to log in before you can comment on or make changes to this bug.