Closed Bug 12502 Opened 20 years ago Closed 20 years ago

View Source doesn't display non UTF-8 charsets on doc's w/o HTTP or Meta

Categories

(Core :: Internationalization, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: ftang, Assigned: jbetak)

References

Details

(Whiteboard: [PDT+])

Attachments

(1 file)

It work currently when the HTTP header charset present. We have a seperate bug
when the HTML Meta charset present (and assign to harishd). But we also need to
do this when only Deftault encoding is there.
Status: NEW → ASSIGNED
Summary: View Source does not display non ISO-8859-1 document when there are no HTTP nor Meta → View Source does not display non ISO-8859-1 document when there are no HTTP nor Meta
Target Milestone: M11
Mark this Assigned M11
Target Milestone: M11 → M12
mark M12
Target Milestone: M12 → M14
Summary: View Source does not display non ISO-8859-1 document when there are no HTTP nor Meta → View Source doesn't display non ISO-8859-1 charsets on doc's w/o HTTP or Meta
When we launch view source window. We should copy the charet of the docuemnt and 
set it as the default charset for the view-source window. I don't know how to 
pass that information. Reassign to jbetak to study.
Assignee: ftang → jbetak
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Keywords: beta1
Putting on PDT- radar for beta1.  Need for RTM, but would not hold for beta.
Whiteboard: [PDT-]
I don't think this is a beta stoper. We need to fix the charset menu for the 
view source. That is beta stopper. But I don't think this is a beta stoper. 
View source should be now in an acceptable shape for Beta1. We still don't 
transfer the current charset settings from the "parent" browser window to the 
view source webshell. I looked into the code and I think it might be saner to 
address this in the light of a "larger" solution. Both bug 27646 (transfer 
charset settings to new "child" webshells) and bug 21313 (document charset 
caching) might offer a very good way to solve the problem in a more general 
way, instead of layering even more view-souce-specific hacks...


Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
reopen bugs which have NOT YET FIXED yet.  
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Change the summary to "View Source doesn't display non UTF-8 charsets on doc's 
w/o HTTP or Meta" to reflect the reality. Currenlty View source fallback to 
UTF-8 not ISO-8859-1.

Move this bug to M15.
Summary: View Source doesn't display non ISO-8859-1 charsets on doc's w/o HTTP or Meta → View Source doesn't display non UTF-8 charsets on doc's w/o HTTP or Meta
Target Milestone: M14 → M15
*** Bug 23577 has been marked as a duplicate of this bug. ***
Requesting PDT+ status and permission to check-in a private fix for Beta1. The view source 
functionality is currently broken in a way that will be quite prohibitive to effective testing, 
problem tracking and will very likely significantly impact Beta support lines.

Currently, Seamonkey is not capable of displaying the source of a large percentage of web pages. 
On top of that any user interaction with the view source window will lead to a fall-back to regular
HTML page rendering instead of the HTML source.

Potential risks are limited to XML: if we missed something in our fix, the 
view source for XML instead of HTML documents might be broken
Status: REOPENED → ASSIGNED
Whiteboard: [PDT-]
Whiteboard: [PDT+]
Ok, next attemot to close this bug. The code changes are finally in. They should be in the nightly build on Feb 23.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
I verified this in 2000022308 Mac and Linux, and 200002309 Win32 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.