Sumo's ElasticSearch seems grumpy

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mythmon, Unassigned)

Tracking

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/2588] )

(Reporter)

Description

2 years ago
There has been a significant uptick in the amount of errors Sentry is reporting about Sumo's ES. For example, [0] is getting a 500 error when trying to get More Like This (MLT) results for articles.

Site search appears to still work, so this is not critical. It has thrown enough errors lately that Sentry has sent a "high alert volume" alert. So it would be nice to look in to.

[0]: https://sentry.prod.mozaws.net/operations/sumo/group/233374/

Updated

2 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/2588]

Comment 1

2 years ago
We had issues on this day restarting this cluster for glibc updates. For a while the cluster was in an odd state. This could be the cause of the errors you're seeing in Sentry.

Is this ongoing or was it just on the 22nd?
Flags: needinfo?(mcooper)
(Reporter)

Comment 2

2 years ago
I think that the problem has gone away now. I'm glad this aligns with some other problems.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mcooper)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.