Closed Bug 1251351 Opened 5 years ago Closed 5 years ago

Schedule Mn-e10s on Windows 7

Categories

(Infrastructure & Operations Graveyard :: CIDuty, task)

task
Not set
normal

Tracking

(e10s+)

RESOLVED FIXED
Tracking Status
e10s + ---

People

(Reporter: jgriffin, Assigned: jgriffin)

References

(Blocks 1 open bug)

Details

(Keywords: pi-marionette-server)

Attachments

(2 files, 1 obsolete file)

We'd like to schedule Mn-e10s (Marionette) on Windows 7, both opt and debug. First, we should verify that suite runs green there.
try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=8302286097ae

There are a couple of tests which fail consistently. Andreas, do you have time to look? Otherwise I can disable.
Flags: needinfo?(ato)
From a quick glance at the logs and the tests, they look fairly easy to fix.  Can I use your try syntax verify?
Flags: needinfo?(ato)
Depends on: 1251701
Component: General Automation → Buildduty
QA Contact: catlee → bugspam.Callek
(In reply to Andreas Tolfsen ‹:ato› from comment #2)
> From a quick glance at the logs and the tests, they look fairly easy to fix.
> Can I use your try syntax verify?

You'll need to apply the patch in this try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=8302286097ae

This just adds the --e10s flag to the in-tree configs.
Blocks: e10s-tests
tracking-e10s: --- → +
jgriffin: Mn-e10s appears to be passing on Windows 7 and Windows 8 now, following the integration of bug 1251701.
Attached patch Schedule Mn-e10s tests on win7, (obsolete) — Splinter Review
Attachment #8727131 - Flags: review?(catlee)
Attachment #8727133 - Flags: review?(catlee)
Attachment #8727131 - Attachment is obsolete: true
Attachment #8727131 - Flags: review?(catlee)
Builders added:
+ Windows 7 32-bit b2g-inbound debug test marionette-e10s
+ Windows 7 32-bit b2g-inbound opt test marionette-e10s
+ Windows 7 32-bit fx-team debug test marionette-e10s
+ Windows 7 32-bit fx-team opt test marionette-e10s
+ Windows 7 32-bit fx-team pgo test marionette-e10s
+ Windows 7 32-bit mozilla-central debug test marionette-e10s
+ Windows 7 32-bit mozilla-central opt test marionette-e10s
+ Windows 7 32-bit mozilla-central pgo test marionette-e10s
+ Windows 7 32-bit mozilla-inbound debug test marionette-e10s
+ Windows 7 32-bit mozilla-inbound opt test marionette-e10s
+ Windows 7 32-bit mozilla-inbound pgo test marionette-e10s
+ Windows 7 32-bit try debug test marionette-e10s
+ Windows 7 32-bit try opt test marionette-e10s
Attachment #8727133 - Flags: review?(catlee) → review+
Assignee: nobody → jgriffin
This got pushed out in a reconfig this afternoon and now I'm seeing failures like https://treeherder.mozilla.org/logviewer.html#?job_id=23186887&repo=mozilla-inbound on inbound. Are we needing something to land in-tree to get these working correctly? Should we hide them until they get fixed? Does this need backed out and re-reconfigged?
Flags: needinfo?(jgriffin)
Fascinating state of affairs - they are failing by running as non-mozharness tests. Somehow.

Hidden.
I'm high, it is running as mozharness, just not working. Still hidden, though, I got that right.
Attachment #8727985 - Flags: review?(catlee) → review+
Comment on attachment 8727985 [details] [diff] [review]
Add config file options for marionette-e10s on Windows,

https://hg.mozilla.org/build/buildbot-configs/rev/1ce5d30d8e7c
Flags: needinfo?(jgriffin)
Attachment #8727985 - Flags: checked-in+
These are running green now; sheriffs, can you please unhide?
Flags: needinfo?(sheriffs)
(In reply to Jonathan Griffin (:jgriffin) from comment #15)
> These are running green now; sheriffs, can you please unhide?

This is done.
Flags: needinfo?(sheriffs)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Product: Release Engineering → Infrastructure & Operations
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.