Closed Bug 1254316 Opened 4 years ago Closed 4 years ago

Black video problems when playing Facebook live streaming

Categories

(Core :: Plug-ins, defect)

Unspecified
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox46 --- verified

People

(Reporter: cpeterson, Unassigned, NeedInfo)

References

Details

Attachments

(1 file)

Someone at PCMag reported this problem. It sounds like a GPU driver issue.

Here is their about:support info:

             Application Basics
    Name 	Firefox
    Version 	44.0.2
    Build ID 	20160210153822
    Update History 	


Update Channel 	release
User Agent 	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Profile Folder 	

Enabled Plugins 	about:plugins
Build Configuration 	about:buildconfig
Memory Use 	about:memory
Registered Service Workers 	about:serviceworkers
Multiprocess Windows 	0/1 (default: false)
Safe Mode 	false
Crash Reports for the Last 3 Days
Report ID 	Submitted

All Crash Reports

This application has not been configured to display crash reports.
Extensions
Name 	Version 	Enabled 	ID
Graphics
Adapter Description	Intel(R) HD Graphics 4000
Adapter Drivers	igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
Adapter RAM	Unknown
Asynchronous Pan/Zoom	none
Device ID	0x0166
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.17568)
Driver Date	11-15-2013
Driver Version	9.18.10.3359
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	21f317aa
Supports Hardware H264 Decoding	Yes
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Important Modified Preferences
Name 	Value
browser.cache.disk.capacity	1048576
browser.cache.disk.filesystem_reported	1
browser.cache.disk.smart_size.first_run	false
browser.cache.frecency_experiment	4
browser.download.importedFromSqlite	true
browser.places.smartBookmarksVersion	7
browser.sessionstore.upgradeBackup.latestBuildID	20160210153822
browser.startup.homepage_override.buildID	20160210153822
browser.startup.homepage_override.mstone	44.0.2
browser.tabs.remote.disabled-for-a11y	true
dom.apps.reset-permissions	true
dom.mozApps.used	true
extensions.lastAppVersion	44.0.2
gfx.crash-guard.d3d11layers.appVersion	44.0.2
gfx.crash-guard.d3d11layers.deviceID	0x0166
gfx.crash-guard.d3d11layers.driverVersion	9.18.10.3359
gfx.crash-guard.d3d11layers.feature-d2d	true
gfx.crash-guard.d3d11layers.feature-d3d11	true
gfx.crash-guard.status.d3d11layers	2
gfx.crash-guard.status.d3d9video	2
gfx.direct3d.last_used_feature_level_idx	0
media.hardware-video-decoding.failed	false
network.cookie.prefsMigrated	true
places.history.expiration.transient_current_max_pages	104858
plugin.disable_full_page_plugin_for_types	application/pdf
privacy.sanitize.migrateClearSavedPwdsOnExit	true
user.js Preferences

Your profile folder contains a user.js file, which includes preferences that were not created by Firefox.
Important Locked Preferences
Name 	Value
JavaScript
Incremental GC 	true
Accessibility
Activated 	true
Prevent Accessibility 	0
Library Versions

	Expected minimum version	Version in use
NSPR	4.11	4.11
NSS	3.21 Basic ECC	3.21 Basic ECC
NSSSMIME	3.21 Basic ECC	3.21 Basic ECC
NSSSSL	3.21 Basic ECC	3.21 Basic ECC
NSSUTIL	3.21	3.21
hi Jeromie, someone reported that Facebook's live video streaming, which uses Flash and HLS, renders black video in Firefox. Chris Pearce (CC'd on this bug) was able to reproduce the problem by live streaming from the Facebook iPhone app (IIUC).

Presumably Facebook tested Flash live streaming on Firefox at some point, so which suggests this problem is a Flash and/or Firefox regression or a problem with the user's particular GPU (Intel(R) HD Graphics 4000).
The Intel 4000 HD is problematic.  The good news is that I ended up buying a few laptops with this chipset off eBay in order to arrive at that conclusion.  I can definitely have someone attempt to repro.

The thing that jumps out at me is that there are definitely newer drivers.  It would be good to know if they can still reproduce the problem with current drivers installed.
(In reply to Jeromie Clark from comment #2)
> The Intel 4000 HD is problematic.  The good news is that I ended up buying a
> few laptops with this chipset off eBay in order to arrive at that
> conclusion.  I can definitely have someone attempt to repro.

hi Jeromie, has your team been able to repro this Facebook video problem? Is there an mms.cfg setting to disable the GPU for Flash?

> The thing that jumps out at me is that there are definitely newer drivers. 
> It would be good to know if they can still reproduce the problem with
> current drivers installed.

Unfortunately, the reporter can't upgrade their GPU drivers from version 9.18.10.3359 (from 2013) to 15.33.42.4358 (from January 2016 [1]). Their Lenovo laptop has a proprietary Lenovo driver that the Intel driver updater refuses to overwrite.

[1] https://downloadcenter.intel.com/product/81499/Intel-HD-Graphics-4000-for-3rd-Generation-Intel-Core-Processors
cpearce: since you could repro the problem on your Lenovo W530, can you please test an older Firefox build (such as ESR 38) to verify whether this a Firefox NPAPI regression?
Flags: needinfo?(cpearce)
Our only recourse would be to blacklist this particular gpu and driver combination, but because the hardware is fairly widespread and the portion of content affected is pretty limited (this chipset landed in a lot of netbooks, which lack the capabilities to decode and render H.264 video in software with decent performance), so we felt like a blanket blacklist did more harm than good.

I would refer them instead to our video troubleshooting guide, which has instructions on how to disable Hardware Acceleration through the UI.  Making the changes in the UI makes it easier to revert them, should they find a workaround later. 

https://helpx.adobe.com/flash-player/kb/video-playback-issues.html

There is an mms.cfg setting (DisableHardwareAcceleration=1), but it's probably better to have end-users do this through the UI.  It's easier to have them check whether or not the box is ticked, should they ultimately resolve the driver issue.

http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/devnet/flashplayer/pdfs/flash_player_21_0_admin_guide.pdf

I haven't opened a bug on this yet, since it sounded like a driver problem.  I was hoping that the upgrade would work out for them. 

I have a W530 with an Intel 4000 handy, and ran into the same problem with the Intel update utility.  The test scenario is non-trivial and I'm on vacation until Monday, so I'm disinclined to mess around with it, but I was able to see some other content from Livestream without problems.

I'd recommend that they try toggling hardware acceleration in Flash as a first step.  If the issue doesn't go away, then it's not driver related.  I'd ask about anything that might interfere with JavaScript execution at that point (ad-blockers, anti-tracking plugins, etc).
Thanks, Jeromie. I'll pass along the information about the Hardware Acceleration UI.
Hi,

I just wanted to inform that I have EXACTLY the same problem but with GTX 570 GPU

I have tried disabling firefox and flash hw acceleration, reinstalling flash, deleting cookies & temp files but problem persist.  Chrome and other browser show the video just fine.
Here is my about:support


Grafiikka
---------

Ajureiden päiväys: 1-22-2016
Ajureiden versio: 10.18.13.6175
Alajärjestelmän tunnus: 15723842
Asynkronoitu siirto/lähennys: ei mitään
DirectWrite käytössä: false (6.3.9600.16384)
GPU #2 on käytössä: false
GPU:lla kiihdytettyjä ikkunoita: 0/1 Basic (OMTC)
Laitteen ajurit: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Laitteen kuvaus: NVIDIA GeForce GTX 570
Laitteen muisti: 1280
Laitteen tunnus: 0x1081
Myyjän tunnus: 0x10de
Tukee laitteistopohjaista H264-enkoodauksen purkua: No; Hardware video decoding disabled or blacklisted
WebGL-mallintaja: Google Inc. -- ANGLE (NVIDIA GeForce GTX 570 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Tärkeät muutetut asetukset
--------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 4
browser.download.importedFromSqlite: true
browser.download.manager.alertOnEXEOpen: true
browser.download.useDownloadDir: false
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20160315153207
browser.startup.homepage: www.google.fi
browser.startup.homepage_override.buildID: 20160315153207
browser.startup.homepage_override.mstone: 45.0.1
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.reset-permissions: true
dom.ipc.plugins.enabled.npietab2.dll: true
dom.max_script_run_time: 0
dom.mozApps.used: true
extensions.lastAppVersion: 45.0.1
font.internaluseonly.changed: true
gfx.crash-guard.d3d11layers.appVersion: 45.0.1
gfx.crash-guard.d3d11layers.deviceID: 0x1081
gfx.crash-guard.d3d11layers.driverVersion: 10.18.13.6175
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d9video: 2
gfx.crash-guard.status.glcontext: 2
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0
gfx.driver-init.deviceID: 0x1081
gfx.driver-init.driverVersion: 10.18.13.5906
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.gmp-eme-adobe.abi: x86-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1455302634
media.gmp-eme-adobe.version: 15
media.gmp-gmpopenh264.abi: x86-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1455302635
media.gmp-gmpopenh264.version: 1.5.3
media.gmp-manager.buildID: 20160315153207
media.gmp-manager.lastCheck: 1459345862
media.hardware-video-decoding.failed: false
media.webrtc.debug.aec_log_dir: C:\Users****\AppData\Local\Temp
media.webrtc.debug.log_file: C:\Users\***\AppData\Local\Temp\WebRTC.log
media.youtube-ua.override.to: 43
network.cookie.prefsMigrated: true
network.http.speculative-parallel-limit: 0
network.predictor.cleaned-up: true
network.prefetch-next: false
places.database.lastMaintenance: 1458953546
places.history.expiration.transient_current_max_pages: 84461
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.load_in_parent_process.application/ietab2: true
privacy.clearOnShutdown.passwords: false
privacy.cpd.downloads: false
privacy.cpd.formdata: false
privacy.cpd.history: false
privacy.cpd.sessions: false
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
services.sync.declinedEngines:
services.sync.engine.greasemonkey: true
services.sync.engine.prefs.modified: false
services.sync.lastPing: 1459345818
services.sync.lastSync: Wed Mar 30 2016 16:50:20 GMT+0300 (FLE Standard Time)
services.sync.numClients: 1
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1457047978
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Kirjastojen versiot
-------------------

NSPR
Odotettu minimiversio: 4.12
Käytössä oleva versio: 4.12

NSS
Odotettu minimiversio: 3.21.1 Basic ECC
Käytössä oleva versio: 3.21.1 Basic ECC

NSSSMIME
Odotettu minimiversio: 3.21.1 Basic ECC
Käytössä oleva versio: 3.21.1 Basic ECC

NSSSSL
Odotettu minimiversio: 3.21.1 Basic ECC
Käytössä oleva versio: 3.21.1 Basic ECC

NSSUTIL
Odotettu minimiversio: 3.21.1
Käytössä oleva versio: 3.21.1
(In reply to apomon from comment #7)
> I have tried disabling firefox and flash hw acceleration, reinstalling
> flash, deleting cookies & temp files but problem persist.  Chrome and other
> browser show the video just fine.

The issue needs to be fixed by nVidia or Adobe. Hopefully Facebook will move away from Flash.
Component: Audio/Video: Playback → Plug-ins
Closing out bug that has no planned next action.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
Hey I was directed to this link from Mozilla support. 
Could you please read the info I have posted on this link. 
https://support.mozilla.org/en-US/questions/1120068#answer-870222

I see you say this is something that needs fixed with nVidia and Adobe. I doubt facebook 
will move away from Flash since 100s of games on their are flashbased. Really big big games such as FarmVille, Candy Crush ect. 
So the problem at hand is your browser that does not work with their live streaming. If you read my response, you are going to lose 100s and 100s of people just because we are now using the Facebook platform to stream our live tours. People love cats, they love these cats, they want to see them live every day. We are getting more and more views every tour and many are saying they cant see the live vid on FF. Our answer use Chrome. Think maybe you should figure out some fix for this instead of just throwing it off on someone else?
hi Gena, sorry you are experiencing this black video problem. This is a known issue with Flash live streaming with some computer's graphics hardware. I don't know why Flash on Firefox is affected when Flash on Chrome works correctly. As you noted on the Mozilla Support website, the Facebook videos play correctly after the live streams have been saved. The saved videos use HTML5 video in Firefox instead of Flash.

Can you please share your Firefox Troubleshooting Information in this bug report? This information includes details about your computer's graphics hardware that will help us and Adobe diagnose the problem. Here are instructions for copy and pasting your Firefox Troubleshooting Information:

https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox
Flags: needinfo?(cpearce)
This has not to do with the GPU driver ! It has to do with the core of Firefox !
I have AMD RADEON HD 557O and plays in Google CHROME ! And I sure play in any browser that has similat engine like chrome ! And not play to browsers that have similar engine like firefox.
Firefox developers JUST FIX IT or admit that you don't plan to fix it and you are waiting to finish your new browser that is under development to come to the final stable version !
I made some syntax mistakes in my previous message but you got the point.
Yes I did all the usual things. First of all I am a web/graphic designer so keeping a clean cache is like 2nd nature. Actually making sure all unneeded files ect is second nature. I use windows defender firewall. I have never since owning a PC in 99 gotten a virus or malware. Do't have time for it. LOL
I do not have alot of addons the ones I had i disabled. No difference. Really my pc has the 3 browsers and design and video programs. I run a Malware scan ever day. Also have WOT so I never go to sites that are marked with a yellow or red dot. 
Graphics Card is pretty new. Its a Geforce GTX960. We are live streaming 2-3 times a day for an average of 30 mins. During the streaming people are chatting. We are having new people all the time come in and watch. We have an average of 500-700 people viewing at a time and at one time we had almost 2200. People are saying in chat, I have sound but a black video. We say what browser, their answer Firefox. We say switch to Chrome. They come back OMG I can see the cats. So this is from people all over the world with all kinds of computers ect. I have myself 4 different computers and none of them show live streaming on FF. Once the streaming is over and the video saves, you can watch the playback on FF, but not when its live. 

You know even if you are coming out with a new browser that will work with FB live streaming sooner or later, you know most people use 1 browser. Once they change to Chrome they usually wont bother coming back. For me if you decide not to fix it, its not going to effect me. I use whatever works. However people dont want to change browsers. You have no idea what we have heard since starting this live streaming a week ago and the people that used to watch us on Ustream on FF. OMG you would have thought changing browsers was like changing where you live. So for many many people in the world the browser they choose to use on their computers is a big big deal.
(In reply to Safereader from comment #14)
> This has not to do with the GPU driver ! It has to do with the core of Firefox !

I assure you that it is not a problem with Firefox. Please refer to comment 5 above. The instructions to disable hardware acceleration in Flash are:

"Right-click the Flash Player logo below and choose Settings from the context menu. Deselect Enable Hardware Acceleration (on the Display tab), and then click Close."
LOL Of course it has nothing to do with Firefox. We only have 100s of people that have told us after 1wk of live streaming that they can not view the live video on Firefox during live streaming. They can however view it on Chrome and IE, but sure it does not have anything to do with FF. For me as I said I could care less. We are just helping people move to chrome and 80% are deleting FF because they said they only need 1 browser. Your loss not mine. I only use it now because I have to check websites in all the main browsers. It was for a long time my default browser. 
If it was as simple as disabling hard ware acceleration there would not be a problem, so you can sit there with your head in the sand and think its not your problem. Anyways, as I said we are having no problems switching people to chrome so gl.
This is the second big problem I see in Firefox. Seem someone want move Firefox user to Chrome of different browser where this issue are not present.

But I know Chrome as also a very important issue for me so... please Firefox Team you should understand why the issue of this topic is only with Firefox.
Marco, when you are streaming live on Facebook and you have on average 500 or more watching and all the time new people coming in. They are saying I have black video but I can hear it. We are streaming live tour of a cat sanctuary. People want to see these cats. They dont care how but they want to see them. So they will change to chrome and think nothing of it. You know many people only use 1 browser so if they have to give up FF so they can see these cats everyday they are gonna do that.
And the crazy things is user are reporting this issue on Firefox and this topic has been marked as resolved.
I know. That is because they are making a new browser. Also because they are hoping that Facebook will eventually move away from Flash and then they wont have to do anything about fixing it anyways. I am not sure if FB will move away from flash considering the 1000s of games on there that are flash based. I dunno why they cant make it work the same way chrome does.
Gena I agree totally with you, you are right.
Spotify also use flash for play music. In this day I have an open issue with Internet connection but if once resolved I continue to listen music braked music on spoty this can be for another issue with Firefox and Flash.

The new browser seems will be called "Servo" who the meaning in the Italian is a very sad world. I don't like the name "Servo".

Very sad to see Firefox have many issue with Flash components.
At the moment Facebook live is working for me, right now.
They just had a update. They must have fixed something because it is working now.
Is working now in Firefox with the last update 46.0.1 (I wonder why they didn't offer this fix long time ago !) But is not working well. When you click to start the live video and after you right click there is no any menu (that appears normally in Google chrome) for "PAUSE , mute, show URL". So the only way to stop the LIVE video in Firefox is to refresh the page.
(In reply to Safereader from comment #27)
> Is working now in Firefox with the last update 46.0.1.

I don't see anything in the commit log. It is possible that Facebook changed something or Adobe updated the Flash blacklist. Is the issue still reproducible if you change back to 46.0.0?

(In reply to Marco from comment #24)
> I don't like the name "Servo".

I don't like the name either. "Servo" means service station in Australia. I used to live in Australia. It is a research project at this point in time and there are only a relatively small number of guys working on it. It will most likely get a proper product name when it becomes a thing. We can only hope.

> Very sad to see Firefox have many issue with Flash components.

YouTube switched to HTML5 video a year ago for non-DRM video. We're shipping Widevine in 47 which will complete their transition to HTML5 video on Firefox. We even rewrite YouTube object embeds to use iframes to help sites who have out of date YouTube embeds.

At least Facebook moved to HTML5 for inline video.
06/05/2016: Normal video posted on Facebook: when played I can hear only sound and the video is black.

I have discovered the cause in this case and was a recent update of NVDIA Driver made today without reboot the Pc.

After the PC rebook I was able to see the video, video was no more black. I don't know if the streaming issue is the same but maybe the issue is present if you had updated NVDIA driver and PC has not been restarted and you use Firefox.
Thanks for testing, Marco. That's great news about NVIDIA updating their driver.
Resolution: INCOMPLETE → WORKSFORME
Why people you stuck on the driver? !! THINK, millions users have different graphics cards NVIDIA, ATI, INTEL or other and to ALL of them happened the SAME thing with firefox version 46.0.0 and older.
I did NOT change my driver of my AMD and suddenly with the version Firefox 46.0.1 we were able to see Facebook live video !
In my message I don't want mean the NVDIA driver solved the issue. My message is for alert in my case, if the video driver is updated and PC not restarted the video on Facebook are black. That's all I know.
(In reply to Safereader from comment #31)
> I did NOT change my driver of my AMD and suddenly with the version Firefox
> 46.0.1 we were able to see Facebook live video !

Can you confirm that going back to 46.0.0 reintroduces the issue?
I uninstalled from programs control panel as usual the firfefox 46.0.1.
I installed 46.0 and play normally facebook live video !
I uninstalled 46 and installed 45 and again play normally !!
Something changed that day when appeared 46.0.1 Maybe was a coincidence and Facebook changed something.
But still has not the same function like google chrome. I can not pause the live video in Firefox without reloading the page.
@Stefereader have you updated video driver recently?
No. I have long time to change driver. Ans is the latest update.
And is very annoying that I can't edit my earlier posts here to make corrections !
Attached image t.png
And something strange. When you are not loggout from Facebook in firefox and try to just put a facebook page with live video it play but also with right click it show options MENU !! something that is not enabled when you are inside Facebok (login) !!
So when you are logged out you see a big menu as you can see in my attached picture ! How this is happening? !!
correction in first sentence "When you are not loggout from Facebook" change to 
"When you are loggout from Facebook..."
Anyone tried facebook live via firefox beta ? is it working ?
I am also impacted by this and have heard from many others.

If it works in all browsers but Firefox, it is not someone else's driver problem!
i have that bug too !
only on firefox
Anyone tried it in firefox beta ?
¡Hola!

Ended up here via https://support.mozilla.org/questions/1131189 > https://support.mozilla.org/questions/1120068

FWIW on https://support.mozilla.org/questions/1131189 the reporter says that this works on https://www.mozilla.org/firefox/developer/

Kindly confirm if that's the case for you too.

¡Gracias!
Flags: needinfo?(safepeponi)
Flags: needinfo?(bogus)
Blocks: 1295667
You need to log in before you can comment on or make changes to this bug.