Closed Bug 1255970 Opened 5 years ago Closed 4 years ago

crash in java.lang.NullPointerException: Attempt to invoke virtual method ''int java.lang.String.indexOf(java.lang.String)'' on a null object reference at org.mozilla.gecko.toolbar.ToolbarDisplayLayout.updateFromTab(ToolbarDisplayLayout.java)

Categories

(Firefox for Android :: General, defect)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1255767
Tracking Status
firefox46 --- unaffected
firefox47 --- fixed
firefox48 --- fixed
fennec 48+ ---

People

(Reporter: kbrosnan, Assigned: sebastian)

References

Details

(Keywords: crash, regression)

Crash Data

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

This bug was filed from the Socorro interface and is 
report bp-324a95bf-6802-4c31-81e9-0659e2160310.
=============================================================

java.lang.NullPointerException: Attempt to invoke virtual method 'int java.lang.String.indexOf(java.lang.String)' on a null object reference
	at org.mozilla.gecko.toolbar.ToolbarDisplayLayout.updateFromTab(ToolbarDisplayLayout.java:213)
	at org.mozilla.gecko.toolbar.BrowserToolbar.onTabChanged(BrowserToolbar.java:496)
	at org.mozilla.gecko.Tabs$5.run(Tabs.java:674)
	at android.os.Handler.handleCallback(Handler.java:739)
	at android.os.Handler.dispatchMessage(Handler.java:95)
	at android.os.Looper.loop(Looper.java:145)
	at android.app.ActivityThread.main(ActivityThread.java:5942)
	at java.lang.reflect.Method.invoke(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:372)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1399)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1194)

Mfg.       Model     And. API    CPU ABI    #      
oneplus   ONE A2001   22 (REL)  armeabi-v7a  9  25.0%
samsung   SM-N900T    21 (REL)  armeabi-v7a  6  16.7%
motorola  Moto G      23 (REL)  armeabi-v7a  5  13.9%
oneplus   A0001       23 (REL)  armeabi-v7a  4  11.1%
asus      ASUS_Z00AD  21 (REL)  x86          4  11.1%
This looks like bug 1255767.
Assignee: nobody → s.kaspari
See Also: → 1255767
Yep, that's the same issue. I'm going to fix that in bug 1255767.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1255767
tracking-fennec: ? → 48+
Sebastian, Margaret: This bug is currently the top crasher on Aurora 47. It's resolved a dup of bug 1255767 which is fixed in 48 with 47 unaffected. What resolution are we planning for it for 47? Do we need to uplift the fix to aurora to address this top crasher or is a different fix needed for Aurora? Please let me know.
Flags: needinfo?(s.kaspari)
Flags: needinfo?(margaret.leibovic)
(In reply to Ritu Kothari (:ritu) from comment #3)
> Sebastian, Margaret: This bug is currently the top crasher on Aurora 47.
> It's resolved a dup of bug 1255767 which is fixed in 48 with 47 unaffected.
> What resolution are we planning for it for 47? Do we need to uplift the fix
> to aurora to address this top crasher or is a different fix needed for
> Aurora? Please let me know.

I'll leave it to Sebastian to clarify, but maybe it was a mistake that that bug was marked as 47 unaffected? We should uplift that fix if it's needed on 47.
Flags: needinfo?(margaret.leibovic)
bug 1250671 was uplifted and people did not check the dependent bugs as part of the uplift. Moving the NI to the dupe.
Flags: needinfo?(s.kaspari)
Yes, this should definitely be uplifted. I'll request it in bug 1255767.
You need to log in before you can comment on or make changes to this bug.