Closed Bug 1256221 Opened 4 years ago Closed 3 years ago

Remove close button from addon install notification

Categories

(Toolkit :: Add-ons Manager, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla55
Tracking Status
firefox45 --- wontfix
firefox46 --- wontfix
firefox47 --- wontfix
firefox48 --- wontfix
firefox-esr38 --- unaffected
firefox52 --- wontfix
firefox53 --- wontfix
firefox54 --- fix-optional
firefox55 --- verified

People

(Reporter: cpeterson, Assigned: aswan)

References

Details

(Whiteboard: [door hanger] triaged)

Attachments

(1 file)

STR:
1. Load https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/
2. Click the page's "Add to Firefox" button.
3. If necessary, click the "Allow" button on the "Firefox prevented this site from asking you to install software on your computer." door hanger.
4. When the "This site would like to install an add-on" door hanger appears, click the page to dismiss the the door hanger WITHOUT clicking the door hanger's "Install" or "Cancel" buttons.
5. Click the page's "Add to Firefox" button again.

RESULT:
The "This site would like to install an add-on" door hanger will open briefly and then disappear. You can no longer install the add-on from this page. If you open the Add-ons Manager, you will see two placeholder entries (with status "Downloaded") for the add-on that was not installed.

This bug might be a dupe of bug 622960 or bug 1207350.
Agree this is an issue and a pain point - but a very big bug of overall door-hanger issue.  We will have to take these all at once.

we've fixed as many simply as we could - and are putting these under main bug for future. bug 1171636
Blocks: 1171636
Priority: -- → P4
Whiteboard: [door hanger] triaged
Priority: P4 → P3
I will be the first to agree that this is not intuitive, but in the original STR, there should still be a puzzle piece icon on the left side of the location bar, clicking on that will bring back the Cancel/Install popup and let you proceed.
However, due to a bunch of work in the elm project, we can now make this even better without much trouble.  That popup is now persistent so stray clicks won't cause it to be dismissed.  There's still a close button on the popup but I think we should get rid of it, which the attached patch does.  Markus, does this seem okay?
eh Markus is refusing needinfo requests, I'll try to collar him in Hawaii, I think this should be uncontroversial.
Duplicate of this bug: 1207350
Assignee: nobody → aswan
Whoops, I sat on this patch for a long time and forgot about it.  I don't think any tests are needed for this...
Attachment #8816240 - Flags: review?(florian)
Comment on attachment 8816240 [details]
Bug 1256221 Remove close button from addon install popup

https://reviewboard.mozilla.org/r/97036/#review121472

No reason to show the 'x' button here. Could you please rephrase the bug summary to make this less confusing?
Attachment #8816240 - Flags: review?(florian) → review+
Summary: Can't install add-on after dismissing "site would like to install an add-on" door hanger by clicking page → Remove close button from addon install notification
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2cf99777eb0d
Remove close button from addon install popup r=florian
https://hg.mozilla.org/mozilla-central/rev/2cf99777eb0d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Verified as fixed on Firefox 55.0a1 (2017-03-17) under Windows 10 64-bit, Ubuntu 16.04 32-bit and Mac Os X 10.12.1. “X” button is no longer displayed in installation pop-ups: https://www.screencast.com/t/XzimtWmYDJr .
Status: RESOLVED → VERIFIED
(In reply to Julien Cristau [:jcristau] from comment #12)
> Is this worth uplifting to 54?  It's been there forever, otoh it's a one
> liner.

I'm inclined to just let it ride the trains unless somebody else feels very strongly.
We probably don't need to uplift to 54. This bug is less likely to happen in 54 than earlier versions because the door hanger has been redesigned. Clicking the page does not accidentally dismiss the door hanger and leave it in a bad state. The user can still enter the bad state by clicking the door hanger's X button, but I expect that few users will do that because the new door hanger design's Install and Cancel buttons are now very prominent.
You need to log in before you can comment on or make changes to this bug.