Closed Bug 1171636 Opened 5 years ago Closed 3 years ago

Allow displaying multiple simultaneous add-on installs

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1319732
Tracking Status
firefox41 --- affected

People

(Reporter: mossop, Unassigned)

References

Details

Doorhanger notifications don't allow for multiple notifications of the same ID which is how the add-on install notifications work now. This causes problems like bug 1163973.

We should change this so that for a given browser there is at most a single add-on install notification and then inside that display a box for each on-going install for that browser. This would include displays for in-progress, awaiting confirmation, complete or failed installs. The xpinstall disabled/blocked notifications can probably remain as they are for now.
Flags: qe-verify+
QA Contact: vasilica.mihasca
Duplicate of this bug: 1174684
Blocks: 1184296
Duplicate of this bug: 1202411
Duplicate of this bug: 1238364
Depends on: 1256221
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1319732
You need to log in before you can comment on or make changes to this bug.