Re-enable APZ on beta

RESOLVED FIXED in Firefox 46

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

({feature})

48 Branch
mozilla48
All
Unspecified
feature
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 wontfix, firefox46 fixed, firefox47 fixed, firefox48 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1253667 +++

It was decided that, after doing the first few 46 beta builds with APZ off, we would turn it back on in beta4 for a couple of betas, and then the e10s experiment in 46 beta would end.

So basically this bug is to back out bug 1253667 and land it on beta for 46.0b4. See bug 1253667 comment 11 as well.
status-firefox46: --- → affected
status-firefox47: --- → affected
Created attachment 8731250 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: APZ
[User impact if declined]: APZ won't be enabled in beta for the e10s+APZ experiment
[Describe test coverage new/current, TreeHerder]: all the APZ stuff
[Risks and why]: This was discussed in the e10s cross-functional
[String/UUID change made/needed]: none
Attachment #8731250 - Flags: review?(felipc)
Attachment #8731250 - Flags: approval-mozilla-beta?
Attachment #8731250 - Flags: approval-mozilla-aurora?
kats, just to be clear, we plan to disable e10s on Beta 46 after the e10s+APZ experiment ends, which will implicitly disable APZ (regardless of the value of the APZ pref). Is that still the plan?
status-firefox45: --- → wontfix
Flags: needinfo?(bugmail.mozilla)
Yes, I agree with that.
Flags: needinfo?(bugmail.mozilla)
Keywords: feature
Whiteboard: [gfx-noted]
Comment on attachment 8731250 [details] [diff] [review]
Patch

OK to turn on apz by default for aurora and beta.
This should make it into beta 4.
Attachment #8731250 - Flags: approval-mozilla-beta?
Attachment #8731250 - Flags: approval-mozilla-beta+
Attachment #8731250 - Flags: approval-mozilla-aurora?
Attachment #8731250 - Flags: approval-mozilla-aurora+
Comment on attachment 8731250 [details] [diff] [review]
Patch

Review of attachment 8731250 [details] [diff] [review]:
-----------------------------------------------------------------

please hold off landing on beta until we get agreement at the meeting tomorrow, and also because I want to make sure this only gets into the right beta and not earlier. If you want to land on aurora sooner, go ahead.
Attachment #8731250 - Flags: review?(felipc) → review+
I'll land this on inbound/aurora/beta once bug 1247854 and it's dependencies is safely on beta. I'll be around this weekend and can do it then if needed.
I verified bug 1247854 is fixed on the build that has the uplift, so I landed the APZ-enabling patch:

https://hg.mozilla.org/releases/mozilla-aurora/rev/6d030cb1d2ab
https://hg.mozilla.org/releases/mozilla-beta/rev/02bdd0469632

Looks like the tag for FIREFOX_46_0b2_BUILD3, FIREFOX_46_0b2_RELEASE already happened so this will be in beta 3 as discussed during the meeting. I hope that's the right beta, not sure if plans are changing because of the updates being turned off.
status-firefox46: affected → fixed
status-firefox47: affected → fixed

Comment 9

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a20759d13c93
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox48: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
:kats, i assume this was expected?  please confirm, or outline the next steps.
Flags: needinfo?(bugmail.mozilla)
Yeah, this is expected. APZ is not riding to release on 46; we are tracking the regressions on Nightly and fixing them there.
Flags: needinfo?(bugmail.mozilla)
You need to log in before you can comment on or make changes to this bug.