[Tracker] Implement custom recipe management interface

RESOLVED FIXED

Status

()

Firefox
Normandy Server
RESOLVED FIXED
2 years ago
5 months ago

People

(Reporter: mkelly, Assigned: bstoroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
It's time to graduate out of the Django admin and build our own custom management interface for the User Advocacy folks to use for managing recipes on Normandy.

We probably want to do this by writing APIs and having the frontend use those APIs as opposed to a traditional approach like what the Django admin uses. We also have a fair amount of freedom with regards to what the interface should look like, as long as it is able to do all the things the current Recipe admin can do.

Specifically, we want to implement what is currently in the admin under the Recipe model and the Classifier Preview page. The rest of the Django admin can stay where it is.
(Assignee)

Updated

2 years ago
Assignee: nobody → bstoroz
Status: NEW → ASSIGNED

Comment 1

2 years ago
Commit pushed to master at https://github.com/mozilla/normandy

https://github.com/mozilla/normandy/commit/6c4409c59d32fd859d51c9d9eccac78d27bd7278
Merge pull request #95 from brittanystoroz/control-admin

[Bug 1257267] Add new control admin
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1266474
(Assignee)

Updated

2 years ago
Depends on: 1266479
(Assignee)

Updated

2 years ago
Summary: Implement recipe management interface outside of the Django admin → [Tracker] Implement custom recipe management interface
Component: SHIELD → General
Product: Websites → Normandy
(Reporter)

Updated

2 years ago
Component: General → Service
(Assignee)

Updated

2 years ago
Depends on: 1271272
(Reporter)

Updated

2 years ago
Depends on: 1271276
(Reporter)

Updated

2 years ago
Depends on: 1271278
(Reporter)

Updated

2 years ago
Depends on: 1275658
(Reporter)

Updated

2 years ago
Blocks: 1280176
All blockers fixed, wooh!
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

5 months ago
Product: Shield → Firefox
You need to log in before you can comment on or make changes to this bug.