[DOGFOOD][FEATURE] Window size and position should be remembered

VERIFIED DUPLICATE of bug 16516

Status

P2
normal
VERIFIED DUPLICATE of bug 16516
20 years ago
14 years ago

People

(Reporter: phil, Assigned: waterson)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

20 years ago
I just heard hyatt say that he could save DOM elements such as window size and
position persistently, to apply to the next session. Please find out how this
works and plug it into mail/news.

This is definitely not a dogfood issue, and I think it's borderline for beta.
(Reporter)

Updated

20 years ago
Blocks: 10791

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Comment 1

20 years ago
hyatt, can you point us at a doc?

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 2

20 years ago
nevermind, I learned about the persist= stuff
Checking in my fixes tonight.

Updated

20 years ago
Status: RESOLVED → REOPENED

Updated

20 years ago
Resolution: FIXED → ---

Comment 3

20 years ago
hrm. This doesn't seem to actually be working. it's not even writing it to my
localstore.rdf
reopening

Updated

20 years ago
Status: REOPENED → ASSIGNED

Comment 4

20 years ago
rjc or waterson, can you just look at
http://lxr.mozilla.org/seamonkey/source/mailnews/base/resources/content/messenger.xul
and tell me what we're doing wrong?

When I persist the "state" attribute of the "splitter" element below, it works
fine.

Updated

20 years ago
Summary: [FEATURE] Window size and position should be remembered → [DOGFOOD][FEATURE] Window size and position should be remembered

Comment 5

20 years ago
This is dogfood, particularly since the default window size isn't wide enough to
show a 72-column wide message like our old mailer sends, and that bug (13346)
isn't going to be fixed.

Updated

20 years ago
Blocks: 12176

Comment 6

20 years ago
For now, added 12176 which is the dogfood tracking bug to the dependency list.

Updated

20 years ago
Blocks: 11091
No longer blocks: 12176

Comment 7

20 years ago
actually, I added the wrong dependency.  I am going to add the the beta tracking
bug instead.

Comment 8

20 years ago
waterson/rjc/hyatt: I still can't get the messenger window to remember the
height, width, x, or y attributes.
Can you take a look at my xul (URL link above) and see if you see anything out
of the ordinary?
Alec, look in mozilla/xpfe/components/bookmarks/resources/bookmarks.js.
Basically, the bookmark's tree has an onunload() handler which sets the x, y,
height and width attributes when the onunload() fires, and they persist due to
being tagged to do so in the XUL.

Persisting the "state" of the splitter works, I'm guessing, because the splitter
widget updates the "state" attribute directly, but windows don't currently do so
with the other properties, you have to set them by hand

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED

Comment 10

20 years ago
robert, you rock. thanks.
Checking in the fix.

Comment 11

20 years ago
The mail window still doesn't remember either its size or the position of its
panes (I think the pane position is a separate bug on the splitter).  What do I
need to do to get my mail sizes to be remembered?
Pray (if you are a believer) or send cash (if you're a realist).  :^)

Updated

20 years ago
Status: RESOLVED → REOPENED

Comment 13

20 years ago
Reopening ...

BTW, what's the bug on remembering the sizes of the various panes?  "Needs
splitter" (7410) doesn't mention anything about saving positions, and "Mailnews
needs reasonable pane sizes" (13346) was marked as fixed on the theory that you
could resize the panes and their positions would be remembered (with a pointer
to this bug, which seems to be only on the main window size).
(Assignee)

Comment 14

20 years ago
This probably means that the XULDocument has been leaked. Somebody set a
breakpoint in XULDocumentImpl::~XULDocumentImpl and verify that the destructor
runs.

Updated

20 years ago
Resolution: FIXED → ---

Comment 15

20 years ago
Clearing FIXED resolution due to reopen.

Comment 16

20 years ago
When I exit from the mail window, XULDocumentImpl::~XULDocumentImpl called 10
times.  I have tried removing localstore.rdf several times, in case it was a dup
of that problem, but that didn't help.
(Reporter)

Updated

20 years ago
Summary: [DOGFOOD][FEATURE] Window size and position should be remembered → [FEATURE] Window size and position should be remembered
(Reporter)

Comment 17

20 years ago
Removing [dogfood] from bug summary

Updated

20 years ago
Blocks: 13346

Updated

20 years ago
Summary: [FEATURE] Window size and position should be remembered → [DOGFOOD][FEATURE] Window size and position should be remembered

Comment 18

20 years ago
Putting [DOGFOOD] back in summary.

Updated

20 years ago
Depends on: 13120

Comment 19

20 years ago
Adding depends on 13120.

Updated

20 years ago
Depends on: 15775

Updated

20 years ago
Whiteboard: [PDT-]

Comment 20

20 years ago
Sorry...putting on PDT- radar

Updated

19 years ago
Status: REOPENED → ASSIGNED
Priority: P3 → P2

Comment 21

19 years ago
mass-moving bugs I can't fix for M11 to M12
(Reporter)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 22

19 years ago
Worksforme

Comment 23

19 years ago
Really, it works on Windows?  It definitely does not (never has) on Linux.
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 24

19 years ago
I just tried it on Windows, and it didn't work there either (with a build from
this morning): I ran mozilla -mail, resized the window bigger, exited the app
via the File menu, then ran mozilla -mail again, and the window was the default
size, not the size I had chosen.

What is it that's working for you, Phil?
(Reporter)

Comment 25

19 years ago
The width and height of the three pane window are remembered for me, although
screen position is not.

Moving to M13. Predicate bugs are marked M15 and M13 :-(

Comment 26

19 years ago
How do you quit the app so that the window size is remembered?  This doesn't
work for me even on Windows, and I'd love to quit once in the right way so that
it would remember these things.
(Reporter)

Updated

19 years ago
Target Milestone: M12 → M13
(Reporter)

Comment 27

19 years ago
I tried both File | Quit and closing all the windows, and both work for me.

Comment 28

19 years ago
*** Bug 18422 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: alecf → waterson
Status: REOPENED → NEW

Comment 29

19 years ago
This isn't a mail/news bug anyway; it's true of every window in the product.  I
hear that some people sometimes see size remembered, and that this is a waterson
thing (reassigning), but it never works for me on Linux or NT.  I find that on
Linux, the browser and mail windows (but not the editor window) save their
default size in localstore.rdf, and I can edit those by hand and get the sizes I
want; on NT, no sizes for any window are put into localstore.rdf so there's
nothing to edit.

If I spend some time figuring out the format, I may be able to figure out how to
add in sizes for the other windows which don't save entries themselves; but I
don't think this is something the average user is going to be able to do.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Assignee)

Comment 30

19 years ago
*** This bug has been marked as a duplicate of 16515 ***
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
(Assignee)

Comment 31

19 years ago
*** This bug has been marked as a duplicate of 16516 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 32

19 years ago
Mark it Verified/dup.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.