"View Selection Source" throws TypeError: args is null Source File: chrome://global/content/viewPartialSource.js

RESOLVED FIXED in seamonkey2.45

Status

defect
--
major
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: hhofer42, Assigned: philip.chee)

Tracking

SeaMonkey 2.40 Branch
seamonkey2.45
Unspecified
Windows 7
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.41? affected, seamonkey2.42? fixed, seamonkey2.43+ fixed, seamonkey2.44+ fixed, seamonkey2.46+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build ID: 20160120202951

Steps to reproduce:

Select text from a web page and select "View Selection Source" from the context menu.


Actual results:

An empty window opens and the following is logged in the error console:

> Error: TypeError: args is null
> Source File: chrome://global/content/viewPartialSource.js
> Line: 20


Expected results:

A window showing the partial HTML-source should have opened.

I'm almost sure this still worked in SeaMonkey 2.39

Comment 1

3 years ago
Probably DUP of "Bug 1203395 - [window mode] View Selection Source fails"

@Reporter: Thank you for your attention. 
Please feel free to reopen this Bug if you find out that the fix for the other bug does not solve your problem or if you see other well founded indication that you fond an independent bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1203395
Reporter

Comment 2

3 years ago
Sorry, but I don't think bug 1203395 fixed the issue for SeaMonkey.

I can see the changes from https://hg.mozilla.org/releases/mozilla-aurora/rev/d6f44c82219b ,
and the error mentioned in bug 12093395#c0 is different.

So, on the contrary, I think this issue is a _consequence_ of the fix for this bug.
(Probably the part with "let args = window.arguments[0]" instead of "let args = window.arguments" in "viewPartialSource.js")

It affects SeaMonkey 2.40 as well as the latest available nightly (2.45a1, Build ID: 20160308001946) under Win 7.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

3 years ago
(In reply to H. Hofer from comment #2)
> So, on the contrary, I think this issue is a _consequence_ of the fix for
> this bug.
Indeed! 
I will do some additional investigation in the evening.

Comment 4

3 years ago
Steps how to reproduce with en-US SeaMonkey 2.40 final Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) from official download page,  Gecko/20100101  Firefox/ 43.0  Build 20160120202951, (Classic Theme) on German WIN7 64bit:

0. 'Launch Browser to show this page → Launch Error Console'
1. Select (highlight) first paragraph of oritinal report here
2. 'Rightclick → View selection source'
   Bug: Empty window will be opened instead of Window showing selections source
   Error Console: as reported

Works fine with FF 48.0a1 (2016-03-27)

It seems that fix for "Bug 1203395 - [window mode] View Selection Source fails " does not work here, but causes additional problem?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Windows 7
See Also: → 1203395

Comment 5

3 years ago
Still REPRODUCIBLE with  English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  on German WIN7 64bit.

Probably 2.41 ... 2.44 also are affected.

Comment 6

3 years ago
A previously existing capability is now broken without any acceptable workaround.  Thus, this is a Major bug, not a Normal bug.
Severity: normal → major
Assignee

Updated

3 years ago
Depends on: 1203395, 1134585
Assignee

Updated

3 years ago
Summary: "View Selection Source" throws TypeError → "View Selection Source" throws TypeError: args is null Source File: chrome://global/content/viewPartialSource.js
Assignee

Comment 7

3 years ago
Posted patch Working patch WIP (obsolete) — Splinter Review
This patch fixes the error. Now doing a build to confirm.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Assignee

Comment 8

3 years ago
This is a minimal fix for the view selection source. Enhancements and other fancy stuff can wait for another patch. Meanwhile we need to get this into all branches.
Attachment #8736805 - Attachment is obsolete: true
Attachment #8736916 - Flags: review?(iann_bugzilla)
Assignee

Updated

3 years ago
Duplicate of this bug: 1261700

Comment 10

3 years ago
Comment on attachment 8736916 [details] [diff] [review]
Patch v1.0 simplified fix

[Triage Comment]
a/r=me for c-c
a=me for c-a/c-b
a=me for esr if required
Attachment #8736916 - Flags: review?(iann_bugzilla)
Attachment #8736916 - Flags: review+
Attachment #8736916 - Flags: approval-comm-beta+
Attachment #8736916 - Flags: approval-comm-aurora+
Assignee

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Duplicate of this bug: 1320881
You need to log in before you can comment on or make changes to this bug.