Closed Bug 12649 Opened 21 years ago Closed 21 years ago

Popup on personal toolbar does not popup.

Categories

(Core :: XUL, defect, P1, blocker)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: slamm, Assigned: waterson)

References

Details

Click on a folder on the personal toolbar. You get a message like,

***creating XUL popup at 1018 597

But, it never comes up. This happens on NT and Linux with my debug builds from
today.
Blocks: 11899
Priority: P3 → P1
guys, i'm thinking this is a dup of either bug 11304 or bug 11583. what say ye?
This might be a dup of 11304. The popups were working after that bug was filed
though, so I am a little confused.
i remember popups were working most of the time, but crashed some of the
time because of some missing infrastructure. because the implementation
wasn't complete, somebody removed the display of popups pending
completion of the (re)implementation.
Blocks: 12670
Assignee: hyatt → slamm
reassigning to slamm. Hyatt fixed popups, he needs to fix XUL file.
Status: NEW → ASSIGNED
waterson may have to extend the template rules to make this work.
Assignee: slamm → waterson
Status: ASSIGNED → NEW
slamm: i'm gonna steal this bug from you for a bit...
Status: NEW → ASSIGNED
Depends on: 11822
Target Milestone: M11
This, ah, now works, sort of. Modulo bug 11822. Once 11822 is fixed, this
should "just be okay". As it is now, you need to click on a folder in the
personal toolbar about three times to get it to show up.
Depends on: 11266
Whiteboard: implemented; waiting on dependencies to mark as fixed
Also adding a dependency on 11266, because a menu that is popped up from the
personal toolbar won't dismiss _at all_ until you pick something from it. If
that's a different bug, we can open it later.
*** Bug 13086 has been marked as a duplicate of this bug. ***
Severity: normal → blocker
upgrading to blocker for beta.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
QA Contact: phillip → cpratt
assigning Pratt as QA contact
I'm unsure as how I can verify this one as fixed. I am guessing that folders on
the personal toolbar are currently Bookmarks and Channels; clicking on either
one does absolutely nothing in the 1999092909 build under NT. Could someone
please give me a clue? Thanks.
Whiteboard: implemented; waiting on dependencies to mark as fixed → QA needs help with verification
Status: RESOLVED → VERIFIED
Whiteboard: QA needs help with verification
fine in the 1999101109 build, NT
You need to log in before you can comment on or make changes to this bug.