Closed Bug 1265509 Opened 4 years ago Closed 4 years ago

[e10s] [APZ] Artifacts, flickering and stuttering while scrolling + jumpy scroll bar

Categories

(Core :: Panning and Zooming, defect, major)

48 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla48
Tracking Status
e10s + ---

People

(Reporter: Virtual, Assigned: kats)

References

Details

(Keywords: nightly-community, regression, Whiteboard: [gfx-noted] [fixed by patches from bug #1265806 and bug #1260018])

Attachments

(3 files)

The fastest way to reproduce it is:
1. enable "Bookmark Toolbar"
2. add to it http://www.wykop.pl/ and http://www.4chan.org/
3. open http://www.wykop.pl/
4. scroll the page a few times from top to bottom
5. open http://www.4chan.org/ in background tab by moving it to Navigation Toolbar
6. scroll a few more times http://www.wykop.pl/ by mouse scroll and scroll bar to enjoy artifacts

It's also reproducible (but harder) on https://imgur.com/ while scrolling infinitely, next leaving it in background for a few minutes, while browsing other tabs. Going back and scrolling produces similar results.
Looks like you're seeing a little bit of checkerboarding up in the upper right after 4chan loads. kats can you triage this one?
Flags: needinfo?(bugmail.mozilla)
Yeah as far as I can tell this looks like just regular checkerboarding. The tab in the background is probably eating up cycles on the main thread which makes the checkerboarding more likely.

If you go to about:checkerboard, can you find a checkerboard log with a matching timestamp, copy the raw log from the bottom textarea, and attach it to this bug?
Flags: needinfo?(bugmail.mozilla) → needinfo?(bernesb)
Whiteboard: [gfx-noted]
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #4)
> Yeah as far as I can tell this looks like just regular checkerboarding. The
> tab in the background is probably eating up cycles on the main thread which
> makes the checkerboarding more likely.
The issue is still present even after background tab finished loaded.

(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #4)
> If you go to about:checkerboard, can you find a checkerboard log with a
> matching timestamp, copy the raw log from the bottom textarea, and attach it
> to this bug?
I'm seeing nothing in about:checkerboard or maybe I don't know how to use or start it (play button doesn't do anything).
Flags: needinfo?(bernesb)
Summary: [e10s] Artifacts, flickering and stuttering while scrolling → [e10s] Artifacts, flickering and stuttering while scrolling + jumpy scroll bar
Hm, that shows that you have no checkerboard reports. Just to confirm, did you go to about:checkerboard right after reproducing the problem? The checkerboard reports are not persisted after browser restarts.

If that's the case, then it means what you were seeing was not checkerboarding, and was probably some other kind of graphics glitch. In that case, can you turn off APZ and see if it still happens?
Flags: needinfo?(bernesb)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> Hm, that shows that you have no checkerboard reports. Just to confirm, did
> you go to about:checkerboard right after reproducing the problem? The
> checkerboard reports are not persisted after browser restarts.
Yes. I go to about:checkerboard right after reproducing the problem.

(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> If that's the case, then it means what you were seeing was not
> checkerboarding, and was probably some other kind of graphics glitch. In
> that case, can you turn off APZ and see if it still happens?
Setting "layers.async-pan-zoom.enabled" to "false" in about:config to disable APZ fixes the issue.
Component: Graphics → Panning and Zooming
Flags: needinfo?(bernesb)
Summary: [e10s] Artifacts, flickering and stuttering while scrolling + jumpy scroll bar → [e10s] [APZ] Artifacts, flickering and stuttering while scrolling + jumpy scroll bar
Ok. Another question: in the screencast it looks like initially you are scrolling using the mousewheel and there's a little bit of flickering. Then you scroll by dragging the scroll thumb, and there's jumpy behaviour. Is that correct? The second part (jumpy behaviour) is likely the same as bug 1265806 or bug 1265983, which were relatively recent regressions. It's hard to tell from the video if there are other issues that don't fall into these two categories - if there, can you try to describe them (or point to a timestamp in the video that I should look at)?
Yes. It's exactly like you written.

-First part of the video:
from 0:14 to 0:23 - I scroll with the mouse scroll wheel and some white artifacts flickers and stutters in the top of the screen

-Second pare of the video:
from 0:23 to 0:34 - I scroll using mouse with the scroll bar and scroll bar is being jumpy
Thanks for confirming. I'm hoping the jumpiness will be fixed by the patch I just posted to bug 1265806. I'm not sure what to do about the white artifact flickering. It might be related to bug 1265873, but that's a total shot in the dark.
Actually, if you have some time, it would be useful to get a regression window on the flickering issue, if it started happening after APZ was turned on in bug 1157745.
Flags: needinfo?(bernesb)
Flags: needinfo?(bernesb)
Version: Trunk → 48 Branch
I'm not able to reproduce this and there's nothing actionable here right now, so I'm closing this. Feel free to reopen if you can still reproduce it on a recent Nightly and can track down a regression window or are able to run a custom build with logging.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → VERIFIED
Has Regression Range: --- → yes
Has STR: --- → yes
Depends on: 1265806, 1260018
Flags: needinfo?(Virtual)
Resolution: INCOMPLETE → FIXED
See Also: 1265806, 1260018
Whiteboard: [gfx-noted] → [gfx-noted] [fixed by patches from bug #1265806 and bug #1260018]
You need to log in before you can comment on or make changes to this bug.