Thunderbird: Unable to drag and drop attachments to OS file folder - caused by Core::DOM:Events

RESOLVED FIXED in Firefox 48

Status

()

Core
DOM: Events
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Jorg K (GMT+2), Assigned: Neil Deakin (not available until Aug 9))

Tracking

({regression})

Trunk
mozilla49
regression
Points:
---

Firefox Tracking Flags

(firefox48 fixed, firefox49 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

a year ago
Since bug 270292 we were able to drag multiple attachment to an OS folder.
This feature is in TB 45 and it works.

I am using TB 48.0a1 (2016-04-24) Daily and I can't even drag a single attachment any more.

So something went bust somewhere.

Alice, can you find a regression window for us?
(Reporter)

Comment 1

a year ago
Alice, just try to drag a single attachment from a message onto the desktop or some other folder.
Thanking you in advance.
Flags: needinfo?(alice0775)

Comment 2

a year ago
Regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0891f0fa044cba28024849803e170ed7700e01e0&tochange=fc15477ce628599519cb0055f52cc195d640dc94
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=aaf73ae87441&tochange=a5f12c8dc64f

Suspect Bug 860857, Bug 1226977
Flags: needinfo?(alice0775)

Updated

a year ago
Flags: needinfo?(enndeakin)
Created attachment 8745008 [details] [diff] [review]
Add extra drag promise types to whitelist

Can you check if this patch fixes things?
Flags: needinfo?(enndeakin)
(Reporter)

Comment 4

a year ago
Thanks, Neil. I will check this in the next few hours.

Comment 5

a year ago
(In reply to Neil Deakin from comment #3)
> Created attachment 8745008 [details] [diff] [review]
> Add extra drag promise types to whitelist
> 
> Can you check if this patch fixes things?

I confirmed in a local win32 build that the attached patch (comment 3) fixes the problem.
(Reporter)

Comment 6

a year ago
Thanks, my VS2013 build is currently broken, I need to download VS2015 (7GB) first. I'll get to it tomorrow (midnight here now).
Keywords: regressionwindow-wanted
(Reporter)

Updated

a year ago
Component: Attachments → DOM: Events
Product: MailNews Core → Core
(Reporter)

Comment 7

a year ago
Created attachment 8745249 [details] [diff] [review]
Add extra drag promise types to whitelist (made it apply)

Neil, thanks for the patch. As Alice already said in comment #5, this fixes the problem.

However, the patch didn't apply due to some white-space issues. I'll attach my version. Can you please get this reviewed and landed and also back-ported to FF 48 (Aurora) since the problem was caused there.
Attachment #8745008 - Attachment is obsolete: true
Attachment #8745249 - Flags: feedback+
(Reporter)

Updated

a year ago
Flags: needinfo?(enndeakin)
(Reporter)

Updated

a year ago
Summary: Unable to drag and drop attachments to OS file folder → Thunderbird: Unable to drag and drop attachments to OS file folder - caused by Core::DOM:Events
(Reporter)

Comment 8

a year ago
Created attachment 8745255 [details] [diff] [review]
Add extra drag promise types to whitelist (made it apply)

Oops, mis-edited that. Now it's right.
Attachment #8745249 - Attachment is obsolete: true
Attachment #8745255 - Flags: feedback+
Comment on attachment 8745255 [details] [diff] [review]
Add extra drag promise types to whitelist (made it apply)

Windows and Mac use these types to specify the url and filename of downloads.
Flags: needinfo?(enndeakin)
Attachment #8745255 - Flags: review?(bugs)

Updated

a year ago
Attachment #8745255 - Flags: review?(bugs) → review+
(Reporter)

Updated

a year ago
Keywords: checkin-needed
(Reporter)

Comment 10

a year ago
Neil, looks like the sheriffs haven't picked it up. Their rules also are the a try run needs to be attached. Can you simply push it to inbound. Thanks.
Flags: needinfo?(enndeakin)

Comment 11

a year ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/54b1f93e6b73
Keywords: checkin-needed
(Reporter)

Comment 12

a year ago
OK, done.
Flags: needinfo?(enndeakin)

Comment 13

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/54b1f93e6b73
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox49: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
(Reporter)

Comment 14

a year ago
Comment on attachment 8745255 [details] [diff] [review]
Add extra drag promise types to whitelist (made it apply)

Approval Request Comment
[Feature/regressing bug #]: Bug 860857
[User impact if declined]: Drag and drop of files from the Firefox download list (comment #9) or from Thunderbird's message attachment area to an operation system folder won't work.
[Describe test coverage new/current, TreeHerder]: Manual test only.
[Risks and why]:
This was broken recently just before the branch day (Apr 25, 2016), so it should be fixed in the same cycle of bug that broke it.
[String/UUID change made/needed]: None.
Attachment #8745255 - Flags: approval-mozilla-aurora?
(Reporter)

Updated

a year ago
Assignee: nobody → enndeakin

Updated

a year ago
Duplicate of this bug: 1269378
(Reporter)

Comment 16

a year ago
Gentle ping to get this landed on Aurora (and bug 1267612, too).
Flags: needinfo?(lhenry)
Comment on attachment 8745255 [details] [diff] [review]
Add extra drag promise types to whitelist (made it apply)

Fix for drag and drop from Downloads, it's been in nightly a while, OK to uplift to aurora.
Flags: needinfo?(lhenry)
Attachment #8745255 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 18

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/1769f2f6230e
status-firefox48: affected → fixed
You need to log in before you can comment on or make changes to this bug.