Missing space in composer_help.xhtml

RESOLVED FIXED in seamonkey2.59

Status

defect
P5
trivial
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: RainerBielefeldNG, Assigned: rsx11m.pub)

Tracking

(Blocks 1 bug)

Trunk
seamonkey2.59
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.49esr fixed, seamonkey2.57esr fixed, seamonkey2.58 fixed, seamonkey2.59 fixed)

Details

(Whiteboard: [easyconfirm][good first bug])

Attachments

(3 attachments)

Steps how to reproduce  NOT reproducible REPRODUCIBLE with  English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  on German WIN7 64bit:

1. Browser → F1
   » Help appears
2. Type search string "Working with Lists" → Click hit "Working with Lists"
   » Related Help appears
3. Search page for "Enterto"
   Bug: Will be found
  
Wrong:   "Enterto"
Correct: "Enter to"
I can't find this at http://hg.mozilla.org/l10n-central/de/file/9cde891b3a44/suite/chrome/common/help/composer_help.xhtml which should be the right place. Are you translating whatever you see in your version to English "Enterto" or is this verbatim what you see? That page appears to be fully translated and hasn't been touched for the last three years, thus shouldn't show anything in English.
(In reply to rsx11m from comment #1)
Ah, so you are not using the localized version after all, thus it should be composer_help.xhtml at the usual comm-central place. The "NOT reproducible REPRODUCIBLE with  English SeaMonkey 2.45a1" remark in your opening description is a bit confusing, something got mixed up there.
(In reply to rsx11m from comment #3)
REPRODUCIBLE with  en-US SeaMonkey 2.40 final Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) from official download page,  Gecko/20100101  Firefox/ 43.0  Build 20160120202951, (Classic Theme) on German WIN7 64bit

In all my tests it did not matter whether I use an dn-US Language pack or a basic en-US Build.
Thanks for the clarification.
The issue seems to be hidden within "OS-dependent help texts" (more or less). I see source:
<li>Press <kbd>Shift</kbd>+<kbd class="mac">Return</kbd><kbd
    class="noMac">Enter</kbd>to create the hanging indent.</li>

Simply a blank missing before "to create ..."?
Hello, Can I work on this? Can someone assign this to me?
You can simply start to work if you don't have permissions yet - someone with permissions will change Status or similar "due to facts" later.

As a first step you should try to reproduce the problem and leave a comment with your results like Bug 1258900 comment#1. So we can get this one to "NEW" or whatever else depending on your result.
A good manual for bug triage you can find here: <https://wiki.mozilla.org/SeaMonkey/QA/Triage_HowTo>
The only difference is that, when a bug is assigned to you, you can change fields yourself.
For example, set the status from UNCONFIRMED to ASSIGNED when you've reproduced the issue.
Assignee: nobody → ajain2
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build identifier: 20160120202951

Is it ok to change the status to "NEW" ?
NEW due comment 10
Status: UNCONFIRMED → NEW
Ever confirmed: true
TRUNK because of unknown/irrelevant appearance of issue
ASSIGNED due to Comment 9
Status: NEW → UNCONFIRMED
Ever confirmed: false
Version: SeaMonkey 2.45 Branch → Trunk
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
@Akshay Jain:
Do you already have a plan for your next step?
I tried with en-US Language pack for SeaMonkey 2.39: a blank left from "to" does the job.
I don't know where help can be found in native en-US-build
(In reply to rsx11m from comment #3)
> Ah, so you are not using the localized version after all, 
The Helpxxxxx.xhtml have the same names in all languages, what eases handling, but is a little worrying. Normally I check build in help of native en-US version (mostly 2.45a1) and a Language pack (currently: 2.41a1).

> The "NOT reproducible REPRODUCIBLE with  English SeaMonkey 2.45a1" remark 
> in your opening
Yes, copy/paste is some more difficult than I thought ;-)
(In reply to rsx11m from comment #3)
> thus it should be composer_help.xhtml at the usual comm-central place.


A simple google Search for "class="noMac">Enter</kbd>to create the hanging indent.</li>" lead me to <http://hg.mozilla.org/releases/l10n/mozilla-beta/lt//rev/5a45c6567c36>, where the missing space before the "to" is visible.

I have no experience or knowledge how to use Mercurial
(In reply to Rainer Bielefeld from comment #16)
> A simple google Search for "class="noMac">Enter</kbd>to create the hanging
> indent.</li>" lead me to
> <http://hg.mozilla.org/releases/l10n/mozilla-beta/lt//rev/5a45c6567c36>,
> where the missing space before the "to" is visible.

which arbitrarily sent you to the Latvian translation...
Use http://mxr.mozilla.com/comm-central to search within the en-US sources.

> I have no experience or knowledge how to use Mercurial

Always a good time to learn new things!  :-)
Are you still working on this, Akshay?
Flags: needinfo?(ajain2)
Seems not to be the case
Assignee: ajain2 → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(ajain2)
Hardware: Unspecified → All
Summary: composer_help.xhtml: Typo → Missing space in composer_help.xhtml
Posted patch Simple fixSplinter Review
Since Rainer B. doesn't want to fix it himself, here is the patch.  ;-)
I went briefly through all XHTML files and didn't find any other instances.
Assignee: nobody → rsx11m.pub
Status: NEW → ASSIGNED
Attachment #8975171 - Flags: review?(iann_bugzilla)
Comment on attachment 8975171 [details] [diff] [review]
Simple fix

I love stealing complex reviews :)

Maybe asking for uplift to 52 and 60? Typo in en-US only.
Attachment #8975171 - Flags: review?(iann_bugzilla) → review+
Comment on attachment 8975171 [details] [diff] [review]
Simple fix

[Approval Request Comment]
String changes made by this patch: Help changes only, requesting for en-US

Thanks - there is no "approval‑comm‑esr60" yet, thus please confirm in comment.

comm-central-seamonkey is currently closed due to build backlog, thus I'll push that for trunk later once it reopens.
Attachment #8975171 - Flags: approval-comm-esr52?
Attachment #8975171 - Flags: approval-comm-beta?
Pushed by rsx11m.pub@gmail.com:
https://hg.mozilla.org/comm-central/rev/8b6a20172920
Missing space in composer_help.xhtml; r=frg
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Comment on attachment 8975171 [details] [diff] [review]
Simple fix

a=me for beta and esr60
Attachment #8975171 - Flags: approval-comm-esr52?
Attachment #8975171 - Flags: approval-comm-esr52+
Attachment #8975171 - Flags: approval-comm-beta?
Attachment #8975171 - Flags: approval-comm-beta+
Target Milestone: --- → Seamonkey2.59
You need to log in before you can comment on or make changes to this bug.