Closed Bug 1268302 Opened 8 years ago Closed 8 years ago

4.05 - 38.55% glterrain (linux64, windowsxp) regression on push 18d290be0df2e10e8904451d16f2b9aaf936974e (Wed Apr 27 2016)

Categories

(Core :: Graphics: CanvasWebGL, defect, P2)

49 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
e10s + ---
firefox49 --- fixed

People

(Reporter: wlach, Assigned: ethlin)

References

(Blocks 1 open bug)

Details

(Keywords: perf, regression, Whiteboard: [talos_regression])

Attachments

(1 file)

Talos has detected a Firefox performance regression from push 18d290be0df2e10e8904451d16f2b9aaf936974e. As author of one of the patches included in that push, we need your help to address this regression.

This is a list of all known regressions and improvements related to the push:

https://treeherder.mozilla.org/perf.html#/alerts?id=1036

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see:

https://wiki.mozilla.org/Buildbot/Talos/Tests#glterrain

Reproducing and debugging the regression:

If you would like to re-run this Talos test on a potential fix, use try with the following syntax:

try: -b o -p linux64,win32 -u none -t g1[Windows XP],g1-e10s[Windows XP] --rebuild 5  # add "mozharness: --spsProfile" to generate profile data

(we suggest --rebuild 5 to be more confident in the results)

To run the test locally and do a more in-depth investigation, first set up a local Talos environment:

https://wiki.mozilla.lorg/Buildbot/Talos/Running#Running_locally_-_Source_Code

Then run the following command from the directory where you set up Talos:

talos --develop -e [path]/firefox -a glterrain

(add --e10s to run tests in e10s mode)

Making a decision:

As the patch author we need your feedback to help us handle this regression.
*** Please let us know your plans by Monday, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations:

https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Flags: needinfo?(ethlin)
This is only a regression for non-accel layers, so let's leave it in and fix it.
Assignee: nobody → ethlin
No longer blocks: 1250954
Component: Untriaged → Canvas: WebGL
Depends on: 1250954
Product: Firefox → Core
Version: unspecified → 49 Branch
Okay, I will check this issue.
Flags: needinfo?(ethlin)
tracking-e10s: --- → ?
In bug 1250954, I added CloneSurface when surfaceClient has a mismatched forwarder. I should skip the surfaceClient without forwarder since the surfaceClient is just created and it will do InitIPDL correctly.
I also use AsCompositableForwarder to do the forwarder comparison. It should be a better way.
Attachment #8746987 - Flags: review?(jgilbert)
Blocks: 1267562
Blocks: e10s-perf
Priority: -- → P2
Attachment #8746987 - Flags: review?(jgilbert) → review+
The talos test on try server still got similar scores. 
*With this bug's patch: 
https://treeherder.mozilla.org/#/jobs?repo=try&revision=efe26a40b2e0&selectedJob=20534029&filter-searchStr=talos
The glterrain test on Linux x64 opt is 18.53. 

So I removed the patch in bug 1250954 and try again.
*Remove all patches:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=efe26a40b2e0&selectedJob=20534029&filter-searchStr=talos
The glterrain test on Linux x64 opt is 18.44. 

The two scores are almost the same and I think before regression this test's score should be about 24. Is the regression windows wrong?
Flags: needinfo?(wlachance)
18 is without the regression. It then regressed to 24. Also, your two links are identical.
(In reply to Avi Halachmi (:avih) from comment #6)
> 18 is without the regression. It then regressed to 24. Also, your two links
> are identical.

I see. I misunderstanded the number. Thanks.
Flags: needinfo?(wlachance)
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4f85ccb14c7a
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
some winxp wins here:
https://treeherder.mozilla.org/perf.html#/alerts?id=1133

the linux stuff has odd patterns, waiting for the trees to open to collect more data and figure out what is going on.
linux stuff is fixed, the pattern appears to be infrastructure related, but I can decipher it now that I have more data.
You need to log in before you can comment on or make changes to this bug.