Closed Bug 1268881 Opened 4 years ago Closed 4 years ago

Kill hard abort in the child with (msgtype=0x7,name=???) Route error: message sent to unknown actor ID

Categories

(Core :: DOM: Content Processes, defect, critical)

x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1255823
Tracking Status
e10s + ---
firefox47 --- affected
firefox48 --- fixed
firefox49 --- fixed

People

(Reporter: jimm, Unassigned)

References

Details

(Keywords: crash)

Crash Data

Blocks: e10s-crashes
#1 top crasher, there are multiple stacks.

https://crash-stats.mozilla.com/search/?product=Firefox&version=47.0b1&signature=%3DWaitForMultipleObjectsEx+%7C+RealMsgWaitForMultipleObjectsEx+%7C+mozilla%3A%3Awidget%3A%3AWinUtils%3A%3AWaitForMessage+%7C+nsAppShell%3A%3AProcessNextNativeEvent&signature=%3DBaseGetNamedObjectDirectory+%7C+RealMsgWaitForMultipleObjectsEx+%7C+mozilla%3A%3Awidget%3A%3AWinUtils%3A%3AWaitForMessage+%7C+nsAppShell%3A%3AProcessNextNativeEvent&_facets=signature&_columns=date&_columns=platform&_columns=ipc_channel_error#crash-reports
Crash Signature: [@ WaitForMultipleObjectsEx | RealMsgWaitForMultipleObjectsEx | mozilla::widget::WinUtils::WaitForMessage | nsAppShell::ProcessNextNativeEvent] → [@ WaitForMultipleObjectsEx | RealMsgWaitForMultipleObjectsEx | mozilla::widget::WinUtils::WaitForMessage | nsAppShell::ProcessNextNativeEvent] [@ BaseGetNamedObjectDirectory | RealMsgWaitForMultipleObjectsEx | mozilla::widget::WinUtils::WaitForMessage |…
There are multiple signatures beyond those I've listed.
The parent side is dispatching an async message which errors out so this is going to show up all over the place in in the content process.

http://bsmedberg.github.io/socorro-toolbox/html/multiple-minidumps.html?crashID=56054d5b-51ae-40ad-abe1-954f02160428
fyi, you're going to be seeing these all over the place in 47b1.
This was in 47.a1, 47.a2, and 47.b1. The earliest report in nightly and aurora for the top two signatures which appear to be unique is 20160224030246.

20160223030304
https://hg.mozilla.org/mozilla-central/rev/789a12291942763bc1e3a89f97e0b82dc1c9d00b

20160224030246
https://hg.mozilla.org/mozilla-central/rev/5b2baa5e9356644a7ed0b73e422eaff62e159ffb

possible regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=789a12291942763bc1e3a89f97e0b82dc1c9d00b&tochange=5b2baa5e9356644a7ed0b73e422eaff62e159ffb
Bug 1174624 - "Add the Transferable parameter into SendAsyncMessage of nsFrameMessageManager" looks interesting.
Duplicate of this bug: 1265812
Duplicate of this bug: 1265814
Pulling crash data from the start of the 47 cycle I'm finding a few crash reports prior to 2-24. I need to look at all of the top ten or so, see what the earliest data is. Will post back.
new query using about 8 of the top signatures, searching across 47.a1 to try and find a regression range:

possible date this was introduced: 20160218030349

https://crash-stats.mozilla.com/search/?product=Firefox&ipc_channel_error=0x7&version=47.0a1&date=%3E2016-01-01&signature=~js%3A%3ANukeCrossCompartmentWrappers&signature=~BaseGetNamedObjectDirectory+%7C+RealMsgWaitForMultipleObjectsEx+%7C+mozilla%3A%3Awidget%3A%3AWinUtils%3A%3AWaitForMessage+%7C+nsAppShell%3A%3AProcessNextNativeEvent&signature=~WaitForMultipleObjectsEx+%7C+RealMsgWaitForMultipleObjectsEx+%7C+mozilla%3A%3Awidget%3A%3AWinUtils%3A%3AWaitForMessage+%7C+nsAppShell%3A%3AProcessNextNativeEvent&signature=~WaitForSingleObjectEx+%7C+WaitForSingleObject+%7C+PR_WaitCondVar+%7C+mozilla%3A%3ACondVar%3A%3AWait&signature=~ntdll.dll%400x4d3fa&signature=~ntdll.dll%400x4d96a&signature=~ntdll.dll%400xa5bd4&signature=~ntdll.dll%400x4df6a&signature=~GetProcessHeap&_facets=signature&_facets=version&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#crash-reports

20160217062621
https://hg.mozilla.org/mozilla-central/rev/709f559b5406e8555cf84dd09bdc747b076f142c

20160218030349
https://hg.mozilla.org/mozilla-central/rev/1150ac4755c7bb35df4fc7504f6f1b6c257f400e

20160219030248
https://hg.mozilla.org/mozilla-central/rev/9166484e331b685c8b7027bedcf328421029ac59

20160223030304
https://hg.mozilla.org/mozilla-central/rev/789a12291942763bc1e3a89f97e0b82dc1c9d00b

20160224030246
https://hg.mozilla.org/mozilla-central/rev/5b2baa5e9356644a7ed0b73e422eaff62e159ffb


2-17 -> 2-18:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=709f559b5406e8555cf84dd09bdc747b076f142c&tochange=1150ac4755c7bb35df4fc7504f6f1b6c257f400e

2-17 -> 2-24 (wide):
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=709f559b5406e8555cf84dd09bdc747b076f142c&tochange=5b2baa5e9356644a7ed0b73e422eaff62e159ffb
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1255823
bug 1255823 was backed out of beta, kats is looking at it. We go to beta 2 build monday afternoon. if it doesn't make that ithen our next opportunity will be on friday.
See Also: → 1265812
Crash Signature: [@ WaitForMultipleObjectsEx | RealMsgWaitForMultipleObjectsEx | mozilla::widget::WinUtils::WaitForMessage | nsAppShell::ProcessNextNativeEvent] [@ BaseGetNamedObjectDirectory | RealMsgWaitForMultipleObjectsEx | mozilla::widget::WinUtils::WaitForMessage |… → [@ IPCError-browser | (msgtype=0x7,name=???) Route error: message sent to unknown actor ID ] [@ WaitForMultipleObjectsEx | RealMsgWaitForMultipleObjectsEx | mozilla::widget::WinUtils::WaitForMessage | nsAppShell::ProcessNextNativeEvent] [@ BaseGetNamedO…
You need to log in before you can comment on or make changes to this bug.