Main window display breaks when moving between HiDPI and LowDIP Display

RESOLVED DUPLICATE of bug 1266354

Status

RESOLVED DUPLICATE of bug 1266354
3 years ago
3 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

45 Branch
Unspecified
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

3 years ago
Created attachment 8747671 [details]
03_hover_over_ui.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.86 Safari/537.36

Steps to reproduce:

Reproducible with: latest Thunderbird 45 Nightly (BuildID: 20160501030200)
Reproducible on: Mac OS X 10.11.4, with a MacBook Pro Retina 15-inch, Mid 2014, and one or two secondary monitors connected via DisplayPort. 

Steps to reproduce:
1. Start Thunderbird on any monitor (A = lowDPI)
2. Move Thunderbird window to another Monitor (B = hiDPI/Retina)
3. Hover over UI-Elements (B - see 03_hover_over_ui.png)
4. Resize the Thunderbird window on monitor (B)
5. Move Thunderbird window back monitor (A)
6. Resize the Thunderbird window monitor (A)


Actual results: moving the window causes content to zoom in/out, causing buttons to disappear and rendering the window almost unusable.



Actual results:

Moving the window between the monitors breaks the UI and makes it look weird. The UI is not usable anymore, until the window is being resized.


Expected results:

Moving the window between monitors should not affect its UI.
(Reporter)

Comment 1

3 years ago
Created attachment 8747673 [details]
01_start_on_lowdpi.png
(Reporter)

Comment 2

3 years ago
Created attachment 8747674 [details]
02_move_to_highDPI.png
(Reporter)

Comment 3

3 years ago
Created attachment 8747675 [details]
04_resize_highDPI.png
(Reporter)

Comment 4

3 years ago
Created attachment 8747676 [details]
05_move_to_lowDPI.png
(Reporter)

Comment 5

3 years ago
Created attachment 8747677 [details]
06_resize_on_low_DPI.png
(Reporter)

Comment 6

3 years ago
Created attachment 8747679 [details]
thunderbird_UI problems_480p.mov

Attached short screen recording of one of the screens (Retina/hiDPI) showing the broken main window.

Comment 7

3 years ago
thanks for reporting.
this is being tracked in bug 1266354
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
OS: Unspecified → Mac OS X
Resolution: --- → DUPLICATE
Duplicate of bug: 1266354
(Reporter)

Comment 8

3 years ago
Didn't saw that one when i was searching for similar issues. Sorry for the dup.
You need to log in before you can comment on or make changes to this bug.