Closed Bug 1270578 Opened 6 years ago Closed 1 year ago

cs_nav_prefs_navigator.xhtml: Typo "Editmenu"

Categories

(SeaMonkey :: Help Documentation, defect)

Unspecified
All
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RainerBielefeldNG, Assigned: nunojsg)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.3)

Attachments

(4 files)

Steps how to reproduce  with  English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  on German WIN7 64bit:

1. Browser → F1
   » Help appears
2. Type search string "Browser Preferences" → Click hit 
   "Browser Preferences"
   » Related Help appears
3. Click TOC "History"
   Bug: Listing below in item 1. dontains word "Editmenu", what is 
        uncommon. All other paragraphs use "Edig menu"

b) Suggestion for Fix: replace "Editmenu" by "Edit menu"
Summary: cs_nav_prefs_navigator.xhtml: Mentioned "Sidebar Advanced Search Mode" does not exist → cs_nav_prefs_navigator.xhtml: Typo "Editmenu"
Can I work on this? Could you assign it to me?
Sure, thanks!
Assignee: nobody → ajain2
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Hello, Could you help me get started or tips on how to resolve it?
I am newbie here. Thanks
As a minimum, you will need the sources from "comm-central" which is a Mercurial repository. For instructions how to get started, see https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Simple_SeaMonkey_build (depending on your platform). If you are on Linux, you should find everything needed in your distro's repository.

For simple changes like this one, you probably don't need a full build. You could just get the sources, make the change, then create the patch. However, it's always a good idea to double-check that what you've done actually yields the intended result (which sometimes it doesn't).

The code specific to SeaMonkey is in the suite/ directory on the top level of the repository. It contains a folder locales/ which has all labels and texts for the English versions (all other languages have their individual repositories).

See https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/How_to_Submit_a_Patch for a general description of the process. Once you are ready to submit a patch, follow the steps in (even though the red banner at the top of this page says it's outdated) https://developer.mozilla.org/en-US/docs/Mercurial/Using_Mercurial#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F and attach the patch here for review.

Hope this helps and isn't too overwhelming yet. :-)
Thanks a lot for this. I appreciate it. I will start working on it.
You are welcome. Another useful resources to just browse and search the code is http://mxr.mozilla.org/comm-central/ which allows you to find specific files or text snippets you are looking for.
This source code might be a little worrying vbecause there is some OS dependent switch in that area:

c) Source  cs_nav_prefs_navigator.xhtml (does NOT work)
<ol>
  <li>Open the <span class="mac">&brandShortName;</span>
    <span class="noMac">Edit</span> menu and choose Preferences.</li>
 
d) Source  nav_help.xhtml (DOES work)
<ol>
  <li>Open the
    <span class="mac">&brandShortName;</span><span class="noMac">Edit</span>
    menu and choose Preferences.</li>

At least I currently do not understand why 'c' does not work bud 'd' does
@ Akshay Jain:
"Bug 1268031 - composer_help.xhtml: Typo" alos might be such a "lost or missing blank" issue.
Hello Rainer, I will work on Bug 1268031 too.
JFTR: We have suite/locales/en-US/chrome/common/help/helpFileLayout.css which should import mozilla/toolkit/components/help/content/platformClasses.css (that's where the platform-specific classes are defined). I don't see any reason why that shouldn't work.

The difference between 'c' and 'd' is that 'd' has a new line after the "noMac" span element.
User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build identifier: 20160120191716

Verified it on Macintosh where it have text "SeaMonkey Menu"
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build identifier: 20160120202951

Verified it on Windows version. It says "Editmenu". I am working on it. Should I build it after making the changes?
Keywords: good-first-bug
Whiteboard: [easyconfirm][good first bug] → [easyconfirm]
Assignee: ajain2 → nobody
Status: ASSIGNED → NEW
Attachment #9145558 - Flags: review?(iann_bugzilla)

This is also present in l10n (in untranslated English files, at least), should I make a patch for these as well?

Assignee: nobody → nunojsg
Status: NEW → ASSIGNED
Comment on attachment 9145558 [details] [diff] [review]
cs_nav_prefs_navigator.xhtml "Editmenu"->"Edit menu" patch

Yes to l10n. I'm presuming those that have localised to something other than English did not include the typo :)
r/a=me
Attachment #9145558 - Flags: review?(iann_bugzilla)
Attachment #9145558 - Flags: review+
Attachment #9145558 - Flags: approval-comm-release+
Attachment #9145558 - Flags: approval-comm-esr60+
Attachment #9145571 - Flags: feedback?(iann_bugzilla)
Comment on attachment 9145571 [details] [diff] [review]
l10n: cs_nav_prefs_navigator.xhtml "Editmenu"->"Edit menu" patch

[Triage Comment]
LGTM f/a=me
Attachment #9145571 - Flags: feedback?(iann_bugzilla)
Attachment #9145571 - Flags: feedback+
Attachment #9145571 - Flags: approval-comm-release+
Attachment #9145571 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/4083da0d3e3b
Add missing space ("editmenu"->"edit menu"). r=IanN

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Keywords: good-first-bug
Whiteboard: [easyconfirm] → SM2.53.3
You need to log in before you can comment on or make changes to this bug.