Closed Bug 1271466 Opened 4 years ago Closed 2 years ago

Sync load testing based on production traffic patterns and data

Categories

(Cloud Services :: Server: Sync, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1459326

People

(Reporter: rtilder, Assigned: rtilder)

Details

(Whiteboard: [sync-atomic])

We'd like to do some DB performance comparisons based off some actual production traffic patterns and data.  Anonymized and fuzzed data, obviously, but since the data is already encrypted and user IDs are strictly numeric I don't think it will be much of a problem.

The goal is to have one or more scripts that can take a tcpdump data file and generate a data set that can be readily played back in either traditional or batched mode.

Operations has provided a suitable packet dump.  Progress with processing TCP headers and packet flows with Python has proved full of unexpected entertainment.
QA Contact: kthiessen
FWIW, I think this will be useful enough in general, that we should put the script in the server-syncstorage repository alongside the other management scripts.
Component: Firefox Sync: Cross-client → Server: Sync
Blocks: 1273102
No longer blocks: 1250189
Whiteboard: [sync-data-integrity]
Whiteboard: [sync-data-integrity] → [data-integrity]
Whiteboard: [data-integrity] → [sync-atomic]
This seems to be dormant for now; I'll pick it back up if/when it becomes a P1/P2.
QA Contact: kthiessen
Removing this as a blocker for the batch-upload work
No longer blocks: 1273102
Rebecca, do you have a different tracking bug for your recent work on this topic?  Maybe we can close this one as a dupe.
Flags: needinfo?(rbillings)
Yes, this has been reanimated in bug 1459326. Closing.
Flags: needinfo?(rbillings)
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1459326
You need to log in before you can comment on or make changes to this bug.