Only broken slaves hit bootstrapSvc.js | shouldRunServiceTest - [shouldRunServiceTest : 1745] the updater.exe binary should be signed (if not, build system configuration bug?) - false == true

RESOLVED WORKSFORME

Status

Release Engineering
Buildduty
RESOLVED WORKSFORME
a year ago
11 months ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

unspecified
intermittent-failure
Dependency tree / graph

Firefox Tracking Flags

(firefox49 affected)

Details

(Reporter)

Description

a year ago
These have been happening (quite infrequently), and being ignored, for at least several days now.

https://treeherder.mozilla.org/logviewer.html#?job_id=9345886&repo=fx-team
bhearsum, nthomas: any idea why the test binary stopped getting signed?
Flags: needinfo?(nthomas)
Flags: needinfo?(bhearsum)
The example job was rerun at https://treeherder.mozilla.org/logviewer.html#?job_id=9347705&repo=fx-team and was green. Since the only difference should be a different test machine I'll move this over to our product/component.

rstrong, does this test rely on having the maintenance service registry keys being set ?

Buildduty, could you please check if t-xp32-ix-002 has a history of failing xpcshell jobs. It could be a machine that has lost some registry entries, or is otherwise borken. It doesn't appear to have been re-imaged recently. Please also scan treeherder for other xpcshell failures to see if other slaves are affected.
Component: Application Update → Buildduty
Flags: needinfo?(nthomas)
Flags: needinfo?(bhearsum)
Product: Toolkit → Release Engineering
QA Contact: bugspam.Callek
Version: Trunk → unspecified
(Reporter)

Updated

a year ago
Duplicate of this bug: 1259744
(Reporter)

Comment 4

a year ago
I was a tiny bit off in comment 0: this slave has failed every xpcshell test run it has taken since December 17th.
Blocks: 876006, 1079858
Summary: Intermittent bootstrapSvc.js | shouldRunServiceTest - [shouldRunServiceTest : 1745] the updater.exe binary should be signed (if not, build system configuration bug?) - false == true → Only broken slaves hit bootstrapSvc.js | shouldRunServiceTest - [shouldRunServiceTest : 1745] the updater.exe binary should be signed (if not, build system configuration bug?) - false == true
After monitoring  xpcshell job in the last few days it seems there is no issue with bootstrapSvc.js. Below can be seen the latest tests that run and most of them were successfully:

https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=windows%20xp%20debug%20xpcshell&fromchange=efb43f34c4f59851f4b5416769c423b504b11b24&selectedJob=28346491

While doing some investigations on t-xp32-ix-002, I was wondering if you could share how you found out that this slave failed every xpcshell job since December 17th. The thing is that I am only able to see the statistics for this job for a limited amount of days. :-)
(Reporter)

Comment 6

a year ago
https://secure.pub.build.mozilla.org/buildapi/recent/t-xp32-ix-002 gives you 25 jobs, but adding ?numbuilds=100 gives you 100 which you can then filter down to just xpcshell with the search box, and numbuilds will take a high enough number that you will often kill buildapi by doing so (which makes doing it a Very Bad Thing), but eventually can load enough to see that it hasn't had a passing run since last December.
Thank you Phil for the hint.
Seems that lately most of xpcshell jobs runned without problem.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.