Enable plugin content blocking by default

RESOLVED FIXED in Firefox 49

Status

()

defect
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: tschneider, Assigned: tschneider)

Tracking

({dev-doc-complete, site-compat})

unspecified
mozilla51
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 wontfix, firefox47- wontfix, firefox48+ wontfix, firefox49 fixed, relnote-firefox 49+, firefox50 fixed, firefox51 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
This is for flipping browser.safebrowsing.blockedURIs.enabled.

Comment 2

3 years ago
safebrowsing is really the pref name? That's weird; does this have anything to do with the safe browsing system?
Flags: needinfo?(tschneider)
(Assignee)

Comment 3

3 years ago
Yes, we are taking the safe browsing path for the url classification.
Flags: needinfo?(tschneider)
(Assignee)

Updated

3 years ago
Attachment #8756393 - Flags: review?(benjamin)
[Tracking Requested - why for this release]:

Ritu, just a heads up: this bug is the plugin blocklist feature we talked about enabling in 47.0b9. Tobias will land this pref in Nightly 49 and then ask to uplift to Aurora 48 and Beta 47.0b9.

Comment 5

3 years ago
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

Yes, ship it.
Attachment #8756393 - Flags: review?(benjamin) → review+
Assignee: nobody → tschneider
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

Approval Request Comment
[Feature/regressing bug #]: N/A
[User impact if declined]: No change in the amount of plugin content loaded.
[Describe test coverage new/current, TreeHerder]: The plugin blocklist has been tested on the Beta 47 channel during our 10% beta experiment.
[Risks and why]: Medium risk. The plugin blocklist is a pretty short list and focused on nonessential plugin content. If a website is broken, we can publish a new (or empty) list on the shavar server without requiring a Firefox hotfix.
[String/UUID change made/needed]: No string or UUID changes.
Attachment #8756393 - Flags: approval-mozilla-beta?
Attachment #8756393 - Flags: approval-mozilla-aurora?
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

At the Tuesday channel meeting this week, we decided to enable this pref on by default in Fx47. We also have good mitigation plans in place in case this becomes an issue after we ship. Aurora48+, Beta47+
Attachment #8756393 - Flags: approval-mozilla-beta?
Attachment #8756393 - Flags: approval-mozilla-beta+
Attachment #8756393 - Flags: approval-mozilla-aurora?
Attachment #8756393 - Flags: approval-mozilla-aurora+
Hi Chris, please nominate this bug for relnote addition whenever the blog post and other links are ready. I'd like to add it to the Fx47 release notes (to be reviewed) early next week if possible. Thanks!
Flags: needinfo?(cpeterson)
Hi guys, can you please help address test failures asap? I am trying to get this included in 47.0b9. I really do not want to include this in RC1 but rather land this today!
Flags: needinfo?(tschneider)
Flags: needinfo?(benjamin)

Updated

3 years ago
Flags: needinfo?(benjamin)
47.0b9 build is already in progress, we will not have an updated patch ready soon enough. I would prefer not to uplift this in RC1. CPeterson sent out an email to r-d that we will not be making this change in Fx47 but targeting Fx48 instead.
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

Reverting the A+ on this patch. We may need an updated patch that fixes the test failures.
Attachment #8756393 - Flags: approval-mozilla-beta+
Attachment #8756393 - Flags: approval-mozilla-aurora+
Tobias is debugging the test failures so we can land in Nightly 49.
Flags: needinfo?(cpeterson)
Target Milestone: --- → mozilla49

Comment 16

3 years ago
Pushed by bsmedberg@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4d4289b95a79
Enable plugin content blocking by default
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

Approval Request Comment - this needs to land with https://bugzilla.mozilla.org/show_bug.cgi?id=1268120#c18 - see approval comment there
Flags: needinfo?(tschneider)
Attachment #8756393 - Flags: approval-mozilla-beta?
Attachment #8756393 - Flags: approval-mozilla-aurora?

Comment 18

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4d4289b95a79
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: mozilla49 → mozilla50
sorry had to back this out from m-c and all integration branches since we have perma failures like https://treeherder.mozilla.org/logviewer.html#?job_id=31839256&repo=mozilla-inbound after this landing
Status: RESOLVED → REOPENED
Flags: needinfo?(tschneider)
Resolution: FIXED → ---

Comment 20

3 years ago
Backout by cbook@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/4c05938a64a7
Backed out changeset 4d4289b95a79 for causing m-2  Windows 8 x64 opt perma failures in test_bug659071.html
Tobias, can you take a look at these plugin mochitests failures?

TEST-UNEXPECTED-FAIL | dom/plugins/test/mochitest/test_bug1165981.html | uncaught exception - TypeError: pluginElement.identifierToStringTest is not a function at run@http://mochi.test:8888/tests/dom/plugins/test/mochitest/test_bug1165981.html:51:12
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

Not taking it to 48 (just like bug 1268120)
Attachment #8756393 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

Review of attachment 8756393 [details] [diff] [review]:
-----------------------------------------------------------------

This patch enabled plugin blocklist feature. Take it in aurora.
Attachment #8756393 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

Review of attachment 8756393 [details] [diff] [review]:
-----------------------------------------------------------------

Didn't notice this was backout.
Attachment #8756393 - Flags: approval-mozilla-aurora+ → approval-mozilla-aurora?
(Assignee)

Updated

3 years ago
Depends on: 1290749
Flags: needinfo?(tschneider)
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

If this is about uplifting to 49, flipping from aurora:? to beta:? flag post-merge.
Attachment #8756393 - Flags: approval-mozilla-beta?
Attachment #8756393 - Flags: approval-mozilla-beta-
Attachment #8756393 - Flags: approval-mozilla-aurora?
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

I am temporarily resetting the uplift requests because the original pref-enabling patch was backed out from mozilla-inbound (comment 19). Once Tobias lands the test fix (bug 1290749), he can try landing this patch again. If Nightly 51 looks good, then he can re-request uplift to Aurora or Beta.
Attachment #8756393 - Flags: approval-mozilla-beta?
Tobias, your test fix (bug 1290749) landed in mozilla-central, so you can now try to reland this patch to enable the blocklist pref.
Flags: needinfo?(tschneider)
(Assignee)

Updated

3 years ago
Flags: needinfo?(tschneider)
Keywords: checkin-needed

Comment 28

3 years ago
Pushed by cpeterson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f0bd5218a807
Enable plugin content blocking by default. r=bsmedberg
Keywords: checkin-needed

Comment 29

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f0bd5218a807
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Want to request uplift to beta for this to go with bug 1290749?
Flags: needinfo?(tschneider)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #30)
> Want to request uplift to beta for this to go with bug 1290749?

Yes. The test fix in bug 1290749 *must* land before this bug's patch. AFAICT, Tobias already requested both approval-mozilla-aurora and approval-mozilla-beta for the test fix in bug 1290749 comment 6.
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

The Flash blocklist test fix bug 1290749 has been uplifted to Aurora 50 and Beta 49, so we'd like to uplift this patch to enable the Flash blocklist feature.

Approval Request Comment
[Feature/regressing bug #]: Not a regression. This patch enables the Flash blocklist feature.
[User impact if declined]: Some sites will still have invisible Flash pixels that slow down Firefox without providing any direct user benefit.
[Describe test coverage new/current, TreeHerder]: The Flash blocklist has been enabled on Nightly 51 for one week.
[Risks and why]: We're trying to reduce the risk of the Flash blocklist by restricting the first phase to a short list of Flash pixels that are not required for any major sites.
[String/UUID change made/needed]: No strings.
Flags: needinfo?(tschneider)
Attachment #8756393 - Flags: approval-mozilla-beta?
Attachment #8756393 - Flags: approval-mozilla-aurora?
Release Note Request (optional, but appreciated)
[Why is this notable]: This bug enables the first phase of our Flash blocklist, part of an ongoing initiative to reduce NPAPI plugin usage.
[Suggested wording]: Block some nonessential Flash plugin content.
[Links (documentation, blog post, etc)]: https://blog.mozilla.org/futurereleases/2016/07/20/reducing-adobe-flash-usage-in-firefox/
relnote-firefox: --- → ?
Comment on attachment 8756393 [details] [diff] [review]
Flip browser.safebrowsing.blockedURIs.enabled

Flash blocklist, I'd like to see how this works in beta as soon as possible. It should make it into beta 5.
Attachment #8756393 - Flags: approval-mozilla-beta?
Attachment #8756393 - Flags: approval-mozilla-beta+
Attachment #8756393 - Flags: approval-mozilla-aurora?
Attachment #8756393 - Flags: approval-mozilla-aurora+
Target Milestone: mozilla50 → mozilla51

Updated

3 years ago
Depends on: 1311368
Getting ready to mention this on MDN but am slightly confused by the tracking flags. Is this fixed in 51, or earlier? Or has it been rolled into patches to older builds? Or…?
(In reply to Eric Shepherd [:sheppy] from comment #37)
> Getting ready to mention this on MDN but am slightly confused by the
> tracking flags. Is this fixed in 51, or earlier? Or has it been rolled into
> patches to older builds? Or…?

The plugin content blocking shipped in Firefox 49. The feature landed in Nightly 51, but was uplifted to Beta 49 (comment 35).
OK, so this needs to be documented as a Firefox 49 change then. Thanks!
Too late for the release notes, sorry.
relnote-firefox: ? → ---
Actually, I changed my mind and added it to the 49 release notes for posterity
See Also: → 1333553
You need to log in before you can comment on or make changes to this bug.