about:performance not working in Seamonkey

RESOLVED FIXED in seamonkey2.44

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

SeaMonkey 2.44 Branch
seamonkey2.44
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.43 unaffected, seamonkey2.44 fixed, seamonkey2.45 fixed, seamonkey2.46 fixed, seamonkey2.47 fixed)

Details

Attachments

(1 attachment)

Performance monitoring is a new feature in Firefox 47 but not working in Seamonkey 2.44

You get a 

>> Timestamp: 07.06.2016 20:03:29
>> Error: ReferenceError: performanceStatsService is not defined
>> Source File: resource://gre/modules/PerformanceStats.jsm
>> Line: 219

when you try it but it works fine in 2.47 c-c. Bug 1243706 got it into the release channel and we just need to port it.
Tested on Windows 2.44 x64 en-US VS2015 build.

User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0 SeaMonkey/2.44
Assignee: installer → frgrahl
Status: NEW → ASSIGNED
Attachment #8760856 - Flags: review?(philip.chee)
Comment on attachment 8760856 [details] [diff] [review]
1278633-perfmon-installer.patch

Do you think we should port the UI from Bug 1071880 + Bug 1142937 ?
Attachment #8760856 - Flags: review?(philip.chee) → review+
>> Do you think we should port the UI from Bug 1071880 + Bug 1142937 ?

Looks simple at first glance but I wouldn't want it without an option to turn it off in the ui. Not sure what this does on an old P3 otherwise. 

File a followup bug? Maybe rsx11m can do the ui part. 

rsx11m what do you think?

FRG
Flags: needinfo?(rsx11m.pub)
Comment on attachment 8760856 [details] [diff] [review]
1278633-perfmon-installer.patch

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Freebie functionality that is already in Firefox missing.
Testing completed (on m-c, etc.): c-r and c-b 
Risk to taking this patch (and alternatives if risky): none 
String changes made by this patch: none.
Attachment #8760856 - Flags: approval-comm-release?
Attachment #8760856 - Flags: approval-comm-beta?
Attachment #8760856 - Flags: approval-comm-aurora?
Err, since we don't use AddonWatcher.jsm anyway, does that XPT do anything at all at this time?
I don't know much about the Addons Manager itself.
Flags: needinfo?(rsx11m.pub)
Comment on attachment 8760856 [details] [diff] [review]
1278633-perfmon-installer.patch

a=me for all branches inc CLOSED TREE
Attachment #8760856 - Flags: approval-comm-release?
Attachment #8760856 - Flags: approval-comm-release+
Attachment #8760856 - Flags: approval-comm-beta?
Attachment #8760856 - Flags: approval-comm-beta+
Attachment #8760856 - Flags: approval-comm-aurora?
Attachment #8760856 - Flags: approval-comm-aurora+
Blocks: 1282227
>> Do you think we should port the UI from Bug 1071880 + Bug 1142937 ?

I ported the changes for these bugs to 2.47a1 but do not have a test case yet eg. unable to force a notification. I created bug 1282227 to track this.
TM for easing queries.
Target Milestone: --- → seamonkey2.44
TM is supposed to reflect trunk version at the time this landed on comm-central.
Target Milestone: seamonkey2.44 → seamonkey2.47
Please see Bug 1293618 comment #38
Target Milestone: seamonkey2.47 → seamonkey2.44
You need to log in before you can comment on or make changes to this bug.