bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

homeURL and workURL values are wrong (swapped) for LDAP, ldif import and export.

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Robert John Churchill, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

17 years ago
The homeURL and workURL values are incorrectly swapped in the Address Book (both
in the main display when a single card is chosen, as well as in the Card display
when showing all attributes for an entry).
(Reporter)

Comment 1

17 years ago
Created attachment 71647 [details] [diff] [review]
Patch

Here is a patch for 'ya... simple XUL/JS changes.
(Reporter)

Comment 2

17 years ago
Sigh... only one problem with that patch; it transposes any existing cards
(which is wrong.)
(Reporter)

Comment 3

17 years ago
Created attachment 71648 [details] [diff] [review]
Better patch

Better patch that changes the LDAP property mapping (so only LDAP-fetched cards
are tweaked) so that existing Personal Addressbook cards remain correct.
Attachment #71647 - Attachment is obsolete: true

Comment 4

17 years ago
This looks fine to me, but I'd like Seth or John to verify that this is the
right thing.
Assignee: dmose → sspitzer

Comment 5

17 years ago
Additionally, we may need to change the other two redundant tables where this
info is kept.

Comment 6

17 years ago
Created attachment 72054 [details] [diff] [review]
Patch to fix homeurl versus workurl 

Dan, yes Robert's patch looks good. I have updated the patch to include the
other two cases I presume you are talking about. The other area where is this
is used is in Outlook but it is correct there.

Updated

17 years ago
Attachment #71648 - Attachment is obsolete: true
taking a look...

rjc's initial patch makes sense, but I need to see if john's additions to the
patch are also correct.

I want to double check and make sure all these changes are correct.

Comment 8

17 years ago
1. Import Outlook AB: I can see the problem
2. Import Outlook Express AB: ok.

So is this fix specific for importing from an Outlook Address Book?

Comment 9

17 years ago
This bug is related to LDAP only. My comment about Outlook related to the
dynamic integration of Outlook and Outlook Express in Mozilla (bug #78931 and
bug #83103) as opposed to the Importing of Outlook and Outlook Express. 

Yes, I also believe we have a problem in Importing from Outlook. It appears that
we map the PR_BUSINESS_HOME_PAGE (confusing  name!) to Mozilla's Home Web Page
rather than the Business Web Page. But because Outlook uses only one web page
field, then this may explain why this is not such a big issue. In contrast
Outlook Express supports both a Home Web Page and a Business Web Page. It
appears following bug #93588 that this is now fixed.

So to be accurate we could create a new bug for the Import of Outlook.
dmose wrote:

"Additionally, we may need to change the other two redundant tables where this
info is kept."

dan's guess is right, export and import have issues.  it looks like john's last 
patch addresses some of these, but not all.

I'll attach another patch.
Status: NEW → ASSIGNED

Comment 12

17 years ago
This latest patch looks good. r=john.marmion

Comment 13

17 years ago
Comment on attachment 73177 [details] [diff] [review]
updated patch

sr=bienvenu
Attachment #73177 - Flags: superreview+
Keywords: nsbeta1, patch
Summary: homeURL and workURL values are wrong (swapped) → homeURL and workURL values are wrong (swapped) for LDAP, ldif import and export.
Target Milestone: --- → mozilla1.0

Comment 14

17 years ago
Comment on attachment 73177 [details] [diff] [review]
updated patch

r=bhuvan
Attachment #73177 - Flags: review+

Comment 15

17 years ago
Comment on attachment 73177 [details] [diff] [review]
updated patch

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #73177 - Flags: approval+
fixed

thanks to rjc for the bug and the initial patch, and to john for the follow up 
patches and the review.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+

Comment 17

17 years ago
Setting qa contact to Yulian.
QA Contact: nbaca → yulian

Comment 18

17 years ago
fyi: logged bug# 134014 to track the import from outlook problem where the web
pages are not mapped correctly (as stated in comment# 9).

Comment 19

17 years ago
Robert,
Would you confirm the fix with your Directory Server (at home?) which uses the
attributes: "homeURL" and "workURL" ? Thanks!
(Reporter)

Comment 20

17 years ago
Confirmed.

Comment 21

17 years ago
Verified by reporter
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.