Closed Bug 1281815 (webext-port-adblock) Opened 6 years ago Closed 6 years ago

Enable AdBlock Chrome extension to work with Firefox

Categories

(WebExtensions :: Compatibility, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1226547

People

(Reporter: bsilverberg, Unassigned)

References

(Depends on 1 open bug)

Details

(Whiteboard: [popular chrome extensions]triaged)

Chrome extension at https://chrome.google.com/webstore/detail/adblock/gighmmpiobklfepjocnamgkkbiglidom
Test uploaded to AMO at https://addons.allizom.org/en-US/firefox/addon/adblocktest/

Missing APIs:
- chrome.extension.onRequest (deprecated)
- chrome.webNavigation.onTabReplaced (Bug 1280404)
Depends on: 1280404, 1280399
Whiteboard: [popular chrome extensions]triaged
No longer blocks: webext-port-adblock-plus
Alias: webext-port-adblock
Having grepped the full source code, here is a list of missing APIs:
- chrome.devtools.panels.create
- chrome.extension.sendRequest
- chrome.idle
- chrome.management.getAll
- chrome.management.getSelf
- chrome.management.setEnabled
- chrome.permissions.remove
- chrome.permissions.request
- chrome.runtime.onInstalled
- chrome.runtime.requestUpdateCheck
- chrome.tabs.sendRequest
- chrome.webRequest.MAX_HANDLER_BEHAVIOR_CHANGED_CALLS_PER_10_MINUTES
- chrome.webRequest.ResourceType
(In reply to Bob Silverberg [:bsilverberg] from comment #1)
> Having grepped the full source code, here is a list of missing APIs:
> - chrome.devtools.panels.create
> - chrome.extension.sendRequest (deprecated, use runtime.sendMessage)
> - chrome.idle
> - chrome.management.getAll (bug 1282981)
> - chrome.management.getSelf (bug 1283116)
> - chrome.management.setEnabled (bug 1282982)
> - chrome.permissions.remove
> - chrome.permissions.request
> - chrome.runtime.onInstalled (bug 1252871)
> - chrome.runtime.requestUpdateCheck
> - chrome.tabs.sendRequest (deprecated, use runtime.sendMessage)
> - chrome.webRequest.MAX_HANDLER_BEHAVIOR_CHANGED_CALLS_PER_10_MINUTES
> - chrome.webRequest.ResourceType
Component: WebExtensions: Untriaged → WebExtensions: Compatibility
Priority: -- → P3
So many ABP bugs, its a popular add-on. Wladimir said he'd like to focus on just bug 1226547, so lets do that.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: webext-port-abp
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.