Bug 1281816 (webext-port-adblock-plus)

Enable AdBlock Plus Chrome extension to work with Firefox

RESOLVED DUPLICATE of bug 1226547

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1226547
11 months ago
8 months ago

People

(Reporter: bsilverberg, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [popular chrome extensions]triaged)

(Reporter)

Description

11 months ago
Chrome extension at https://chrome.google.com/webstore/detail/adblock-plus/cfhdojbkjhnklbpkdaibdccddilifddb
Test uploaded to AMO at https://addons.allizom.org/en-US/firefox/addon/adblockplus01/ (maybe)

Missing APIs:
- chrome.extension.onRequest (deprecated)
(Reporter)

Updated

11 months ago
No longer depends on: 1280404, 1281815
(Reporter)

Updated

11 months ago
Duplicate of this bug: 1282749
(Reporter)

Updated

11 months ago
Depends on: 1282771
(Reporter)

Comment 2

11 months ago
My latest test also shows a missing API of:
- chrome.webNavigation.onCreatedNavigationTarget (bug 1282771)

And also errors such as:

- The Components object is deprecated. It will soon be removed. compat.js:45:4
- Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. ExtensionUtils.jsm:300
- Invalid match pattern: 'moz-extension://7cedffee-b65a-d049-8b32-aaeebe733bbb/options.html' MatchPattern.jsm:52
- TypeError: this._recipeManager is null LoginManagerParent.jsm:77:9
- Unknown localization message global_newgroup_title  adblockplus.js:174
- Unknown localization message global_whitelistgroup_title  adblockplus.js:174
(Reporter)

Updated

11 months ago
No longer depends on: 1282771
(Reporter)

Updated

11 months ago
Depends on: 1190687

Updated

11 months ago
Alias: webext-port-adblock-plus
(Reporter)

Comment 3

11 months ago
Having grepped the full source code, here is a list of missing APIs:
- chrome.devtools.inspectedWindow.tabId
- chrome.devtools.panels.create
- chrome.webNavigation.onCreatedNavigationTarget
- chrome.webRequest.MAX_HANDLER_BEHAVIOR_CHANGED_CALLS_PER_10_MINUTES
- chrome.webRequest.ResourceType

Updated

8 months ago
Depends on: 1166496

Updated

8 months ago
Depends on: 1211859

Comment 4

8 months ago
We've got two bugs about AdBlock Plus and bug 1226547 has more details. This bug is focused on getting the Chrome version working, that bug is more about allowing the feature rich Firefox version working, I'd rather focus on that one so duping over to that one.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226547
You need to log in before you can comment on or make changes to this bug.