Awesomebar results display overlapping the hamburger menu

RESOLVED DUPLICATE of bug 1187647

Status

()

Firefox
Address Bar
P5
normal
RESOLVED DUPLICATE of bug 1187647
a year ago
11 months ago

People

(Reporter: Dan D (Not an employee, just a tester), Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Created attachment 8766473 [details]
Screenshot at 2016-06-29 14:37:42.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160629004019

Steps to reproduce:

1. Click in the Awesomebar
2. Click the hamburger button to display hamburger menu
3. Type characters


Actual results:

Awesomebar results display over the hamburger menu. Both are interact-able, but they are majorly overlapping; the hamburger menu is obscured by the Awesomebar results.

Clicking around in the hamburger menu does not dismiss the Awesomebar results. Typing in the Awesomebar does not dismiss the hamburger menu. 


Expected results:

Simple UX (such as the hamburger menu closes when typing in the Awesomebar; or the Awesomebar results close when clicking in the hamburger menu; or ... devs come up with a better solution)

Comment 1

a year ago
This is reproducible using the STR on 49.0a2, 48.0b3 or 50.0a1 (20160629).
Component: Untriaged → Menus
Has STR: --- → yes
Component: Menus → Location Bar
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
Whiteboard: [fxsearch]

Comment 2

11 months ago
This is reproducible with searchbar popup, and also:
- it's a part of bug 1187647
- I must notice that screenshot in this bug is better UI than screencast in bug 1187647
- bug 1187647 has became worse (see regression bug 1327941 mentioned there)

It makes sense to reopen it and fix separately if you want to have urlbar-specific fix, but what about searchbar then? And urlbar was mentioned in bug 1187647.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1187647
You need to log in before you can comment on or make changes to this bug.