Popups do not collapse when focus is changed via keyboard

REOPENED
Unassigned

Status

()

Firefox
Menus
REOPENED
2 years ago
6 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8638966 [details]
Australis menu popups do not collapse when focus is changed.webm

STR (tested on Win7):
1. Place downloads button before tabs (via customization)
2. Press downloads button
3. Press Ctrl+L
4. Type something

RESULT: addressbar gained focus and suggestions are displayed while downloads popup is still visible

EXPECTATIONS: downloads popup should hide when you change focus to other things

Note:
See also bug 1171394 and feel free to edit these 2 bugs and/or merge them

Updated

2 years ago
See Also: → bug 1171394

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment hidden (typo)
(Reporter)

Updated

2 years ago
Summary: Australis menu popups from toolbar do not collapse when focus is changed (in some cases) → Australis menu popups from toolbar do not collapse when I navigate with keyboard (in some cases)
(Reporter)

Updated

2 years ago
See Also: → bug 778391
(Reporter)

Updated

2 years ago
See Also: → bug 1211311
(Reporter)

Updated

a year ago
Duplicate of this bug: 1251046
Duplicate of this bug: 1251046
This looks to be a duplicate of bug 1171746, which was filed earlier and appears to have a good discussion on-going already.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171746
(Reporter)

Comment 5

a year ago
Scenario in comment 0 won't be resolved by bug 1171746 (it appears that I just listed all similar issues right here, in the same bug. That wasn't good move, I agree now)
Honestly, I'd like to hide some comments/attachments, specify the summary and keep this bug opened
Flags: needinfo?(jaws)
Okay, I've reopened the bug and hidden comment #1.
Status: RESOLVED → REOPENED
Flags: needinfo?(jaws)
Resolution: DUPLICATE → ---
Summary: Australis menu popups from toolbar do not collapse when I navigate with keyboard (in some cases) → Popups do not collapse when focus is changed via keyboard
Blocks: 1219794
No longer blocks: 1219794
(Reporter)

Updated

6 months ago
See Also: → bug 1327607
(Reporter)

Updated

6 months ago
See Also: → bug 1327941
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1283246
(Reporter)

Updated

6 months ago
See Also: → bug 1327846
(Reporter)

Updated

6 months ago
See Also: → bug 1206133
You need to log in before you can comment on or make changes to this bug.