Intermittent uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | application ran for longer than allowed maximum time

RESOLVED DUPLICATE of bug 1204281

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1204281
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: gbrown)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Comment 1

2 years ago
I'm not sure if the bug caused by test framework or test case it self. But, I saw some similar bugs on Bugzilla. Let's set priority as P3 and keep monitoring this bug.
QA Whiteboard: mochitest-failure

Updated

2 years ago
Priority: -- → P3
16 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 9
* autoland: 5
* mozilla-central: 2

Platform breakdown:
* android-4-3-armv7-api15: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2016-07-04&endday=2016-07-10&tree=all
14 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 4
* fx-team: 2
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2016-07-11&endday=2016-07-17&tree=all
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-central: 2
* mozilla-inbound: 1
* fx-team: 1
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api15: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2016-07-18&endday=2016-07-24&tree=all
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 5
* mozilla-inbound: 1

Platform breakdown:
* android-4-3-armv7-api15: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2016-08-15&endday=2016-08-21&tree=all
23 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 15
* autoland: 7
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api15: 23

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2016-08-22&endday=2016-08-28&tree=all
46 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 21
* mozilla-inbound: 17
* fx-team: 4
* mozilla-central: 3
* try: 1

Platform breakdown:
* android-4-3-armv7-api15: 46

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2016-08-29&endday=2016-09-04&tree=all
43 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 18
* autoland: 17
* mozilla-central: 4
* fx-team: 4

Platform breakdown:
* android-4-3-armv7-api15: 43

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2016-09-05&endday=2016-09-11&tree=all

Comment 9

2 years ago
(In reply to OrangeFactor Robot from comment #8)
> 43 automation job failures were associated with this bug in the last 7 days.
> 
> Repository breakdown:
> * mozilla-inbound: 18
> * autoland: 17
> * mozilla-central: 4
> * fx-team: 4
> 
> Platform breakdown:
> * android-4-3-armv7-api15: 43
> 
> For more details, see:
> https://brasstacks.mozilla.com/orangefactor/
> ?display=Bug&bugid=1283719&startday=2016-09-05&endday=2016-09-11&tree=all

Hi, Wesly,

May I have your help?
Could we assign a developer to investigate this failure?
The failure has has happened on 43 jobs in the last 7 days.
The failure rate is increased.

Test: https://dxr.mozilla.org/mozilla-central/source/uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml?q=uriloader%2Fexthandler%2Ftests%2Fmochitest%2Ftest_unsafeBidiChars.xhtml&redirect_type=direct

Thanks.
Flags: needinfo?(wehuang)

Comment 10

2 years ago
Hi Ben:

Would you help check if this is something our project team can do the best, or should reach out for support? Thanks.
Flags: needinfo?(wehuang) → needinfo?(btian)
36 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 19
* autoland: 11
* fx-team: 4
* try: 1
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 36

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2016-09-12&endday=2016-09-18&tree=all

Comment 12

2 years ago
(In reply to William Hsu [:whsu] from comment #9)
> > Platform breakdown:
> > * android-4-3-armv7-api15: 43

William, the bug happens only on Android API15, right?
Flags: needinfo?(btian) → needinfo?(whsu)

Comment 13

2 years ago
Restore my ni?
Flags: needinfo?(btian)

Comment 14

2 years ago
Hit similar failure (bug 1301686) while reproducing this bug.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=1d7f054e22c6&selectedJob=27862625
Flags: needinfo?(btian)
See Also: → bug 1301686

Comment 15

2 years ago
(In reply to Wesly Huang (Firefox EPM) from comment #10)
> Would you help check if this is something our project team can do the best,
> or should reach out for support? Thanks.

I suggest to reach out for support on Android mochitest framework. Since application keeps running for tens of seconds after test itself completes, based on logs of following failures from comment 8 link.

William, does similar timeout happen on other mochitests?


> === 11 Sep 2016, 02:33 mozilla-inbound ===
04:56:03     INFO -  546 INFO TEST-START | uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml
04:56:03     INFO -  547 INFO TEST-OK | uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | took 20822ms
04:56:44     INFO -  org.mozilla.fennec still alive after SIGABRT: waiting...
04:56:49  WARNING -  TEST-UNEXPECTED-FAIL | uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | application ran for longer than allowed maximum time

> === 11 Sep 2016, 06:44	 fx-team ===
09:05:06     INFO -  546 INFO TEST-START | uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml
09:06:37     INFO -  547 INFO TEST-OK | uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | took 62453ms
09:07:05 WARNING - TEST-UNEXPECTED-FAIL | uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | application ran for longer than allowed maximum time 

> === 11 Sep 2016, 14:45 mozilla-inbound ===
17:13:19     INFO -  607 INFO TEST-START | uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml
17:13:19     INFO -  608 INFO TEST-OK | uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | took 21768ms
17:13:57  WARNING -  TEST-UNEXPECTED-FAIL | uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | application ran for longer than allowed maximum time
43 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 23
* mozilla-inbound: 15
* mozilla-central: 2
* fx-team: 2
* mozilla-aurora: 1

Platform breakdown:
* android-4-3-armv7-api15: 43

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2016-09-19&endday=2016-09-25&tree=all

Comment 17

2 years ago
(In reply to Ben Tian [:btian] from comment #15)
> (In reply to Wesly Huang (Firefox EPM) from comment #10)
> > Would you help check if this is something our project team can do the best,
> > or should reach out for support? Thanks.
> 
> I suggest to reach out for support on Android mochitest framework. Since
> application keeps running for tens of seconds after test itself completes,
> based on logs of following failures from comment 8 link.
> 
> William, does similar timeout happen on other mochitests?

Sorry for the late reply.
After one week monitoring, I found the timeout issue happened on those tests.
- js/xpconnect/tests/mochitest/test_bug940783.html (Bug 1300971)
- js/xpconnect/tests/mochitest/test_bug871887.html (Bug 1300965)
- js/xpconnect/tests/mochitest/test_bug986542.html (Bug 1300961)
- js/xpconnect/tests/mochitest/test_nac.xhtml (Bug 1300624)
- js/xpconnect/tests/mochitest/test_sandbox_fetch.html (Bug 1300249)
- dom/html/test/test_bug606817.html (Bug 1300970)
...

Perhaps, we can contact the owner/creater (test_unsafeBidiChars.xhtml) to see if we need to disable the test or modify it. What do you think?

Thank you. :)
Flags: needinfo?(whsu)

Comment 18

2 years ago
Sure we can contact the test case owner to help.

But as comment 15 suggests, I think it's Android mochitest framework rather than test case itself that results in the timeout, and disabling test cases with timeout only workaround the root cause.
14 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 6
* mozilla-inbound: 4
* mozilla-aurora: 3
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2016-09-26&endday=2016-10-02&tree=all
(Assignee)

Comment 20

2 years ago
"Application ran for longer than allowed maximum time" is reported by the test harness when a test job (like "mochitest-20") runs for longer than its configured maximum time. The max time is typically 60 minutes, but it is sometimes 90, or 120 minutes. For Android Debug mochitests, the max time is 120 minutes.

The maximum time may be exceeded because
 - a single test is hanging
 - a single test is suddenly taking much longer to complete
 - a general performance regression
 - new tests have been added, or existing tests have been made more complex.

If there is a single test or some other identifiable cause for the slow-down, we want to fix that. Otherwise, we can increase the max time or increase the number of chunks (so that fewer tests are run in each chunk).

The number of Android Debug mochitests was increased in bug 1204281 on 2016-09-28.

Feel free to ping me any time you see this type of error and want to increase the test chunks.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1204281
(Assignee)

Updated

2 years ago
Assignee: nobody → gbrown
6 failures in 790 pushes (0.008 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 4
* mozilla-inbound: 2

Platform breakdown:
* android-4-3-armv7-api15: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1283719&startday=2017-03-06&endday=2017-03-12&tree=all
You need to log in before you can comment on or make changes to this bug.