Closed Bug 1283908 Opened 3 years ago Closed 3 years ago

After updating from win7 to win10, Thunderbird is not responding for 1-2 minutes after sending mail when Windows service "Windows Search" is running (win10)

Categories

(Thunderbird :: OS Integration, defect, major)

45 Branch
Unspecified
Windows 10
defect
Not set
major

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: alexander.buchner, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.106 Safari/537.36

Steps to reproduce:

After upgrading from Windows 7 to Windows 10 I have the following problem.

The Windows Service "Windows Search" is running.
In about 90 % of the cases when I send a mail TB is freezing ("Thunderbird is not responding") for about 1 or 2 minutes.

If I deactivate the Windows Service "Windows Search" then everything is fine but, of course, then I am missing some Windows features which rely on this service being run.

The option "Allow Windows Search to search messages" is deactivated.
Does anyone have the same problem?
Is Thunderbird profile and account folders in their default location, i.e. you never changed them?
Is Antivirus software set to NOT scan thunderbird and the Thunderbird profile and account folders? 
What is size of Sent folder on disk?
Flags: needinfo?(alexander.buchner)
Keywords: perf
Summary: Thunderbird is not responding after sending mail when Windows service "Windows Search" is running → Thunderbird is not responding for 1-2 minutes after sending mail when Windows service "Windows Search" is running
Thunderbird profile and account folders are in the default locations.

I only use Windows Defender and excluded "thunderbird.exe" to the processes exclusion list and the folder "%APPDATA%\Thunderbird" for exclusion of files and folders.

The Sent folder is about 850 MB.
Flags: needinfo?(alexander.buchner)
please save the contents of
  help | troubleshooting | copy text to clipboard (without account details)
save the text to a file and use "attach file" to this bug report
Rmaf, please don't post unrelated problems.
This bug is about problems related to "Windows Search". I see that you opened a new bug 1286620 for your problem.
Does anybody have an idea what could be causing the problem?
Thank you for the links. But at first glance they all are about problems with Windows search being slow etc.
In my case Windows Search works fine unless I turn it off to mitigate my initial problem.

Nevertheless I will have a closer looks at your links. Maybe something from there works.
The three links couldn't help me.

Does anybody know why the Service "Windows Search" matters at all when I have set "Allow Windows Search to search messages" to off?
I still have this problem.
What kind of information can I deliver to help debugging?
I have the same problem after update to Win10. Turn off the Windows Search helped. Indexing (profile not on c:\) is also turned off (but without any effects).
If you need some more information - no problem ;)
(In reply to Alexander Buchner from comment #11)
> ...
> Does anybody know why the Service "Windows Search" matters at all when I
> have set "Allow Windows Search to search messages" to off?

(In reply to Alexander Buchner from comment #12)
> I still have this problem.
> What kind of information can I deliver to help debugging?

I think it unlikely you will fine the answers here. It's more a question for someone at Microsoft or someone who understands the guts of Windows Search.

Thank you for the offers of more information. But I don't think this can be resolved by anything on Thunderbird side, so closing invalid, which means not a bug in Thunderbird code.
Severity: normal → major
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
See Also: → 1083233
See Also: → 1249056
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #15)
>...
> Thank you for the offers of more information. But I don't think this can be
> resolved by anything on Thunderbird side, so closing invalid, which means
> not a bug in Thunderbird code.

That said, after more thought this bug absolutely must impact some users who see bug 1249056
Blocks: 1249056
See Also: 1249056
OS: Unspecified → Windows 10
Summary: Thunderbird is not responding for 1-2 minutes after sending mail when Windows service "Windows Search" is running → After updating from win7 to win10, Thunderbird is not responding for 1-2 minutes after sending mail when Windows service "Windows Search" is running (win10)
Alexander,

bug 1262517 comment 21 states "I observed that freeze occurs when Thunderbird is creating %TEMP%\nsemail-*.eml file."

Is that also true in your case?
Component: Untriaged → OS Integration
Flags: needinfo?(alexander.buchner)
The bug is so old that I'm on a new machine now and there I don't have this problem anymore.
Flags: needinfo?(alexander.buchner)
You need to log in before you can comment on or make changes to this bug.