Regular freezing while writing, sending or saving email with Windows 10 (since 4 months despite several updates!). OK in Windows Safe Mode. Cause: Windows Indexer aka "Windows Search service"

RESOLVED INVALID
(Needinfo from 2 people)

Status

defect
RESOLVED INVALID
3 years ago
Last year

People

(Reporter: bettina.gartner, Unassigned, NeedInfo)

Tracking

({perf})

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

()

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

Thunderbird keeps freezing for ca. 1 min. while writing emails, sending emails or saving drafts. It does so often, but not always. This problem started a couple of weeks after I had upgraded to Windows 10 (in early December, I guess). At the beginning, i.e. for the first 2 weeks after the regular freezing had started, installing an older version of Thunderbird could fix the problem. 

This problem lasts since 4 months now and makes working with Thunderbird a real pain. As far as I can see, it is connected with Windows 10 and not related to my profile (including add-ons, size of files etc.) because, after having migrated my profile to a computer with Windows 7, but basically the same software (including anti-virus software etc.), freezing did not occur anymore, but it returned as soon as I migrated my profile back to the Windows 10 computer. Numerous users complain about this freezing problem which occurs in numerous variants. During the past months, I have tried countless suggestions to fix this problem, as they are available on the web. Nothing worked. 

The current version is 38.7.2.
Start *Windows'* safe mode with networking enabled
- win10 http://windows.microsoft.com/en-us/windows-10/change-startup-settings-in-windows-10
Still In Windows safe mode, start thunderbird in safe mode
- https://support.mozilla.org/kb/safe-mode-thunderbird
Does problem go away? 

If no, please try version 45 beta and post your results
 https://www.mozilla.org/en-US/thunderbird/all-beta.html
Flags: needinfo?(bettina.gartner)
Keywords: perf
Thanks for your suggestions. Here is my report: 1. There seems to be no freezing if I use Thunderbird in Windows safe mode (with activated add-ons). (I used it only for writing and saving a couple of emails because I needed to send these emails which is not possible in safe mode). Returning to Windows normal mode, freezing returns. 
2. I installed version 45 beta. Freezing did not occur for the first hours; since then, it seems to be more frequent than before. 3. Starting Thunderbird in safe mode (in Windows normal mode) does not stop the freezing (as I checked already during the past 4 months in which I have tried more or less everything what is suggested on the web). 

Btw, my text modules (add-on Quicktext) ‚disappeared’, i.e. seem to have been deleted, during the same time period when I installed the version 45 beta. Is it possible that this was caused by the installation of the beta version?

If you make suggestions, could you please add some explanation regarding the purpose of the procedure, the expected causes to be eliminated by this procedure and the like? This enables users to add more information regarding the symptoms that might support the proposed procedure or lead to other methods to solve the problem. Furthermore, it helps users to become more competent solving similar problems.
Flags: needinfo?(bettina.gartner)
(In reply to bettina.gartner@gmx.de from comment #2)
> Thanks for your suggestions. Here is my report: 1. There seems to be no
> freezing if I use Thunderbird in Windows safe mode (with activated add-ons).
> (I used it only for writing and saving a couple of emails because I needed
> to send these emails which is not possible in safe mode). Returning to
> Windows normal mode, freezing returns. 
> 2. I installed version 45 beta. Freezing did not occur for the first hours;
> since then, it seems to be more frequent than before. 3. Starting
> Thunderbird in safe mode (in Windows normal mode) does not stop the freezing
> (as I checked already during the past 4 months in which I have tried more or
> less everything what is suggested on the web). 
> 
> Btw, my text modules (add-on Quicktext) ‚disappeared’, i.e. seem to have
> been deleted, during the same time period when I installed the version 45
> beta. Is it possible that this was caused by the installation of the beta
> version?

If there is a version mismatch, sure.
 
> If you make suggestions, could you please add some explanation regarding the
> purpose of the procedure, the expected causes to be eliminated by this
> procedure and the like? This enables users to add more information regarding
> the symptoms that might support the proposed procedure or lead to other
> methods to solve the problem. Furthermore, it helps users to become more
> competent solving similar problems.

Matt in https://support.mozilla.org/en-US/questions/1117146 has pointed to a couple such documents.  Also google search with the relevant terms often reveals the documents which go into such detail. For example google "what is windows safe mode".

Beyond that, my full statement about safe mode is...

Start *Windows'* safe mode with networking enabled
Still In Windows safe mode, start thunderbird in safe mode
- https://support.mozilla.org/kb/safe-mode-thunderbird

Does problem go away?

- If no, then cause is either: bug in Thunderbird, in your Thunderbird profile, your mail provider. Please post into topic the contents of Help | Troubleshooting | copy text to clipboard

- If yes, (still in Windows safe mode) ... start Thunderbird normally
     -- If problem is still gone, then cause is a program loaded during windows startup.  Possibilities include: antivirus SW, virus/malware, background downloads such as program updates
     -- If problem is came back, then cause is likely a Thunderbird addon - eliminate them by disabling each one at a time in Tools | addons | extensions and restarting

- If results are unclear ... possibilities include temporary conditions such as contention from other running programs, downloads related to windows update, etc
(In reply to bettina.gartner@gmx.de from comment #2)
> Thanks for your suggestions. Here is my report: 1. There seems to be no
> freezing if I use Thunderbird in Windows safe mode (with activated add-ons).
> (I used it only for writing and saving a couple of emails because I needed
> to send these emails which is not possible in safe mode). Returning to
> Windows normal mode, freezing returns. 

This mean the caues is someting other than Thunderbird.

> 2. I installed version 45 beta. Freezing did not occur for the first hours;
> since then, it seems to be more frequent than before. 3. Starting
> Thunderbird in safe mode (in Windows normal mode) does not stop the freezing
> (as I checked already during the past 4 months in which I have tried more or
> less everything what is suggested on the web). 

Are you still having trouble with version 45?
Is so, is it gone if you install the beta from http://www.mozilla.org/en-US/thunderbird/all-beta.html

> Btw, my text modules (add-on Quicktext) ‚disappeared’, i.e. seem to have
> been deleted, during the same time period when I installed the version 45
> beta. Is it possible that this was caused by the installation of the beta
> version?

Quicktext has been updated.  bug 1209425 comment 30
Flags: needinfo?(bettina.gartner)
Whiteboard: [closeme 2016-05-15]
Apologies for answering late. I have investigated the problem of freezing again by differentiating between different kind of freezings because I have thought that different causes might differnet types of freezing which I did not recognize before because both problems started more or less simultaneously. 

So, I disabled, i.e. renamed msgfilterrules.dat which 'naturally' stopped type-one freezing (freezing when I add a new address to the filter) because it would not make sense to me to  add new addresses to the new msgfilterrules.dat that Thunderbird created. (Freezing when using the filter occurred in safe mode, i.e. seems in fact to be one cause.)

Then, I temporarily disabled anti-virus software before sending an email, but type-two freezing (freezing when I send an email) continued. (As I wrote before, I have anyway disabled windows defender by adding a new registry key.) 

Third, I additionally disabled the firewall before sending an email, but type-two freezing (freezing when I send an email) continued. 

In betweeen, type-three and type-four freezing (freezing when I write an email and when I save an email) also continued to occur. Yet, type-two freezing is the most frequent at the moment. 

 
> > 2. I installed version 45 beta. Freezing did not occur for the first hours;
> > since then, it seems to be more frequent than before. 3. Starting
> > Thunderbird in safe mode (in Windows normal mode) does not stop the freezing
> > (as I checked already during the past 4 months in which I have tried more or
> > less everything what is suggested on the web). 
> 
> Are you still having trouble with version 45?
> Is so, is it gone if you install the beta from
> http://www.mozilla.org/en-US/thunderbird/all-beta.html

Which kind of trouble: freezing? 

Thunderbird recently updated the beta version. Am I right if I suppose that it installed the version you suggest?

> > Btw, my text modules (add-on Quicktext) ‚disappeared’, i.e. seem to have
> > been deleted, during the same time period when I installed the version 45
> > beta. Is it possible that this was caused by the installation of the beta
> > version?
> 
> Quicktext has been updated.  bug 1209425 comment 30

Thanks for this. Unfortunately, it is not solved on my computer yet. (The problem is that templates.xml exists, but Quicktext does not indicate the templates in Thunderbird.) I suggest to focus on this problem if the freezing is solved.  

So, all known causes of freezing seem to be ruled out. Nonetheless, freezing continues. Wayne, do you have any other idea what I could do?
> Numerous users complain about this freezing problem which occurs in numerous variants.
Do you mean that many other users at your business also are having trouble?


(In reply to bettina.gartner@gmx.de from comment #5)
> Apologies for answering late. I have investigated the problem of freezing
> again by differentiating between different kind of freezings because I have
> thought that different causes might differnet types of freezing which I did
> not recognize before because both problems started more or less
> simultaneously. 
> ...
> So, all known causes of freezing seem to be ruled out. Nonetheless, freezing
> continues. Wayne, do you have any other idea what I could do?

Indeed, normally most of them would be revealed by safe mode but there are many other possibilities. Please go through the list at https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems


> So, I disabled, i.e. renamed msgfilterrules.dat which 'naturally' stopped
> type-one freezing (freezing when I add a new address to the filter) because
> it would not make sense to me to  add new addresses to the new
> msgfilterrules.dat that Thunderbird created. (Freezing when using the filter
> occurred in safe mode, i.e. seems in fact to be one cause.)
> 
> Then, I temporarily disabled anti-virus software before sending an email,
> but type-two freezing (freezing when I send an email) continued. (As I wrote
> before, I have anyway disabled windows defender by adding a new registry
> key.) 
> 
> Third, I additionally disabled the firewall before sending an email, but
> type-two freezing (freezing when I send an email) continued. 
> 
> In betweeen, type-three and type-four freezing (freezing when I write an
> email and when I save an email) also continued to occur. Yet, type-two
> freezing is the most frequent at the moment. 
> 
>  
> > > 2. I installed version 45 beta. Freezing did not occur for the first hours;
> > > since then, it seems to be more frequent than before. 3. Starting
> > > Thunderbird in safe mode (in Windows normal mode) does not stop the freezing
> > > (as I checked already during the past 4 months in which I have tried more or
> > > less everything what is suggested on the web). 
> > 
> > Are you still having trouble with version 45?
> > Is so, is it gone if you install the beta from
> > http://www.mozilla.org/en-US/thunderbird/all-beta.html
> 
> Which kind of trouble: freezing? 
> 
> Thunderbird recently updated the beta version. Am I right if I suppose that
> it installed the version you suggest?

Yes

> > > Btw, my text modules (add-on Quicktext) ‚disappeared’, i.e. seem to have
> > > been deleted, during the same time period when I installed the version 45
> > > beta. Is it possible that this was caused by the installation of the beta
> > > version?
> > 
> > Quicktext has been updated.  bug 1209425 comment 30
> 
> Thanks for this. Unfortunately, it is not solved on my computer yet. 

Unfortunately the fix is still awaiting approval for distribution
> Indeed, normally most of them would be revealed by safe mode but there are
> many other possibilities. Please go through the list at
> https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems

Already done in the past. What now?
Please provide the details requested there and also the sizes of your 5 largest active folders
If you still have difficulty please update the bug.
FWIW you are not the only person to report a problem on win10
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(bettina.gartner)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2016-05-15]
Hi Wayne, 
Apologies for answering late. The reason is that I still do not recognize a clear relationship between freezing and other activities of the computer. I think that the identification of the problem has been blurred thus far because I did not take into account that different causes might affect different types of freezing and that I probably missed to notice that different kinds of freezing started not simultaneously, but briefly one after the other. This means that disabling just one feature - filters or add-ons or av software – does not stop freezing because the other causes are always present. So, I permanently disabled the filter and all add-ons, but still don’t have a clear picture what happens when I disable the av software because, first, freezing occurs irregularly and, second, I lack the discipline to disable it before each email I send. 

(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #8)
> Please provide the details requested there and also the sizes of your 5
> largest active folders

What do means by active folders? In which superior folder?

I went through the check list, but did not finish yet because the descriptions are not always clear. Here are preliminary results: 

Steps 
1.	Are you using the newest update of Thunderbird? (do Help | About | Check for Updates, or visit [1]) 
Yes.
2.	Start Thunderbird in Safe Mode (instructions). If Thunderbird safe mode helps then visit Tools | Add-ons | Extensions and determine which add-on might be causing the problem by disabling/enabling individual add-ons and... 
o	Is add-on in the list of Problem Extensions? Lightning /calendar is an example. Ref: bug 441710, confirmed calendar perf bugs 
o	Contact the add-on author, and report the problem add-on at SUMO. 
See above. Add-ons are disabled, but freezing continues. 
3.	If you are running an MS-Windows OS, is Thunderbird better in Windows safe mode with networking enabled? 
Cannot be used to test the reasons for freezing while sending an email because sending an email via wifi is not possible in safe mode. 
Instructions: win10, win8, win7, winXP. If performance is improved, then suspect software such as antivirus or firewall not working properly with Thunderbird. Test with firewall or antivirus software disabled. If performance is better, try each steps to find which one helps : 
o	you should be running only ONE package, and no more, of each of the following: antivirus, firewall, malware 
o	check that you have the newest version of AV/firewall software 
o	with AV/firewall software turned on, uninstall Thunderbird, DELETE the Thunderbird PROGRAM directory (not data directory), download, reinstall, and retest Thunderbird. If using beta or Earlybird get it from channels page. 
o	if problem was gone with antivirus software turned off, then see AV performance issues for settings and information which may help. 
o	check with vendor's software support
Does not solve the problem
4.	If you have gmail accounts, is problem seen after unsubscribing the "All Mail" folder? see performance hit 
None.
5.	If you have newsgroup accounts, then in Account Settings|Server Settings disable "Check for new messages at startup". If problem is gone you may be seeing bug 185634, bug 541001, or [2]. 
None.
6.	Are any of these indexing methods enabled: 
o	MS-Windows Integrated Search, Thunderbird setting, try disabling it at Tools|Options|Advanced|General|System Integration|Allow Windows Search [3], [4], [5], [6], [7] 
No.
o	MS-Windows Search try disabling especially if the Thunderbird profile or a Thunderbird account has been moved from the default location [8]. If that helps, you can disable Windows indexing for your Thunderbird data. 
No.
o	Google Desktop Search (GDS)? Try uninstalling report from 2010. 
No.
o	Mac Spotlight Integration, Thunderbird setting, at Tools|Options|Advanced|General|System Integration| 
No.
7.	Are you on Windows, and did you move the Thunderbird profile or any Thunderbird account from the default location (%APPDATA%) to a different Windows directory? If yes, then MS-Windows Search will attempt to index everything Thunderbird is doing. Disable Windows indexing for your Thunderbird data. 
No.
8.	If Thunderbird memory usage is more than expected 
This link is corrupt.
…by hundreds of megabytes (MB), then perhaps one or more folders (internally a database) are not being closed, or some other bug. 
I do not see that memory usage is unusually high. 
Please : 
o	Get a diagnostic log of Thunderbird activity with MSGDB:5,timestamp using logging instructions.
The instructions are partially ununderstandable: „You can set up the batch file to be run using of these methods: double click the batch file, create a shortcut, add it to start menu, from a command window prompt, or from the start>run dialog.“ Double clicking opens a terminal window for a second. The instructions do not explain what should happen after double clicking the batch file.  
o	File a bug, then edit the new bug and attach the zipped log file using "Add an attachment". 
9.	Does problem resolve by disabling global indexing? Tools|Options|Advanced|General|Enable Global Search and Indexer (linux: Edit|Preferences|Advanced|... Mac: cmd , advanced tab) and restart Thunderbird. If the problem goes away: 
o	Does Thunderbird have extremely high IO, seem to be stuck on indexing per Tools|Activity Manager, or is global-messages-db.sqlite (file used for global search) in your profile folder too big? A rule of thumb is it should not be more than 10-20% of the combined the size of all messages (in directories Mail and ImapMail). 
	Rename global-messages-db.sqlite and restart Thunderbird. global-messages-db.sqlite will rebuild but your system load will be high until all your messages are reindexed. 
	Please file a bug about your problem. 
global-messages-db.sqlite is not too big according to the above definition. 
10.	Is there an indexing or Search Messages (Ctrl+K) problem, or is global-messages-db.sqlite corrupt? Shut down Thunderbird, in your profile keep the sqlite file but rename it for later diagnosis, and restart Thunderbird. Note, rebuilding the global index may take a long time and use CPU resources, but it should not redownload your mail [9] [need additional references] 
The search tool works fine. 
11.	Are any folders 2-4GB in size? Large folders take lots of memory and time to load. Check using foldersize add-on. Also Help | Troubleshooting lists large folders. 
Again: which folders on which level? (As I wrote in the past, the same profile can be handled by a computer with an atom processor an 2 GB Ram. In this light, it should also be handled by a computer with a Core M processor and 8 GB Ram.)
12.	Does disabling interval checks for new mail help? (Account Settings | Server Settings | uncheck "Check for new messages every N minutes"). 
No. 
If it does help, then ... 
o	Is a low value (1-3 minutes) specified for checking for new mail or draft autosave? does changing it to 4-10 minutes help - go to, respectively, Account Settings | Server Settings | Check for new messages every N minutes ... and Options | Composition | General | Auto Save every N minutes. 
o	What type of mail account is this (imap or pop), and how many other accounts are the same type? 
o	Are you absolutely certain that antivirus software is not to blame? 
13.	Are any non-Inbox IMAP folders configured to check for new messages (via "always check this folder" in properties)? Or have hidden preference mail.check_all_imap_folders_for_new set to true? These increase load on both Thunderbird and the mail server. bug 729504 
No Imap folder.
14.	Do you have thousands of contacts in your address book? (possible related issues: google contacts add-on], [10] 
No address book.
15.	Is panacea.dat cache file in your profile too big? (>10MB for most people is probably too big. Rule of thumb for panacea size with thunderbird stopped: #folders*0.3k. See bug 65086, bug 1084276) 
193 KB (no).
16.	If error message indicates a script problem, 
No script problem.
please set javascript.options.mem.log to true and provide a couple log entries of the form CC(T+1186.6) collected: 131 (131 waiting for GC), suspected: 98, duration: 274 ms. 
o	Has a proxy ever been defined, and is it working correctly or was the proxy removed? (A proxy can cause "Unresponsive script") 
17.	If using high CPU, check to see if mozilla updater.exe is running in taskmgr [11] 
No. 
18.	Is your Thunderbird profile or any part of Thunderbird on a non-local hard drive, i.e. a "special" drive or mount point?
No.
If yes, does it preform better when it is moved to the local disk? 
o	USB drive? USB is slower compared to a local disk. Some are terrible. Make sure you've got a good one. 
o	network drive? eg SMB, NFS, AFS, samba 
o	SSD? 
19.	If you suspect slow or high disk activity, on a Windows sytem make sure you have at least 20% free disk space and then do defrag. 
Lots of space left.
20.	If you have RSS news reader account, 
No RSS.
in Account Settings|Server Settings disable "Check for new messages at startup". If problem is gone you may be seeing something like bug 551144 (fixed in version 13). 
21.	Common resource requirements/maintenance steps: 
o	Do you have the minimum hardware requirements, and enough memory? Note, even having the minimum or recommended sized system may not be sufficient for your workload. 
o	Consider the possibility of hardware problems [12], [13], [14] 
o	Are your folders well maintained, "too large", or perhaps broken: 
	Do you see high memory or long delay when opening a specific folder? Or when moving message to a specific folder? 
	Do any folders lose their sort order or column settings? 
	Do you empty trash and junk on a regular basis? You should not be using them for long term storage. Does performance improve if you empty them? (see File menu) 
	Do any Inbox or filtered folders have several thousand messages? If so, especially for Inbox, consider moving some messages to another folder. Perhaps use Archive. 
	If you are using a version prior to 5, do you regularly (daily or weekly) File > Compact Folders? 
22.	If you are running an old version of linux, consider updating. hangs on Ubuntu 10.04, 14.04 works 
23.	If a bug report in References below matches your problem, please add yourself to the bug report and add details about your situation. 
24.	If you do not find an existing bug report and still see a problem ...
I forgot. What kind of freezing do the other users of windows 10 report?
(In reply to bettina.gartner@gmx.de from comment #11)
> I forgot. What kind of freezing do the other users of windows 10 report?

General slowness. But certainly not a universal problem for win10 users - isolated cases.

Thanks for all the detail.  You had previously stated the problem is not seen with Windows stated in safe mode. So indicates something in Windows is causing a problem - the typical issues are AV, firewall or Windows Indexing+Search
Resolution: INCOMPLETE → INVALID
If  you have determined what is causing your freezing please let us know.
Summary: Regular freezing of Thunderbird with Windows 10 (since 4 months despite several updates!) → Regular freezing of Thunderbird with Windows 10 (since 4 months despite several updates!). OK in Windows Safe Mode
I forgot to metion, that it may help to check Windows' taskmgr process tab with "show processes from all users" enabled, and click the CPU column header to order the processes on CPU% to see which is using the most CPU.
Hi Wayne, 

Thanks for your diverse suggestions, yet I have checked those potential causes several times as I think I have mentioned three times (or more often)(didn't I?).

My notebook with the freezing Thunderbird disappeared a couple of weeks ago on the postal way from the Lenovo repair service back to my home (it was the second time I sent it in for repair within 3 months because the entire system did not work sufficiently fluently). There seems to be a general incompatibility between hardware and software (windows 10) in the Lenovo Yoga series (starting from Yoga 3 pro or earlier). On the web, I wound a report that described the same series of symptoms I experienced: freezing after wake-up from hibernation; weird, inaccurate battery gauge; no charging of battery anymore; and many other problems. (This report, however, did not mention the freezing of Thunderbird.) And the author mentioned that colleagues/friends reported similar problems. However, this imcompatibility does not seem to occur in all Lenovo Yoga devices, but just some of them (otherwise there should be more complaints about it on the web). 

In sum, thanks so much for your help. I hope that this problem will never occur again on another notebook. (Too bad that the cause could not be identified.)
Hi,
I've news with this issue:
I've got at least 3 laptop with windows 10 with 30 seconds of freezing several times a day.
Thunderbird 45.3.0
When I stop the "Windows Search service" it immediately unfreezes.
Thanks for your great work.
Guilain
Component: Untriaged → Message Compose Window
Summary: Regular freezing of Thunderbird with Windows 10 (since 4 months despite several updates!). OK in Windows Safe Mode → Regular freezing while writing, sending or saving email with Windows 10 (since 4 months despite several updates!). OK in Windows Safe Mode. Cause: Windows Indexer aka "Windows Search service"
My Thunderbird 45.6.0 freezes after updating to win 10 version 1607. It happens after pressing send.

I already set Thunderbird Local and Roaming working dirs from being indexed, and even stopped the index service (this had solved the problem in previous windows versions but not now).

I already set the same dirs from being scanned by Windows defender, and even stopped the real time protection.

I already added special entries in the windows firewall for allowing Thunderbird.exe to initiate any kind of network connections.

But Thunderbird still freezes while sending mails!!

When asking Task manager to analyze the "wait chain" it says: One or more Thunderbird threads are waiting to finish Network I/O.

How can this be solved??
I had the same problem: TB freezing as soon as a message was being sent. 

I discovered this morning this thread and disabled the feature in TB advanced options 'Allow Windows Search ...'. I've been sending more emails now this day and the problem hasn't occurred again. It is solved!! :-D

I've been having this issue since many months. Sometimes there were better days than other. I tried everything including Safe Modes, Disabling antivirus, and some other possible solutions found on the MS support website, nothing of these has ever helped. Finally I got rid of it... Thanks!!
Many thanks to the solution by Guilain in Comment #16. My torment of writing emails in TB has now been relieved!!

Since purchasing a Toshiba laptop in 2016 with W10 already installed, this identical freezing and/or hanging problem immediately began occurring after installing Thunderbird. With thanks to this reported Bug and all of the dialog, I tried a simple solution mentioned by Guilain and it worked! That is, unchecking "Allow Windows Search to search messages" under System Integration, General tab under Advanced tab, under Options, and then under Tools in the Menu Bar of TB 54.0.
THANK YOU Guilain!!! And also thanks to bettina.gartner@gmx.de and Wayne Mery for all the digging they did.  This has been driving me (and several others here!) crazy. I've been battling this issue for months, esp the last two on Win 10.  Stopping Windows Search service does the trick.  

But very unclear to me why since supposedly nothing of TBird is being searched:
-- I have "Allow Windows Search " in TBird off
-- neither my profile folder (or any subfolder) is included in Windows' Search Indexing.  
-- Ditto for my APPDATA/local/Thunderbird and APPDATA/roaming/Thunderbird
-- virtually no other area is included in Windows Search Indexing either

I posted this problem in the Forum last June, and will echo this reply there, to help others.  See
https://support.mozilla.org/en-US/questions/1165158

Anyhow if anyone has any clues how to get around this without turning off Windows Search Service entirely, please post here.
I observed that freeze occurs when Thunderbird is creating %TEMP%\nsemail-*.eml file.
(In reply to thekinoue from comment #21)
> I observed that freeze occurs when Thunderbird is creating
> %TEMP%\nsemail-*.eml file.

I think Windows should not be indexing files in %TEMP%.  

thekinoue,
BaliDave,

If you look at %TEMP% advanced folder properties, is the checkbox enabled for "Allow files in this folder to have contents indexed in addition to file properties"?


FWIW, https://support.mozilla.org/en-US/questions/1117146?page=2#answer-885401 documents the case where a profile was moved to a non-standard location
Flags: needinfo?(thekinoue)
Flags: needinfo?(dvanrooy)
Duplicate of this bug: 1436278
Duplicate of this bug: 1437511
please see the question in comment 11.
Flags: needinfo?(nospam)
My issue describes something else. Thunderbird does't freeze i.e. not respond anymore, but it doesn't finish the Save Draft operation, or the Save to Sent folder operation. Different bug.
Flags: needinfo?(nospam)
Thanks Wayne! I had this problem since I converted from Windows 7 to Windows 10. I was surprised to see in Control Panel| Indexing options that the Temp directory was scanned. Non of my other computers have this setting. To  resolve the issue:
Click on Modify and in the new window click on the Temp directory name in the lower pane with the name Summary of selected locations. Click OK and on Modify again to verify the change. That's it! A shame that it took me so so long to to find out.
Erik
I've been having issues like this with Thunderbird for years now but currently worse. 
I've tried most of the "fixes" found so far. I've removed indexing from TB. I've made sure no temp directory indexed by winsearch, I've optimized sqllite files, etc, etc
I truly have a setup with many imap accounts (gmail) but my issues (40-60 seconds freezes) appear normally when I am in the middle of writing an email... which makes it even more frustrating.
Shame... I am about to give up, consider alternatives or perhaps move to webemail like almost everyone this days
You need to log in before you can comment on or make changes to this bug.