Closed Bug 1284464 Opened 4 years ago Closed 4 years ago

Missing arrow indicating submenus in the context menu

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 + fixed

People

(Reporter: florian, Assigned: stefanh)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screenshot
See attached screenshot. The ">" arrow at the end of the "This Frame" context menu item is missing on current 50a1 trunk builds (on Mac at least).
I can reproduce both on the internal retina screen and the external low DPI screen.

Works correctly on release (47) builds.
[Tracking Requested - why for this release]: Visible regression in Fx 50.

mozregression says https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=259c39227fd6e1ccbc244b39bb6c02136c614cee&tochange=22f34da350173fda29c5048974e6d99e2db028e6 -> bug 1279017

In case this matters, I'm running OS X 10.10.4 (14E46).
Blocks: 1279017
Flags: needinfo?(stefanh)
I see what I did wrong (and OS version actually matters here)...
Assignee: nobody → stefanh
Flags: needinfo?(stefanh)
Component: Menus → Widget: Cocoa
Product: Firefox → Core
Version: unspecified → Trunk
Attached patch 1284464.1.diffSplinter Review
I obviously slipped... thanks to Florian who noticed this.
Attachment #8768103 - Flags: review?(mstange)
Comment on attachment 8768103 [details] [diff] [review]
1284464.1.diff

Review of attachment 8768103 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like I slipped as well.
Attachment #8768103 - Flags: review?(mstange) → review+
Pushed by stefanh@inbox.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1bd2b6599c55
Missing submenu arrows in xul menus on Mac OS X 10.9-10.10. r=mstange.
Tracking 50+ for this visible Mac regression.
Duplicate of this bug: 1284943
https://hg.mozilla.org/mozilla-central/rev/1bd2b6599c55
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.