2,000 instances of "NS_ENSURE_SUCCESS(status, status) failed with result 0x805303F4" emitted from netwerk/protocol/http/nsCORSListenerProxy.cpp during linux64 debug testing

RESOLVED FIXED in Firefox 53

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: erahm, Assigned: erahm)

Tracking

(Blocks 1 bug)

Trunk
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed)

Details

(Whiteboard: [necko-backlog])

Attachments

(1 attachment)

> 1740 WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x805303F4: file netwerk/protocol/http/nsCORSListenerProxy.cpp, line 553

This warning [1] shows up in the following test suites:

>    638 - [TC] Linux64 mochitest-plain-e10s-6 6
>    638 - [TC] Linux64 mochitest-6 6
>     95 - [TC] Linux64 mochitest-5 5
>     95 - [TC] Linux64 mochitest-plain-e10s-5 5
>     83 - [TC] Linux64 web-platform-tests-e10s-4 4
>     75 - [TC] Linux64 web-platform-tests-4 4
>     31 - [TC] Linux64 web-platform-tests-e10s-3 3
>     31 - [TC] Linux64 web-platform-tests-3 3
>     16 - [TC] Linux64 mochitest-plain-e10s-2 2
>     16 - [TC] Linux64 mochitest-2 2
>      9 - [TC] Linux64 mochitest-7 7
>      4 - [TC] Linux64 web-platform-tests-2 2
>      4 - [TC] Linux64 web-platform-tests-e10s-2 2
>      2 - [TC] Linux64 web-platform-tests-e10s-9 9
>      2 - [TC] Linux64 web-platform-tests-9 9
>      1 - [TC] Linux64 mochitest-plain-e10s-7 7

It shows up in 54 tests. A few of the most prevalent:

>    212 -        dom/tests/mochitest/fetch/test_fetch_cors_sw_reroute.html
>    212 - [e10s] dom/tests/mochitest/fetch/test_fetch_cors_sw_reroute.html
>    212 -        dom/tests/mochitest/fetch/test_fetch_cors_sw_empty_reroute.html
>    212 - [e10s] dom/tests/mochitest/fetch/test_fetch_cors_sw_empty_reroute.html
>    201 -        dom/tests/mochitest/fetch/test_fetch_cors.html
>    201 - [e10s] dom/tests/mochitest/fetch/test_fetch_cors.html
>     59 - [e10s] dom/security/test/cors/test_CrossSiteXHR.html
>     59 -        dom/security/test/cors/test_CrossSiteXHR.html
>     40 - [e10s] /fetch/api/cors/cors-redirect-credentials.html
>     40 -        /fetch/api/cors/cors-redirect-credentials.html

[1] https://hg.mozilla.org/mozilla-central/annotate/214884d507ee/netwerk/protocol/http/nsCORSListenerProxy.cpp#l553
It's interesting to me that the line at fault occurs earlier in execution than the lines that bug 1279324 added to that method. I'm not sure what to make of that; maybe we're suddenly causing a bunch of preflights in tests to fail now.
(In reply to Josh Matthews [:jdm] from comment #2)
> It's interesting to me that the line at fault occurs earlier in execution
> than the lines that bug 1279324 added to that method.

Ah good point, I think the line normalization in my bisection code might be messed up. I'll take a look and re-run.
i have run some of the tests you listed with and without my patch and i'm failing to see an increase in the number of nsCORSListenerProxy warnings between the two.

here are the exact steps i took:

1. ./mach mochitest dom/tests/mochitest/fetch/test_fetch_cors_sw_reroute.html &> log_with_patch.txt
2. hg backout -r e5387a7d0920 --no-commit
3. ./mach build binaries
4. ./mach mochitest dom/tests/mochitest/fetch/test_fetch_cors_sw_reroute.html &> log_without_patch.txt

log_with_patch.txt contain 212 instances of "WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x805303F4: file /home/decky/src/mozilla-central/netwerk/protocol/http/nsCORSListenerProxy.cpp, line 553". log_without_patch.txt contains the same number (when the line number is corrected).

i repeated these steps for dom/tests/mochitest/fetch/test_fetch_cors_sw_empty_reroute.html and /fetch/api/cors/cors-redirect-credentials.html with analogous results.

here's a diff of the backout: https://gist.github.com/deckycoss/83e8e677b33db6e33d056262a492f550
Flags: needinfo?(coss)
The script was indeed confused by the line number changes, sorry for the confusion (unfortunately normalization isn't an option here due to how generic the warning is, it's used other places in the same file). Apparently this warning has been around since as far as I can bisect (2016-04-01).

So there's still a bunch of warnings, but not because of bug 1279324.
No longer blocks: 1279324
Whiteboard: [necko-backlog]
Duplicate of this bug: 1290289
This continues to be a top warning and has become somewhat more verbose.
Summary: 1,700 instances of "NS_ENSURE_SUCCESS(status, status) failed with result 0x805303F4" emitted from netwerk/protocol/http/nsCORSListenerProxy.cpp during linux64 debug testing → 2,000 instances of "NS_ENSURE_SUCCESS(status, status) failed with result 0x805303F4" emitted from netwerk/protocol/http/nsCORSListenerProxy.cpp during linux64 debug testing
In bug 1152574 we stopped warning in the web console but started warning in the
console instead. This removes that warning as well.

Patrick, feel free to redirect.

MozReview-Commit-ID: 2TYUngN8DBW
Attachment #8810635 - Flags: review?(mcmanus)
Assignee: nobody → erahm
Status: NEW → ASSIGNED
Attachment #8810635 - Flags: review?(mcmanus) → review+
https://hg.mozilla.org/mozilla-central/rev/8a79f4aaa4be
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.