If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Improve visibility of localized builds on mozilla.org

RESOLVED DUPLICATE of bug 1278315

Status

www.mozilla.org
Pages & Content
RESOLVED DUPLICATE of bug 1278315
a year ago
a year ago

People

(Reporter: flod, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Issue was pointed to me by a localizer at a recent event, and I can't agree more.

Let's say you're using a system set to en-US, and try do download Firefox for another language. How exactly are you supposed to do it?

Example, I use Chrome and open getfirefox.com, I get here
https://www.mozilla.org/en-US/firefox/new/

What if English is not the language I want, but I want Armenian? There's a very hidden link in the footer that brings me to https://www.mozilla.org/en-US/firefox/all/, but it's way less visible than the old "Other system and languages" link that used to be under the download button.

Now, let's say you want Developer Edition in Armenian. 
https://www.mozilla.org/en-US/firefox/channel/

Where do I download it? There's a language switcher at the bottom of the page, but what if the page is not localized but we have localized builds? Is there a /all equivalent for Beta and Aurora? There's definitely no link in the footer here.

We really need to improve this and get better visibility for localized builds.
Thanks Flod, this is something that's already been reported as an outstanding issue. Closing as a duplicate of Bug 1281003. Agree we need to find a way to improve this.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1281003
Duplicate of bug: 1278315
You need to log in before you can comment on or make changes to this bug.