Closed Bug 1278315 Opened 5 years ago Closed 5 years ago

Restore "Firefox for Other Platforms & Languages" link on /channel download page so that people can find win64 and localized builds on /all/ page

Categories

(www.mozilla.org :: Pages & Content, defect, P3)

Production
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1299947

People

(Reporter: bkelly, Assigned: kohei.yoshino)

References

(Blocks 1 open bug, )

Details

(Keywords: 64bit)

Currently there is no way to download a 64-bit beta or dev-edition firefox from the website.  We should at least offer these links somewhere people can find them.

Note, there are links for 64-bit windows for release here:

https://www.mozilla.org/en-US/firefox/all/#en-US

And for nightly here:

https://nightly.mozilla.org/
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Component: Webdev → Pages & Content
Product: mozilla.org → www.mozilla.org
Version: other → Production
https://www.mozilla.org/en-US/firefox/channel/ and
https://www.mozilla.org/en-US/firefox/developer/ had a link to
https://www.mozilla.org/en-US/firefox/developer/all/

However, it was removed recently due to the download button simplification work. Also, the channel page itself has been orphaned :(

If you'd like to offer win64 builds by default, we can simply modify the download button with 2 lines of CSS:

https://github.com/kyoshino/bedrock/commit/58c4273
So who can give a green light here? As I said it's technically easy to show win64 download buttons since we are already sniffing UA strings and those are just hidden with CSS so far, though we still need some additional tests.
From the dev-platform thread I think its up to Javaun?
Flags: needinfo?(jmoradi)
Thanks for helping out, Kohei.
Forwarding the needinfo to Peter Dolanjski, the new product manager for Win64.

FWIW, I don't see any reason to delay adding links to the 64-bit installers on the Beta and DevEdition download pages, considering we already link to the 64-bit installer on the Firefox Release download page.
Flags: needinfo?(jmoradi)
Priority: -- → P3
(In reply to Chris Peterson [:cpeterson] from comment #5)
> Forwarding the needinfo to Peter Dolanjski, the new product manager for
> Win64.
> 
> FWIW, I don't see any reason to delay adding links to the 64-bit installers
> on the Beta and DevEdition download pages, considering we already link to
> the 64-bit installer on the Firefox Release download page.

Agreed, please go ahead and add in links to the beta and dev-edition pages.
Duplicate of this bug: 1286886
2 months now since no way to download 64 bit beta and developer edition.
(In reply to kalviskajaks from comment #8)
> 2 months now since no way to download 64 bit beta and developer edition.

The 64-bit builds of Beta and Developer Edition are available here:

https://www.mozilla.org/firefox/beta/all/

https://www.mozilla.org/firefox/developer/all/
According to an email thread, we are likely in agreement that the "Systems & Languages" link under a download button should be added back. Those /all/ pages remain orphaned otherwise.
Summary: add 64-bit windows download links for beta and developer edition → Restore "Systems & Languages" link so that people can find win64 and localized builds on /all/ page
Duplicate of this bug: 1281003
Duplicate of this bug: 1283506
Duplicate of this bug: 1286508
Kohei, do you have time to work on this bug for the /channel download page?

The /new download page is being redesigned (in bug 1295181) to make 64-bit Firefox and localized builds easier to find, but we would still like links to 64-bit and other localized builds on the /channel download page. I asked jpetto in bug 1295181 if the /new page redesign should also be used on the /channel page.

https://www.mozilla.org/firefox/new/
https://www.mozilla.org/firefox/channel/
Blocks: 1295181
Flags: needinfo?(jon)
Summary: Restore "Systems & Languages" link so that people can find win64 and localized builds on /all/ page → Restore "Firefox for Other Platforms & Languages" link on /channel download page so that people can find win64 and localized builds on /all/ page
Just want to clarify that the /new page is *not* being redesigned. We are experimenting with adding a single link below the current download button that will either send users to /firefox/all or open a modal with direct download links to all platform builds.

The results of this test may lead us to (again) add a link underneath *all* download buttons that sends users to /firefox/all, which would impact the download buttons site-wide (including on /firefox/channel).

The team is aware of the current poor state of accessing downloads for other platforms and languages, but I don't know what the priority/timeline is for the work.

needinfo'ing jbertsch to hopefully add some clarity around priority.
Flags: needinfo?(jon) → needinfo?(jbertsch)
Thanks for the clarification. Regardless of whichever changes are made to the /new page, it seems like we should still make the additional platform downloads more discoverable on the /channel page. Restoring to the "Systems & Languages" link (since renamed "Firefox for Other Platforms & Languages" on the /new page) seems like a simple solution.

btw, the Firefox team has decided to also provide a choice between 32- and 64-bit builds in the stub installer itself (bug 797208) so users won't need to hunt for the 32- or 64-bit builds on the /new or /all pages. Thus the urgency to make the additional platforms more discoverable is somewhat lessened.
I think bug 1288544 is also relevant here. It's about Nightly.
Hi All-

We are working on this project here https://bugzilla.mozilla.org/show_bug.cgi?id=1299947

The new design of the pre-release downloads page will include a link to the appropriate /all pages.

I'll attach the preliminary design to that bug.  

I'm going to close this bug as a dupe of that one.

Thanks for all the discussion,
Jen
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jbertsch)
Resolution: --- → DUPLICATE
Duplicate of bug: 1299947
You need to log in before you can comment on or make changes to this bug.