App task bar mail icon doesn't show new POP mail if mail window closed (after logon within session)

VERIFIED DUPLICATE of bug 71105

Status

MailNews Core
Filters
VERIFIED DUPLICATE of bug 71105
16 years ago
10 years ago

People

(Reporter: Marcus Münch, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When you receive new mail that is moved into a folder via mailfilter, the green
arrow at the left bottom of the window will not show that you have new mail. You
have to start the Mail/News-Client and check manualle if you have mail.
This works correct, if you receive mail, that is not filtered.

Expected: Green arrow in statusline should always show that you have new mail,
not only for unfiltered mail

Build: 2002030308

Works fine with milestone 0.98

Comment 1

16 years ago
build 2002032108 on Linux
I seem to be experiencing similar symptoms. Ever since I started using the
message filters feature, biff is neither beeping at me nor showing its little
green arrow-- although I can indeed confirm it actually running. I have
monitored my mail server, observed incoming messages get stored in my mailbox,
and then observed them dissapear as biff downloads them (I have the pref set to
download messages automatically)

Comment 2

16 years ago
This works for me with mar25 trunk build, linus rh6.2.
I tried POP account with the 'download new mail automatically' option set. New
mail arrives, is filtered to folder, sound goes off. Green arrow shows at
account level, folder level and in mail icon in task bar.

Is your filter destination folder on the same account or are you going to
another account?

Comment 3

16 years ago
Reporter: please try on a more current build and if you still have the problem,
let us know what kind of account you're using and where/what account your filter
destination folder(s) is.

There was some recent problems with unread counts being updated ... fixed on
mar20 or 21.  JPaige -- can you try again on a little later build and let me know?  

Comment 4

16 years ago
On win98 IMAP acct as well as on linux, I also see the application task bar mail
icon green arrow go on for filtered mail.

However,  if you receive new mail and some stays in the inbox (not filtered)
when you read the new mail in the inbox the task bar's mail icon loses its green
arrow even though there is still new mail in the filter destination.  The folder
and account in mail window still have the green arrow, but task bar icon loses
the green.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: Mozilla does not show new mail when filtered → Mozilla does not show new mail when filtered (taskbar mail icon)
(Reporter)

Comment 5

16 years ago
I can confirm comment #4 on Windows Xp, build 2002032503
(Reporter)

Comment 6

16 years ago
Addition to my last comment: on build 2002032503, Windows XP, the envelope in
the tray tells me that I still have 9 unread mail, although I have already read
them (POP3 mail)

Comment 7

16 years ago
Okay. I retested this vigorously with Linux Build 2002032608

I am no longer certain whether the problem I am experiencing is the same one ans
the report or a different one, but it is certainly a problem. Permit be to describe:

I set my mail-checking interval to 3 minutes.

I left one browser window open, and mailnews was closed entirely (but I did make
sure to open and close it once first because of bug 71105 )

I then mailed myself from a separate account on a separate computer, and waited
much longer than three minutes. No green biff arrow, no biff beep.

I then opened mailnews, and my message showed up immediately.

I disabled "automatically download any new messages" and repeated the test. Same
results, no arrow, no beep

I then disabled all of my filters (all of my filters are spam-killers that
delete the message, rather than moving it anywhere. None of my test messages
would have triggered any of the filters)

I got the same results with filters disabled. no beep, no arrow.

I then repeated the test once more, leaving mailnews open. In this case, it
worked perfectly. After a few minutes, I heard the beep, and the little arrow
went green.

So, I would conclude that biff/mail-notification is not firing at all unless
mailnews is open. The state of ones mail filters, and the state of the
automatic-download pref seem to be irrelevant.

Whether this is the same problem the reporter was describing, I cannot say.

Comment 8

16 years ago
My tests were with mail open, I didn't get from the description that mail wasn't
open.   I'll double-check when mail is closed, but it sounds then that this is
another report of bug 71105.

Comment 9

16 years ago
<mostly-off-topic>
bug 71105 is about the fact that you must start mailnews *AT LEAST ONCE* in
order to get logged in to your mail accounts, thus allowing mail notification to
work. The symptom I am seeing is that mailnews is not open *RIGHT NOW* mail
notification does not work, so if my symnptom is not related to this bug, then
it needst to be filed a s a separete bug, it is not a dup of bug 71105
</mostly-off-topic>

Comment 10

16 years ago
We're not on the same wavelength about the report in 71105, but whatever. The
issues have been muddied a little and I'll try to clarify the summaries or log
any needed separate issues when I get a chance (I'm not currently where I can
retest this reported issue, but will do so tomorrow).
(Reporter)

Comment 11

16 years ago
In build 2002032708 there is another problem: I get the notifier in the tray the
first time I check mail after starting mozilla. The mails get filtered and are
moved into the correct folders, which are marked by the green folder. I read all
messages and the green marker at the folder disappears, but the envelope in the
tray still tells me that I have unread mail, which is not true. I first saw this
problem in build 2002032503, but I don't know when it appeared first.

Comment 12

16 years ago
Comment #11 is an entirely different issue.  I believe a duplicate... will look
for it. 

As to the original issue here where the message icon in the task bar doesn't get
green arrow when filtered mail fires:  I just tried again on win98 in mar26 when
mail was closed after having logged in within the session.  The mail icon in the
browser task bar got a green arrow upon 3 different tries of getting filtered
mail (again -- mail window was not open).  So this worksforme in the trunk. 
Will leave it up to racham and navin to decide whether we resolve or keep
looking into it.

I will separate the bug where the green arrow goes away after reading the
Inbox/unfiltered messages as stated in my comment #4.

Comment 13

16 years ago
OK, more info, more tries using mar28 commercial trunk build on win98 and linux
rh6.2:  
1.  Works fine for unfiltered or filtered mail when mail window is closed (had
been opened,account logged in within session) if IMAP account. 
2.  Does not work for unfiltered or filtered mail when mail window is closed
(had been opened, account logged in within session, automatically download new
mail is enabled) if POP account.
3.  Works fine if mail window is open for IMAP or POP account.

So, I'm thinking this bug should be particular to POP only, mail window closed
and that it doesn't matter as to whether the mail is filtered or not... OK with
everyone?   I'm changing the summary line.

Other issues log separately, including message counts or new system tray mail
notification and alerts for win32.
Summary: Mozilla does not show new mail when filtered (taskbar mail icon) → App task bar mail icon doesn't show new POP mail if mail window closed (after logon within session)

Comment 14

16 years ago
*** Bug 141043 has been marked as a duplicate of this bug. ***

Updated

16 years ago
QA Contact: laurel → sheelar

Comment 15

16 years ago
*** Bug 141043 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
the problem I described in comment #7 is covered by bug 134480 "Does not
automatically check for new mail if Mail/News window is not open"

Updated

16 years ago
QA Contact: sheelar → stephend

Comment 17

15 years ago
Is this a dup of bug 71105?
Depends on: 71105
Yes, this is a dup of bug 71105

*** This bug has been marked as a duplicate of 71105 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
No longer depends on: 71105
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.