Closed Bug 12895 Opened 20 years ago Closed 20 years ago

[Tree][FEATURE] Need a way to scroll to a specific treeitem

Categories

(Core :: XUL, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: scottputterman, Assigned: alecf)

References

Details

In mailnews, when I perform an operation like NextMessage, if the newly selected
message header is offscreen, I need to be able to scroll to it.
moving to m14
Target Milestone: M14
Assignee: hyatt → putterman
I'll take this. cc'ing bienvenu who expressed interest in it.
Blocks: 15008
*** Bug 15098 has been marked as a duplicate of this bug. ***
Linux (1999-10-11-14-M11) Commercial
Win32 (1999-10-11-15-M11) Commercial
Mac (1999-10-11-14-M11) Mozilla

The same problem occurs to Go|Next|Flagged Message. When the "flagged" message
is below the split bar, it does not show the newly selected flagged message in
the thread pane, I have to manually scroll the vertically bar to find it. Since
bug 15098 was marked dup. of this one, I am adding this bug here. If you
disagree, please let me know.
reassign these tree bugs to me.
Note to self: add putterman to the CC when you see this!
Status: NEW → ASSIGNED
Target Milestone: M14 → M11
I'm partly done with this.
I've got the Frame side implemented, just trying to figure out how to
communicate from the DOM to the frames. (need to talk to hyatt)

I'm doing this for M11 because it's a good lowhanging bug that gets me familiar
with the tree, and requires some plumbing that we'll use in other bugs.
Target Milestone: M11 → M12
M12. Would still take this for M11, but wouldn't hold for it.
Blocks: 17907
Summary: Need a way to scroll to a specific treeitem → [Tree] Need a way to scroll to a specific treeitem
I've implemented EnsureRowIsVisible, so the next step is hooking this up to the
DOM API.
Priority: P3 → P2
Blocks: 18471
Summary: [Tree] Need a way to scroll to a specific treeitem → [Tree][FEATURE] Need a way to scroll to a specific treeitem
giving me rest of phillips open qa contact bugs, sorry for spam
Target Milestone: M12 → M13
Blocks: 19504
Blocks: 21469
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
hey guess what.. this is done!
I'll be honest, I haven't tested it, but I'm kinda tired right now. I'm going to
mark fixed and then work on testing this with putterman. The two possible
problems are:
- the tree frame that I get from GetPrimaryFrameFor is actually the tree's outer
frame, so the QueryInterface will fail
- the getRowIndexOf function may be incorrect... but it's accessable from JS, so
we can test it seperately.

you can actually call ensureContentIsVisible() on any content node in the tree -
a tree cell, row, or any arbitrary content node you add, it will figure out what
the content's row is, and bring that row into view.
(thanks to brian ryner for the midnight code review too)
Great!  This will be the first thing I try out when I get in this morning.  I'll
hook it up to Next Message.
qa contact to lchiang for verification in mail
QA Contact: paulmac → lchiang
Linux (2000-02-16-08 M14)
Win32 (2000-02-15-16 M14)
Mac (2000-02-16-08 M14)
Scrolling to a specific treeitem works well for both Go|Next|Unread Message and
Go|Next|Flagged Message .
Status: RESOLVED → VERIFIED
No longer blocks: 17907
No longer blocks: 18471
You need to log in before you can comment on or make changes to this bug.