Closed Bug 1289824 Opened 3 years ago Closed 3 years ago

Add "missing talos" jobs for TaskCluster jobs

Categories

(Tree Management :: Treeherder, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: armenzg, Assigned: bstack)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Once we have Talos jobs running on Treeherder we will want the ability to trigger any missing talos jobs as we can do now for Buildbot jobs.
I assume the jobs will be running in TaskCluster, which requires hardware (and I expect there's a bug out there somewhere representing that project?).

As I understand it, this bug is a *treeherder* bug to allow backfilling those jobs?  How is it different from bug 1289823?
Flags: needinfo?(armenzg)
Two different methods.

One of them trasverses revisions for a specific job.
This one add all talos jobs for a specific revision.
Flags: needinfo?(armenzg)
Summary: Add missing talos jobs for TaskCluster jobs → pulse_actions - Add "missing talos" jobs for TaskCluster jobs
Assignee: nobody → bstack
Removing pulse_actions from the bug summary since this might be implemented under taskcluster-treeherder.
Summary: pulse_actions - Add "missing talos" jobs for TaskCluster jobs → Add "missing talos" jobs for TaskCluster jobs
Duplicate of this bug: 1297690
No longer blocks: 1325654
Is this still blocking our push to tier 1 for Linux/Android next week?
As I understand it, this does not block anything since it is just a convenience. I want to finish this by next week regardless, so it might not be an issue either way.
this will not be a blocker, but it is a huge time saver
I'm going to remove this from the migration flowchart, then.  I trust that Joel will make sure we get it done :)
this is still important to get done, it is a commonly used sheriffing feature that buildbot supports and taskcluster does not.  Please leave it on the list of things to resolve as part of the migration.
This is being worked on actively. Just wading through treeherder and pulse_actions now.
Status: NEW → ASSIGNED
Attachment #8825838 - Flags: review?(jmaher)
Once these two patches are in good shape, we can land them (gecko change first). As I understand it, we still want to trigger pulse_action so that it can start the buildbot talos jobs, and also submit a tc action task for creating the tc talos jobs. If that's a misunderstanding, I'm happy to go back in and change how this works. There's an example of this in-progress (at the moment) on https://treeherder.mozilla.org/#/jobs?repo=try&revision=96994dc4b558f04c8de01751297f2dc9b87ae22f (I'm pretty sure the failed build isn't related to this, but I'll look into it a bit more).
Assignee: bstack → cdawson
Comment on attachment 8825838 [details]
Bug 1289824 - Add "add-talos" taskgraph action

https://reviewboard.mozilla.org/r/103912/#review107526

so this only works from mach, or does it plug into treeherder like the backfill button?
Comment on attachment 8825838 [details]
Bug 1289824 - Add "add-talos" taskgraph action

https://reviewboard.mozilla.org/r/103912/#review107526

Soon as somebody ships https://github.com/mozilla/treeherder/pull/2092, it will work from treeherder.
Comment on attachment 8825838 [details]
Bug 1289824 - Add "add-talos" taskgraph action

https://reviewboard.mozilla.org/r/103912/#review107534
Attachment #8825838 - Flags: review?(jmaher) → review+
Attachment #8828974 - Flags: review?(cdawson)
Assignee: cdawson → bstack
Autoland couldn't rebase this for landing.
Keywords: checkin-needed
Sorry about that. I've rebased onto m-c. Hopefully it works this time around!
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/28912d8b6b3a
Add "add-talos" taskgraph action r=jmaher
Keywords: checkin-needed
Comment on attachment 8828974 [details] [review]
[treeherder] imbstack:bug-1289824 > mozilla:master

I requested a couple small changes, but with those, this is ready to go.  Would you just document here in the bug the testing you did for this so we have it?

Thanks!!
Attachment #8828974 - Flags: review?(cdawson) → review+
bstack: OK, I've approved those changes.  Would you like to merge this, or have me do it?   :)
Flags: needinfo?(bstack)
I don't think I have the permissions necessary to merge it! Thanks for the help :)
Flags: needinfo?(bstack)
(In reply to Brian Stack [:bstack] from comment #25)
> I don't think I have the permissions necessary to merge it! Thanks for the
> help :)

Tagging :camd directly for this.
Flags: needinfo?(cdawson)
Ok, this has now been merged.  Thanks for the n-i, coop.  :)
Flags: needinfo?(cdawson)
Unfortunately landing this broke perfherder and the logviewer, because it added a dependency on taskcluster to the logviewer. I have a fix.
Comment on attachment 8835561 [details] [review]
[treeherder] wlach:1289824-fixup > mozilla:master

Hi Brian, unfortunately your changes broke some stuff because it introduced a new dependency on the resultset service that required updates to perfherder and the logviewer. :( Not your fault really, we need better automated tests around the UI. Anyway, the fix is simple. Figured you'd be fine to review it.
Attachment #8835561 - Flags: review?(bstack)
Attachment #8835561 - Flags: review?(bstack) → review+
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Depends on: 1339041
Depends on: 1339659
Blocks: 1293783
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.