If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incoming Mail Notification Should Be Like Netscape 3

RESOLVED EXPIRED

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED EXPIRED
16 years ago
8 years ago

People

(Reporter: Felix Miata, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
When only the bottom right or left corners of Mozilla are showing behind other
apps, incoming mail notification is invisible from Mozilla, unlike Netscape 3,
which at extreme lower right provides not only incoming mail notification, but a
quick switch-to and download from a single button click. I still use Netscape 3
for email in large part because I can leave my open mail window at extreme
bottom right and bottom of screen and have the incoming mail notification
visible at all times that no app has full screen.
(Reporter)

Comment 1

16 years ago
Created attachment 72596 [details]
Screenshot of bottom frames of Netscape 3, Comm 4, & Mozilla

This is a screenshot of the extreme lower right of my screen. Note that only
Netscape 3 can have its incoming email notification placed in a corner where it
can be and be kept visible virtually always.

Updated

16 years ago
QA Contact: esther → sheelar
QA Contact: sheelar → stephend

Comment 2

16 years ago
Once bug 122626 is fixed, having the browser's mail notification icon in the 
lower-right would make is look redundant.
(Reporter)

Comment 3

16 years ago
Yes, that it would in windoze, but this is a multi-platform bug. You didn't
happen to notice a taskbar in the screenshot of the extreme lower right of the
screen, did you? It wasn't there because there isn't one. Not all platforms have
a systray equivalent.

Comment 4

16 years ago
removing stephend & adding myself as qa
QA Contact: stephend → gchan

Comment 5

16 years ago
mrmazda there are plans for the mail notification icon
bug to appear in other platforms besides windows (see
bug 18730, bug 18731,bug 18732.

If it's ok with you than I'll mark this as wont fix..
(Reporter)

Comment 6

16 years ago
Those are Linux and Mac bugs. I'm using OS/2. Regardless, I can't see any reason
why the mail icon shouldn't be moved to one of the corners, no compelling reason
for the padlock to be lower right, nor browser icon lower left. What I've asked
is a cross platform solution that would intrude zero upon proposed email
notification solutions specific to any platform, and could coexist with them
happily.

Comment 7

16 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

16 years ago
Well, at least in Classic (I don't use Modern), I see the green arrow on the
mail icon to show that you have new mail. If that's a problem with modern you
should file a themes bug. Also, I filed the bug asking for the mail icon to go
to read your new mail some time ago but it's not happened yet.
(Reporter)

Comment 9

16 years ago
neil@, you should read the original comment and study the attachment more
carefully. The issue is not the mail icon, it is the mail icon placement.

Comment 10

15 years ago
Created attachment 97941 [details]
But this is what I see...
(Reporter)

Comment 11

15 years ago
You are apparently missing the point entirely. What the icon looks like when
mail is waiting for download is not the issue. The issue is whether the icon is
visible. Currently, a very substantial portion of the Mozilla (or 4.x) bottom
frame must be peeking from behind other windows in order to see that mail
awaits. In Netscape 3, only a tiny little peek at the lower right corner of the
frame is required in order to know mail awaits. To the Navigator (?) chrome
filespec <http://bugzilla.mozilla.org/attachment.cgi?id=65067&action=view> in
section 6 the mail icon should be added, with emphasis on its placement in a
corner, preferably lower right, where it can most easily be made to peek out
from behind other windows and thus be visble even though Mozilla doesn't have
focus.  With a mail icon placed on that prime real estate, there would be no
need to put a mail icon on the main toolbar as called for by the chrome
filespec. With the other app icons removed from the bottom frame, the privacy
control, security control, and offline control icons' function as toggles could
be distinguished by their placement at the left side of the bottom frame.

Neil@, read comment 9 again.  Also, to what bug were you referring in comment 8?
Blocks: 176238

Comment 12

14 years ago
Somehow I don't see that you're going to get the icon moved :-(
(Reporter)

Comment 13

14 years ago
Why, is there some patent or copyright obstacle to putting it in the most useful
location? Even just swapping the browser and mailnews icons would do the trick,
putting mailnews in the left lower corner instead of the right lower corner.

Comment 14

14 years ago
No, it was an opinion.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Updated

11 years ago
No longer blocks: 176238
(Reporter)

Updated

11 years ago
Blocks: 176238
Assignee: mail → nobody
QA Contact: grylchan → message-display

Comment 15

8 years ago
I just can't see us doing this, sorry. If you want it, you need to do it as an add-on, which is easy to manage in SeaMonkey 2.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 16

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 17

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.