New mail notification icon does not come up on win98

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
MailNews: Message Display
P1
major
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Sheela Ravindran, Assigned: Scott MacGregor)

Tracking

({pp})

Trunk
mozilla1.0
x86
Windows 98
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT2])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Commercial Build: 2002-01-30-06 win98

On win98 machine new mail notification icon in the system tray cannot be seen.

Steps:
Start browser
Start mail
Perfs: check new messages every [] minutes checked. 
compose a new message
send message
wait for biff to go off
Actual result: No mail notification icon on system tray.  

Expected Result: Should bring up the mail notification icon in the system tray
(Reporter)

Updated

17 years ago
QA Contact: esther → sheelar
(Assignee)

Comment 1

17 years ago
I believe this is a dup of 122351. 

*** This bug has been marked as a duplicate of 122351 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Reopening this bug because fixing bug 122351 did not fix this bug. I still don't
see the mail notification working on win98 and winME. The recent build I have is
2002-02-04-06.  
Status: RESOLVED → REOPENED
Keywords: nsbeta1
Resolution: DUPLICATE → ---

Comment 3

16 years ago
awhh.. yes. another bug that works on every other win platform is a bug specific
to the win98 OS changes over w95. :) adding platform parity keyword.

Keywords: pp

Comment 4

16 years ago
On those platforms that have it, does anyone bother checking the return value of
Shell_NotifyIconW?

Comment 5

16 years ago
FWIW:
I'm using win98 and I don't see the new mail icon in the systray, but the icon
for quicklaunch shows correctly, so it seems to me that this work has been coded
twice, and that at least for me the correct implementation is the one used to
display the quicklaunch icon.

Updated

16 years ago
Status: REOPENED → ASSIGNED
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla1.0

Comment 6

16 years ago
Shouldn't this bug block bug 18729?
(Assignee)

Comment 7

16 years ago
why? as i said before, 18729 is a "nice idea" bug...i.e. developing a cross
platform framework for maniuplating icons in an operating system's system tray.
It's not specific to biff. It's a framework bug. 

119344 was the bug I used to implement biff notification in the system tray. It
is working on all windows platforms except for win98. From that bug, I filed
this bug citing the fact that win98 isn't happy with the methods on the windows
shell API that I'm using. I haven't figured out why yet. 
QA Contact: sheelar → stephend

Comment 8

16 years ago
Not all platforms have a systray equivalent. Compare to bug 129052.

Comment 9

16 years ago
mscott: I believe it's not correct to check the availability of a function via
GetProcAddress. I think that Shell_NotifyIconW is there in later win95 and win98
versions of shell32.dll (it will fail, but anyway). At least it seems to be
present  (by a visual examination, can't confirm as I only have win2k) in
shell32.dll shipped with IE4 w/ Desktop Update for win98. 
*** Bug 132007 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
Discussed in Mail News bug mtg with Engineering QA Mktng PjM.  Decided to ADT2
this bug. 
Whiteboard: [ADT2]

Comment 12

16 years ago
removing stephend & adding myself as qa
QA Contact: stephend → gchan
(Assignee)

Comment 13

16 years ago
Created attachment 76000 [details] [diff] [review]
the fix...fall back to non unicode versions if we get an error

Apparently on Win98, the Shell_NotifyIconW (the unicode version) is defined;
however it isn't actually implemented. So if you call it, it returns FALSE
signaling an error. 

My fix is to revert back to the ascii version of the routine if we get an error
back from Shell_NotifyIconW. We do this by releasing our handle to the icon in
the unicode shell struct. We then copy any tooltip data over to the ascii shell
struct and we then call the ascii version of Shell_NotifyIcon

Comment 14

16 years ago
Comment on attachment 76000 [details] [diff] [review]
the fix...fall back to non unicode versions if we get an error

r=bhuvan
Attachment #76000 - Flags: review+

Comment 15

16 years ago
What if additional e-mails arrive *after* the icon is already being displayed in
the system tray; will the tooltip update to reflect the *new* number of messages?

Comment 16

16 years ago
Peter, I believe the bug about updating new number of mesgs
if the icon is already displayed is bug 123104

Comment 17

16 years ago
Comment on attachment 76000 [details] [diff] [review]
the fix...fall back to non unicode versions if we get an error

yeah, Microsoft's unicode support on win98 sucks. sr=bienvenu
Attachment #76000 - Flags: superreview+
Comment on attachment 76000 [details] [diff] [review]
the fix...fall back to non unicode versions if we get an error

a=dbaron for trunk checkin 

(Stylistically I'd much rather see

if (res)
  return;
...

than

if (!res)
  ...
else
  return;

but it doesn't really matter.)
Attachment #76000 - Flags: approval+
(Assignee)

Comment 19

16 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 20

16 years ago
Working for me with mar28 commercial trunk, win98.

Comment 21

16 years ago
Using 2002032803 on 3 Win98 machines (i believe 1st edition)
and 1 WinME machine, I may have to reopen this bug.

When a new mesg arrives, instead of the white envelope
icon w/red flag up signaling new mail has arrived.
I'm seeing a yellow triangle w/exclamation mark in the middle
in the system tray.

Scott, Stephen mentioned that Kerz saw this on his machine,
but I couldn't find the bug number on this.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 22

16 years ago
I get the same yellow alert triangle. I thought it was what I was supposed to be
seeing!
(Assignee)

Comment 23

16 years ago
re-closing. The icon is working on win98 now.

About the yellow icon, apparently there were some bad bits yesterday. People who
were seeing the yellow icon told me they aren't seeing it on todays build. In
either case that should be filed as a new bug since it is unrelated to this one. 
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 24

16 years ago
I am very happy to see this working in time for 1.0. Using build 2002032708 on
Win98, I see yellow exclamation triangle, but that's fine with me. Sorry for
spam, but had to cheer somehow!
Yes, on Windows 98 using build 2002-04-01-03, with the 'Show an Alert' and with 
biff set on the account, I am able to see the new mail notification icon - 
although it is yellow, that is covered by Gary's bug 134754.

Verified FIXED.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.