Closed Bug 1291284 Opened 3 years ago Closed 3 years ago

Enable modal highlighting by default in Firefox

Categories

(Toolkit :: Find Toolbar, defect)

50 Branch
defect
Not set
Points:
1

Tracking

()

VERIFIED FIXED
mozilla51
Iteration:
51.3 - Sep 19
Tracking Status
firefox49 --- unaffected
firefox50 --- unaffected
firefox51 --- disabled
firefox52 --- verified

People

(Reporter: mikedeboer, Assigned: mikedeboer)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

See summary.
Flags: qe-verify+
Flags: firefox-backlog+
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Iteration: --- → 51.3 - Sep 12
Points: --- → 1
Comment on attachment 8786378 [details]
Bug 1291284 - enable 'Highlight All' and modal highlighting mode by default in Firefox.

https://reviewboard.mozilla.org/r/75348/#review73266

What is the criteria for letting this ride the 51 train? Should we turn it off if we can't meet some determined performance metric (less than X milliseconds to highlight first match on HTML spec, etc)? Can we add a talos test that will turn orange if the performance regresses?

We should figure that out before we enable it.
Attachment #8786378 - Flags: review?(jaws) → review+
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5febcc03a729
enable 'Highlight All' and modal highlighting mode by default in Firefox. r=jaws
https://hg.mozilla.org/mozilla-central/rev/5febcc03a729
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
I reproduced the issue using Firefox Aurora 50.0a2 (20160802004003).

The fix was verified on latest Nightly 51.0a1 (2016-09-11), using Windows 10 Pro, x64, Ubuntu 16.04 LTS, x64 and Mac OS X El capitan 10.11.06.
QA Contact: brindusa.tot
Depends on: 1303248
Reopening this issue, as this feature was not landed on 52.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla51 → mozilla52
The standard way to track this is via the tracking flags and to mark a release as disabled since it was disabled outside of Nightly by bug 1303248.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: mozilla52 → mozilla51
Depends on: 1316513
Depends on: 1316514
Verified as fixed on Nightly 52.0a1. New modal highlight feature is enabled by default only on Nightly 52.0a1.

Verified on Windows 7, Mac OS X 10.10, Ubuntu 16.04.
Status: RESOLVED → VERIFIED
Depends on: 1328034
You need to log in before you can comment on or make changes to this bug.