Closed Bug 1292049 Opened 5 years ago Closed 5 years ago

Ctrl+Tab gets stuck after reopening a closed tab

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 51
Tracking Status
firefox50 + verified
firefox51 --- verified

People

(Reporter: dao, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

STR:

- enable "Ctrl+Tab cycles through tabs in recently used order"
- have a bunch of tabs open
- close a tab
- reopen the tab
- hit Ctrl+Tab

This is because SessionStore.jsm may set lastAccessed on a selected tab, and the lastAccessed getter(!) doesn't account for the tab being selected as of bug 980231.
Attached patch patch (obsolete) — Splinter Review
Attachment #8777703 - Flags: review?(mdeboer)
[Tracking Requested - why for this release]: we're now exposing this feature to end users (bug 1116787)
Comment on attachment 8777703 [details] [diff] [review]
patch

Review of attachment 8777703 [details] [diff] [review]:
-----------------------------------------------------------------

Well-spotted.
Attachment #8777703 - Flags: review?(mdeboer) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/510f0b4792de
Prevent tab.lastAccessed from being set to a discrete value when the tab is selected. r=mdeboer
Backed out because of this:

04:27:00 INFO - 54 INFO TEST-UNEXPECTED-FAIL | browser/components/sessionstore/test/browser_354894_perwindowpb.js | Uncaught exception - at chrome://browser/content/tabbrowser.xml:2023 - TypeError: t.updateLastAccessed is not a function

updateLastAccessed should definitely exist there. Looks like a case of XBL being broken.
Attached patch patch v2Splinter Review
Moved the updateLastAccessed call to the tab's XBL constructor. Shouldn't be necessary but it does appear to fix the browser_354894_perwindowpb.js issue.
Attachment #8777703 - Attachment is obsolete: true
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/343370281fd7
Prevent tab.lastAccessed from being set to a discrete value when the tab is selected. r=mdeboer
https://hg.mozilla.org/mozilla-central/rev/343370281fd7
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Comment on attachment 8777800 [details] [diff] [review]
patch v2

Approval Request Comment
[Feature/regressing bug #]: bug 1116787
[User impact if declined]: see bug summary and comment 0
[Describe test coverage new/current, TreeHerder]: has a test
[Risks and why]: fairly straightforward and well-understood fix, low risk
[String/UUID change made/needed]: none
Attachment #8777800 - Flags: approval-mozilla-aurora?
I have reproduced this bug with nightly 51.0a1 (2016-08-04) on windows 10, 32 bit.

The bug’s fix is now verified on Latest Nightly 51.0a1.

Build ID:20160805030444.
User Agent:Mozilla/5.0 (Windows NT 10.0; rv:51.0) Gecko/20100101 Firefox/51.0.
(In reply to Akash from comment #10)
> I have reproduced this bug with nightly 51.0a1 (2016-08-04) on windows 10,
> 32 bit.
> 
> The bug’s fix is now verified on Latest Nightly 51.0a1.
> 
> Build ID:20160805030444.
> User Agent:Mozilla/5.0 (Windows NT 10.0; rv:51.0) Gecko/20100101
> Firefox/51.0.

Thanks!
Status: RESOLVED → VERIFIED
Comment on attachment 8777800 [details] [diff] [review]
patch v2

Regression fixed, Aurora50+
Attachment #8777800 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Confirming that this issue no longer reproduces on Win 10x64, Ubuntu 12.04 x86 and Mac OS X 10.11.6 using latest 50.0a2 Aurora, build ID 20160913004005.
Flags: qe-verify+
QA Contact: cornel.ionce
Duplicate of this bug: 1190128
Duplicate of this bug: 1289395
You need to log in before you can comment on or make changes to this bug.