Closed Bug 1294009 Opened 3 years ago Closed 3 years ago

I10t browser_markup_events_jquery_1.7.js,browser_perf-recording-actor-01.js,browser_dbg_server-conditional-bp-01.js | crashed [@ js::ProfileEntry::pc()][@ js::ProfileEntry::pc() const volatile][@ JSScript::offsetToPC(unsigned long) const]

Categories

(Core :: JavaScript Engine, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox49 --- unaffected
firefox50 --- unaffected
firefox51 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jonco)

References

Details

(Keywords: intermittent-failure)

In test: https://treeherder.mozilla.org/logviewer.html#?job_id=34101714&repo=mozilla-inbound
Summary: Intermittent devtools/client/inspector/markup/test/browser_markup_events_jquery_1.7.js | application crashed [@ js::ProfileEntry::pc()] → Intermittent browser_markup_events_jquery_1.7.js,test_bug260264.html | application crashed [@ js::ProfileEntry::pc()]
browser_perf-recording-actor-01.js: https://treeherder.mozilla.org/logviewer.html#?job_id=34764428&repo=mozilla-inbound
Summary: Intermittent browser_markup_events_jquery_1.7.js,test_bug260264.html | application crashed [@ js::ProfileEntry::pc()] → Intermittent browser_markup_events_jquery_1.7.js,browser_perf-recording-actor-01.js,test_bug260264.html | application crashed [@ js::ProfileEntry::pc()]
Duplicate of this bug: 1295806
Duplicate of this bug: 1296117
Duplicate of this bug: 1298168
Duplicate of this bug: 1298195
Duplicate of this bug: 1298197
Duplicate of this bug: 1298253
Duplicate of this bug: 1298518
Duplicate of this bug: 1298519
Eddy said he'd bring this up in the next team meeting.
Flags: needinfo?(ejpbruel)
Summary: Intermittent browser_markup_events_jquery_1.7.js,browser_perf-recording-actor-01.js,test_bug260264.html | application crashed [@ js::ProfileEntry::pc()] → Intermittent browser_markup_events_jquery_1.7.js,browser_perf-recording-actor-01.js,test_bug260264.html | application crashed [@ js::ProfileEntry::pc()] or [@ js::ProfileEntry::pc() const volatile]
Depends on: 1298639
See Also: → 1298141
(In reply to Ryan VanderMeulen [:RyanVM] from comment #12)
> Eddy said he'd bring this up in the next team meeting.

I brought this up during the devtools team meeting. The consensus was that, although this a JS engine bug, we should probably fix it ourselves, because no-one else really owns this code.

Nick said he'd be willing to take a look at this bug. If he can figure out what's causing this, and how hard it is to fix, we can take it from there.
Flags: needinfo?(ejpbruel)
Assignee: nobody → nfitzgerald
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1298639
(Reopening for treeherder starring abilities)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Summary: Intermittent browser_markup_events_jquery_1.7.js,browser_perf-recording-actor-01.js,test_bug260264.html | application crashed [@ js::ProfileEntry::pc()] or [@ js::ProfileEntry::pc() const volatile] → Intermittent browser_markup_events_jquery_1.7.js,browser_perf-recording-actor-01.js,test_bug260264.html,browser_dbg_server-conditional-bp-01.js | application crashed [@ js::ProfileEntry::pc()] or [@ js::ProfileEntry::pc() const volatile]
Summary: Intermittent browser_markup_events_jquery_1.7.js,browser_perf-recording-actor-01.js,test_bug260264.html,browser_dbg_server-conditional-bp-01.js | application crashed [@ js::ProfileEntry::pc()] or [@ js::ProfileEntry::pc() const volatile] → I10t browser_markup_events_jquery_1.7.js,browser_perf-recording-actor-01.js,browser_dbg_server-conditional-bp-01.js | crashed [@ js::ProfileEntry::pc()][@ js::ProfileEntry::pc() const volatile][@ JSScript::offsetToPC(unsigned long) const]
Duplicate of this bug: 1298141
See Also: → 1300471
Duplicate of this bug: 1300748
Blocks: 1301890
Blocks: 1301962
Blocks: 1302165
Blocks: 1302326
Fixed by bug 1298639.
Assignee: nfitzgerald → jcoppeard
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
See Also: 1298141, 1300471
Target Milestone: --- → mozilla51
No longer blocks: 1301890
No longer blocks: 1301962
No longer blocks: 1302165
No longer blocks: 1302326
Duplicate of this bug: 1301890
Duplicate of this bug: 1301962
Duplicate of this bug: 1302165
Duplicate of this bug: 1302326
You need to log in before you can comment on or make changes to this bug.