Closed Bug 1295075 Opened 3 years ago Closed 3 years ago

Lots of crashes igd10umd64.dll starting in 51

Categories

(Core :: Graphics, defect, P1, critical)

Unspecified
Windows 7
defect

Tracking

()

RESOLVED DUPLICATE of bug 1292923

People

(Reporter: njn, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [gfx-noted])

Crash Data

Attachments

(3 files)

This bug was filed from the Socorro interface and is 
report bp-e872722b-40a1-4009-a133-dd2312160813.
=============================================================

We're seeing a big spike in crashes within igd10umd64.dll from the August 12
Nightly and onwards. 

For example, from the top 50 August 11 Nightly crashes:

https://crash-stats.mozilla.com/search/?product=Firefox&build_id=20160811030201&platform=Windows&date=%3E%3D2016-08-11&release_channel=nightly&_sort=-date&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-signature

we have a handful in that DLL:

> 26 	igd10umd64.dll | RtlpAllocateHeapInternal | RtlpAllocateHeapInternal | igd10umd64.dll | RtlpAllocateHeapInternal | igd10umd64.dll | std::_List_alloc<T>::_Buynode0   Add term 	5 	0.04 % 	1292923
> 36 	igd10umd64.dll | D3DKMTCreateAllocation   Add term 	4 	0.03 % 	
> 37 	igd10umd64.dll | ResourceCopyRegionDDIHelper<T>   Add term 	4 	0.03 % 	
> 48 	igd10umd64.dll | CContext::ID3D11DeviceContext1_SetShader_<T>   Add term 	3 	0.03 % 	


Comparing the August 12 Nightly:

https://crash-stats.mozilla.com/signature/?build_id=20160812030200&product=Firefox&release_channel=nightly&platform=Windows&date=%3E%3D2016-08-12&signature=igd10umd64.dll%20%7C%20D3DKMTCreateAllocation&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_columns=adapter_device_id&_columns=adapter_driver_version&_columns=adapter_subsys_id&_columns=adapter_vendor_id&_sort=-date&page=1

we have a lot more:

> 8 	igd10umd64.dll | D3DKMTCreateAllocation   Add term 	18 	0.99 % 	
> 10 	igd10umd64.dll | ResourceCopyRegionDDIHelper<T>   Add term 	13 	0.72 % 	
> 11 	igd10umd64.dll | CContext::ID3D11DeviceContext1_SetShader_<T>   Add term 	12 	0.66 % 	
> 20 	igd10umd64.dll | RtlAllocateMemoryBlockLookaside | igd10umd64.dll | D3DKMTCreateAllocation   Add term 	8 	0.44 % 	
> 27 	igd10umd64.dll | CContext::OnRender   Add term 	6 	0.33 % 	
> 28 	igd10umd64.dll | RtlpAllocateHeapInternal | RtlpAllocateHeapInternal | igd10umd64.dll | RtlpAllocateHeapInternal | igd10umd64.dll | std::_List_alloc<T>::_Buynode0   Add term 	6 	0.33 % 	1292923
> 32 	igd10umd64.dll   Add term 	5 	0.28 % 	1292923
> 33 	igd10umd64.dll | CContext::ID3D11DeviceContext1_SetSamplers_<T>   Add term 	5 	0.28 % 	
> 34 	igd10umd64.dll | atiuxp64.dll@0x6c9b   Add term 	5 	0.28 % 	
> 35 	igd10umd64.dll | atiuxp64.dll@0x6dbb   Add term 	5 	0.28 % 	
> 41 	igd10umd64.dll | SPipelineState::TrimAllHWM   Add term 	4 	0.22 % 	

Same for August 13 and 14 Nightly.

I can't tell what happened. The new crashes are across a range of gfx devices
and driver versions.

Milan, this is one you should have on your radar...
Flags: needinfo?(milan)
Whiteboard: [gfx-noted]
Not quite sure I believe the "started on the 12th", and the driver DLL is too large a target, but perhaps the D3DKMTCreateAllocation version is the one to start with.  Bas, can you take a look?  I haven't looked at the driver versions, but if new, it could be from whitelisting WebGL.  Otherwise, I would have gone for bug 1293028, except that didn't land yet.

I think I'm seeing these crashes on the August 8th build as well, so it may be worth looking earlier.
Flags: needinfo?(milan) → needinfo?(bas)
Discussed this yesterday on the phone. I was wondering, Matt, could this be related to your video device consolidation efforts?
Flags: needinfo?(bas) → needinfo?(matt.woodrow)
Bug 1292923 was filed on August 6th - looks as if this bug has a bunch of different signatures associated with it.
Crash Signature: [@ igd10umd64.dll | D3DKMTCreateAllocation] → [@ igd10umd64.dll | D3DKMTCreateAllocation] [@ igd10umd64.dll | ResourceCopyRegionDDIHelper<T>] [@ igd10umd64.dll | CContext::ID3D11DeviceContext1_SetShaderResources_<T>] [@ igd10umd64.dll | CContext::ID3D11DeviceContext1_SetShader_<T>] [@ igd10umd64.…
My bet is currently on August 4th build :)
(In reply to Milan Sreckovic [:milan] from comment #4)
> My bet is currently on August 4th build :)

This was just based on the number of crashes - hovering <20, then going to 43 on August 4th, 81 on August 5th, and going from there.  Going through what landed on August 3rd...

(In reply to Bas Schouten (:bas.schouten) from comment #2)
> Discussed this yesterday on the phone. I was wondering, Matt, could this be
> related to your video device consolidation efforts?

This is bug 1284672, and happens to have landed August 3rd.

Bending the statistical analysis to a breaking point, things are pointing to bug 1284672.  (The reason for doing bug 1284672 was to deal with crashes in the driver - if I squint, I could see the improvement after August 3rd in bug 1267970, for example, but I don't see (any?) of those crashes on nightly anyway, so there is danger in drawing conclusions from data like this.)

Unless we can figure this out shortly, we should probably put the behaviour changes in bug 1284672 behind a pref, and run an experiment on nightly, to see if the control group (old behaviour) and the new group (new behaviour) crash with different rates.

Ryan, can you quickly put a patch together for that?
Flags: needinfo?(rhunt)
Summary: Lots of crashes igd10umd64.dll starting in August 12 Nightly → Lots of crashes igd10umd64.dll starting in 51
Anthony, heads up, we may need to run an A/B experiment on nightly shortly - can you setup whatever needs doing so that once we have that preference, we can test this?
Flags: needinfo?(anthony.s.hughes)
This should do the trick.

The pref is called 'gfx.direct3d11.reuse-decoder-device' and defaults to true which gives us the current behavior of reusing decoder devices. So to test the old group you'd want to switch it to false.
Flags: needinfo?(rhunt)
Unfortunately without steps to reproduce this is going to be difficult to A/B test manually, however we should be able to see this in Crash Data and Telemetry.

From the crash data perspective I have set up the following:
http://ashughes1.github.io/metrics-graphics-gfx/#v2-bug-1295075

It shows an obvious spike in 51.0a1 on August 2nd both by volume and by rate.
Flags: needinfo?(anthony.s.hughes)
Bug 1289640 also landed on the 3rd, any reason not to blame that one?

It's annoying that we're not getting proper stacks here, but it looks like these are all texture creation, so it could be similar to (or the same as?) bug 1292923.

Can we try reproduce this in the Toronto office? Disabling DXVA decoding on an Intel machine with d3d11 layers should hit the right code path when playing h264 video.

If this only happens on Intel then we might need to just stop that path from being hit with Intel drivers.

I've asked Intel to take a look into their driver code too.
Flags: needinfo?(matt.woodrow)
(In reply to Matt Woodrow (:mattwoodrow) from comment #9)
> Bug 1289640 also landed on the 3rd, any reason not to blame that one?

I was about to :)
(In reply to Anthony Hughes (:ashughes) [GFX][QA][Mentor] from comment #8)
> It shows an obvious spike in 51.0a1 on August 2nd both by volume and by rate.

Correction, the spike starts appearing on Aug 4th (not 2nd) which could possibly point to what Matt said in comment 9.

> Can we try reproduce this in the Toronto office? Disabling DXVA decoding on
> an Intel machine with d3d11 layers should hit the right code path when
> playing h264 video.

This would certainly help in at least verifying the change has some impact. Crash data takes several days to tell us anything meaningful and does not always paint a complete picture of what's happening in the wild.

> If this only happens on Intel then we might need to just stop that path from
> being hit with Intel drivers.

This certainly does appear to be exclusive to Intel (source: http://bit.ly/2bMp3Gg).
* 100% of reports on 51.0a1 since August 4, 2016 have 0x8086 as the vendor ID

Furthermore, this appears isolated to Sandybridge and Ivybridge chipsets:
* 66.44% are on Sandybridge chipsets, 54% of those users are using an Intel HD 3000 GPU
* 33.22% are on Ivybridge chipsets, 67% of those users are using an Intel HD 4000 GPU

Furthermore, this appears mostly with the 9.17.10.* branch of driver:
* 94.99% are on 9.17.10.*, 54% of these users are on 9.17.10.4229
*  3.22% are on 8.15.10.*, 30% of these users are on 8.15.10.2752
* 84.53% of users on the most common device (Intel HD 3000) are using driver 9.17.10.4229
igd10umd64.dll is the Intel graphics driver, so it would be exclusive to Intel hardware.  I wouldn't be surprised if something like this: https://crash-stats.mozilla.com/report/index/71781a59-5b4c-4080-aa9e-1090e2160813 is the "same crash".
Flags: needinfo?(milan)
Duplicate of this bug: 1298624
Crash Signature: igd10umd64.dll] → igd10umd64.dll] [@ igd10umd64.dll | malloc | igd10umd64.dll | nvumdshimx.dll@0x38470] [@ igd10umd64.dll | nvumdshimx.dll@0x36b69 ]
Crashes for week ending August 30:
> Firefox 51.0a1: 862 crashes, ~2 crashes per user
> Firefox <=50: 108 crashes, ~1 crash per user
Ryan, any update on the A/B testing idea? We're getting a *lot* of crashes with this signature...
Crash Signature: igd10umd64.dll] [@ igd10umd64.dll | malloc | igd10umd64.dll | nvumdshimx.dll@0x38470] [@ igd10umd64.dll | nvumdshimx.dll@0x36b69 ] → igd10umd64.dll] [@ igd10umd64.dll | malloc | igd10umd64.dll | nvumdshimx.dll@0x38470] [@ igd10umd64.dll | nvumdshimx.dll@0x36b69 ] [@ igd10umd64.dll | CContext::OnRender]
Bulk move of gfx-noted bugs without priority to P3 for tracking.
Priority: -- → P3
I have the same issue, mainly with facebook page. I noticed that it almost always crashes when a flashplayer video is played (in Facebook all videos plays automatically). In my case when it doesn't crash, the webpage turns black.

about:support information
Application Basics
------------------

Name: Firefox
Version: 52.0a1
Build ID: 20160922030437
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
OS: Windows_NT 6.3
Multiprocess Windows: 1/1 (Enabled by default)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-47b8cb77-fb32-4859-b17f-666312160923
Submitted: 4 minutes ago

Report ID: bp-19fd7d3f-952c-423c-adc4-744832160923
Submitted: 5 minutes ago

Report ID: bp-875612eb-a017-4692-b024-026cc2160922
Submitted: 13 hours ago

Report ID: bp-498a76c2-abb5-48aa-b9c8-044852160922
Submitted: 13 hours ago

Report ID: bp-f188d532-f173-416a-b920-c2d9c2160922
Submitted: 13 hours ago

Report ID: bp-3c44eb0f-bf31-42a6-b4c6-091512160922
Submitted: 13 hours ago

Report ID: bp-3010689b-b194-479e-83d7-eef462160922
Submitted: 14 hours ago

Report ID: bp-067a247b-7c24-4f5b-b4e8-e4cd32160922
Submitted: 19 hours ago

All Crash Reports

Extensions
----------

Name: Cookies Manager+
Version: 1.13.1
Enabled: true
ID: {bb6bc1bb-f824-4702-90cd-35e2fb24f25d}

Name: Facedown
Version: 1.24.1-signed
Enabled: true
ID: jid1-jOzgwWWFkIQQqg@jetpack

Name: FlyWeb
Version: 1.0.0
Enabled: true
ID: flyweb@mozilla.org

Name: Form Autofill
Version: 1.0
Enabled: true
ID: formautofill@mozilla.org

Name: Multi-process staged rollout
Version: 1.2
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Graphics
--------

Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D11 vs_4_1 ps_4_1)
WebGL2 Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D11 vs_4_1 ps_4_1)
Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted
Audio Backend: wasapi
Direct2D: true
DirectWrite: true (6.3.9600.18123)
GPU #1
Active: Yes
Description: Intel(R) HD Graphics 3000
Vendor ID: 0x8086
Device ID: 0x0116
Driver Version: 9.17.10.4229
Driver Date: 5-28-2015
Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Subsys ID: 16421043
RAM: Unknown
GPU #2
Active: No
Description: NVIDIA GeForce GT 540M
Vendor ID: 0x10de
Device ID: 0x0df4
Driver Version: 10.18.13.6839
Driver Date: 6-2-2016
Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Subsys ID: 16421043
RAM: 1024
Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo





Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.download.useDownloadDir: false
browser.places.smartBookmarksVersion: 8
browser.sessionstore.upgradeBackup.latestBuildID: 20160922030437
browser.startup.homepage: about:home
browser.startup.homepage_override.buildID: 20160922030437
browser.startup.homepage_override.mstone: 52.0a1
browser.tabs.crashReporting.includeURL: true
browser.tabs.warnOnClose: false
browser.urlbar.suggest.searches: true
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.lastUpdate.buildID: 20160725030248
dom.apps.lastUpdate.mstone: 50.0a1
dom.apps.reset-permissions: true
extensions.lastAppVersion: 52.0a1
font.internaluseonly.changed: true
media.benchmark.vp9.fps: 114
media.benchmark.vp9.versioncheck: 1
media.gmp-eme-adobe.abi: x86_64-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1459718292
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86_64-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1470774274
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20160922030437
media.gmp-manager.lastCheck: 1474564684
media.gmp-widevinecdm.abi: x86_64-msvc-x64
media.gmp-widevinecdm.lastUpdate: 1470774285
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1474291404
places.history.expiration.transient_current_max_pages: 122334
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_bgcolor: false
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_bgimages: false
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_duplex: -437918235
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_edge_bottom: 0
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_edge_left: 0
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_edge_right: 0
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_edge_top: 0
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_evenpages: true
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_footercenter:
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_footerleft: &PT
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_footerright: &D
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_headercenter:
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_headerleft: &T
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_headerright: &U
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_in_color: true
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_margin_bottom: 0.5
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_margin_left: 0.5
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_margin_right: 0.5
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_margin_top: 0.5
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_oddpages: true
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_orientation: 0
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_page_delay: 50
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_paper_data: 9
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_paper_height: 296,90
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_paper_name:
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_paper_size_unit: 1
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_paper_width: 210,00
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_resolution: 600
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_reversed: false
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_scaling: 1,00
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_shrink_to_fit: true
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_to_file: false
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_unwriteable_margin_bottom: 0
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_unwriteable_margin_left: 0
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_unwriteable_margin_right: 0
print.printer_\\ADMINISTRACION\HP_LaserJet_M1319f_MFP.print_unwriteable_margin_top: 0
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_bgcolor: false
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_bgimages: false
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_duplex: -437918235
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_edge_bottom: 0
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_edge_left: 0
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_edge_right: 0
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_edge_top: 0
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_evenpages: true
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_footercenter:
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_footerleft: &PT
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_footerright: &D
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_headercenter:
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_headerleft: &T
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_headerright: &U
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_in_color: true
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_margin_bottom: 0.5
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_margin_left: 0.5
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_margin_right: 0.5
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_margin_top: 0.5
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_oddpages: true
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_orientation: 0
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_page_delay: 50
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_paper_data: 9
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_paper_height: 296,90
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_paper_name:
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_paper_size_unit: 1
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_paper_width: 210,00
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_resolution: 600
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_reversed: false
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_scaling: 1,00
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_shrink_to_fit: true
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_to_file: false
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_bottom: 0
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_left: 0
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_right: 0
print.printer_\\GRANCELLI-PC\HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_top: 0
print.printer_Adobe_PDF.print_bgcolor: false
print.printer_Adobe_PDF.print_bgimages: false
print.printer_Adobe_PDF.print_duplex: -437918235
print.printer_Adobe_PDF.print_edge_bottom: 0
print.printer_Adobe_PDF.print_edge_left: 0
print.printer_Adobe_PDF.print_edge_right: 0
print.printer_Adobe_PDF.print_edge_top: 0
print.printer_Adobe_PDF.print_evenpages: true
print.printer_Adobe_PDF.print_footercenter:
print.printer_Adobe_PDF.print_footerleft: &PT
print.printer_Adobe_PDF.print_footerright: &D
print.printer_Adobe_PDF.print_headercenter:
print.printer_Adobe_PDF.print_headerleft: &T
print.printer_Adobe_PDF.print_headerright: &U
print.printer_Adobe_PDF.print_in_color: true
print.printer_Adobe_PDF.print_margin_bottom: 0.5
print.printer_Adobe_PDF.print_margin_left: 0.5
print.printer_Adobe_PDF.print_margin_right: 0.5
print.printer_Adobe_PDF.print_margin_top: 0.5
print.printer_Adobe_PDF.print_oddpages: true
print.printer_Adobe_PDF.print_orientation: 0
print.printer_Adobe_PDF.print_page_delay: 50
print.printer_Adobe_PDF.print_paper_data: 9
print.printer_Adobe_PDF.print_paper_height: -1,00
print.printer_Adobe_PDF.print_paper_name:
print.printer_Adobe_PDF.print_paper_size_unit: 1
print.printer_Adobe_PDF.print_paper_width: -1,00
print.printer_Adobe_PDF.print_resolution: 1200
print.printer_Adobe_PDF.print_reversed: false
print.printer_Adobe_PDF.print_scaling: 1,00
print.printer_Adobe_PDF.print_shrink_to_fit: true
print.printer_Adobe_PDF.print_to_file: false
print.printer_Adobe_PDF.print_unwriteable_margin_bottom: 0
print.printer_Adobe_PDF.print_unwriteable_margin_left: 0
print.printer_Adobe_PDF.print_unwriteable_margin_right: 0
print.printer_Adobe_PDF.print_unwriteable_margin_top: 0
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_bgcolor: false
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_bgimages: false
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_duplex: -437918235
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_edge_bottom: 0
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_edge_left: 0
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_edge_right: 0
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_edge_top: 0
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_evenpages: true
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_footercenter:
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_footerleft: &PT
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_footerright: &D
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_headercenter:
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_headerleft: &T
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_headerright: &U
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_in_color: true
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_margin_bottom: 0.5
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_margin_left: 0.5
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_margin_right: 0.5
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_margin_top: 0.5
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_oddpages: true
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_orientation: 0
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_page_delay: 50
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_data: 9
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_height: 297,00
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_name:
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_size_unit: 1
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_width: 210,00
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_resolution: 600
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_reversed: false
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_scaling: 1,00
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_shrink_to_fit: true
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_to_file: false
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_bottom: 0
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_left: 0
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_right: 0
print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_top: 0
print.printer_HP_LaserJet_Professional_P_1102w.print_bgcolor: false
print.printer_HP_LaserJet_Professional_P_1102w.print_bgimages: false
print.printer_HP_LaserJet_Professional_P_1102w.print_duplex: -437918235
print.printer_HP_LaserJet_Professional_P_1102w.print_edge_bottom: 0
print.printer_HP_LaserJet_Professional_P_1102w.print_edge_left: 0
print.printer_HP_LaserJet_Professional_P_1102w.print_edge_right: 0
print.printer_HP_LaserJet_Professional_P_1102w.print_edge_top: 0
print.printer_HP_LaserJet_Professional_P_1102w.print_evenpages: true
print.printer_HP_LaserJet_Professional_P_1102w.print_footercenter:
print.printer_HP_LaserJet_Professional_P_1102w.print_footerleft: &PT
print.printer_HP_LaserJet_Professional_P_1102w.print_footerright: &D
print.printer_HP_LaserJet_Professional_P_1102w.print_headercenter:
print.printer_HP_LaserJet_Professional_P_1102w.print_headerleft: &T
print.printer_HP_LaserJet_Professional_P_1102w.print_headerright: &U
print.printer_HP_LaserJet_Professional_P_1102w.print_in_color: true
print.printer_HP_LaserJet_Professional_P_1102w.print_margin_bottom: 0.5
print.printer_HP_LaserJet_Professional_P_1102w.print_margin_left: 0.5
print.printer_HP_LaserJet_Professional_P_1102w.print_margin_right: 0.5
print.printer_HP_LaserJet_Professional_P_1102w.print_margin_top: 0.5
print.printer_HP_LaserJet_Professional_P_1102w.print_oddpages: true
print.printer_HP_LaserJet_Professional_P_1102w.print_orientation: 0
print.printer_HP_LaserJet_Professional_P_1102w.print_page_delay: 50
print.printer_HP_LaserJet_Professional_P_1102w.print_paper_data: 1
print.printer_HP_LaserJet_Professional_P_1102w.print_paper_height: 11,69
print.printer_HP_LaserJet_Professional_P_1102w.print_paper_name:
print.printer_HP_LaserJet_Professional_P_1102w.print_paper_size_unit: 0
print.printer_HP_LaserJet_Professional_P_1102w.print_paper_width: 8,27
print.printer_HP_LaserJet_Professional_P_1102w.print_resolution: 600
print.printer_HP_LaserJet_Professional_P_1102w.print_reversed: false
print.printer_HP_LaserJet_Professional_P_1102w.print_scaling: 1,00
print.printer_HP_LaserJet_Professional_P_1102w.print_shrink_to_fit: true
print.printer_HP_LaserJet_Professional_P_1102w.print_to_file: false
print.printer_HP_LaserJet_Professional_P_1102w.print_unwriteable_margin_bottom: 0
print.printer_HP_LaserJet_Professional_P_1102w.print_unwriteable_margin_left: 0
print.printer_HP_LaserJet_Professional_P_1102w.print_unwriteable_margin_right: 0
print.printer_HP_LaserJet_Professional_P_1102w.print_unwriteable_margin_top: 0
print.printer_Nitro_PDF_Creator_(Pro_10).print_bgcolor: false
print.printer_Nitro_PDF_Creator_(Pro_10).print_bgimages: false
print.printer_Nitro_PDF_Creator_(Pro_10).print_duplex: -437918235
print.printer_Nitro_PDF_Creator_(Pro_10).print_edge_bottom: 0
print.printer_Nitro_PDF_Creator_(Pro_10).print_edge_left: 0
print.printer_Nitro_PDF_Creator_(Pro_10).print_edge_right: 0
print.printer_Nitro_PDF_Creator_(Pro_10).print_edge_top: 0
print.printer_Nitro_PDF_Creator_(Pro_10).print_evenpages: true
print.printer_Nitro_PDF_Creator_(Pro_10).print_footercenter:
print.printer_Nitro_PDF_Creator_(Pro_10).print_footerleft: &PT
print.printer_Nitro_PDF_Creator_(Pro_10).print_footerright: &D
print.printer_Nitro_PDF_Creator_(Pro_10).print_headercenter:
print.printer_Nitro_PDF_Creator_(Pro_10).print_headerleft: &T
print.printer_Nitro_PDF_Creator_(Pro_10).print_headerright: &U
print.printer_Nitro_PDF_Creator_(Pro_10).print_in_color: true
print.printer_Nitro_PDF_Creator_(Pro_10).print_margin_bottom: 0.5
print.printer_Nitro_PDF_Creator_(Pro_10).print_margin_left: 0.5
print.printer_Nitro_PDF_Creator_(Pro_10).print_margin_right: 0.5
print.printer_Nitro_PDF_Creator_(Pro_10).print_margin_top: 0.5
print.printer_Nitro_PDF_Creator_(Pro_10).print_oddpages: true
print.printer_Nitro_PDF_Creator_(Pro_10).print_orientation: 0
print.printer_Nitro_PDF_Creator_(Pro_10).print_page_delay: 50
print.printer_Nitro_PDF_Creator_(Pro_10).print_paper_data: 9
print.printer_Nitro_PDF_Creator_(Pro_10).print_paper_height: -1,00
print.printer_Nitro_PDF_Creator_(Pro_10).print_paper_name:
print.printer_Nitro_PDF_Creator_(Pro_10).print_paper_size_unit: 1
print.printer_Nitro_PDF_Creator_(Pro_10).print_paper_width: -1,00
print.printer_Nitro_PDF_Creator_(Pro_10).print_resolution: 600
print.printer_Nitro_PDF_Creator_(Pro_10).print_reversed: false
print.printer_Nitro_PDF_Creator_(Pro_10).print_scaling: 1,00
print.printer_Nitro_PDF_Creator_(Pro_10).print_shrink_to_fit: true
print.printer_Nitro_PDF_Creator_(Pro_10).print_to_file: false
print.printer_Nitro_PDF_Creator_(Pro_10).print_unwriteable_margin_bottom: 0
print.printer_Nitro_PDF_Creator_(Pro_10).print_unwriteable_margin_left: 0
print.printer_Nitro_PDF_Creator_(Pro_10).print_unwriteable_margin_right: 0
print.printer_Nitro_PDF_Creator_(Pro_10).print_unwriteable_margin_top: 0
print.printer_PDFCreator.print_bgcolor: false
print.printer_PDFCreator.print_bgimages: false
print.printer_PDFCreator.print_duplex: -437918235
print.printer_PDFCreator.print_edge_bottom: 0
print.printer_PDFCreator.print_edge_left: 0
print.printer_PDFCreator.print_edge_right: 0
print.printer_PDFCreator.print_edge_top: 0
print.printer_PDFCreator.print_evenpages: true
print.printer_PDFCreator.print_footercenter:
print.printer_PDFCreator.print_footerleft: &PT
print.printer_PDFCreator.print_footerright: &D
print.printer_PDFCreator.print_headercenter:
print.printer_PDFCreator.print_headerleft: &T
print.printer_PDFCreator.print_headerright: &U
print.printer_PDFCreator.print_in_color: true
print.printer_PDFCreator.print_margin_bottom: 0.5
print.printer_PDFCreator.print_margin_left: 0.5
print.printer_PDFCreator.print_margin_right: 0.5
print.printer_PDFCreator.print_margin_top: 0.5
print.printer_PDFCreator.print_oddpages: true
print.printer_PDFCreator.print_orientation: 0
print.printer_PDFCreator.print_page_delay: 50
print.printer_PDFCreator.print_paper_data: -1
print.printer_PDFCreator.print_paper_height: 296,90
print.printer_PDFCreator.print_paper_name:
print.printer_PDFCreator.print_paper_size_unit: 1
print.printer_PDFCreator.print_paper_width: 210,00
print.printer_PDFCreator.print_resolution: 600
print.printer_PDFCreator.print_reversed: false
print.printer_PDFCreator.print_scaling: 1,00
print.printer_PDFCreator.print_shrink_to_fit: true
print.printer_PDFCreator.print_to_file: false
print.printer_PDFCreator.print_unwriteable_margin_bottom: 0
print.printer_PDFCreator.print_unwriteable_margin_left: 0
print.printer_PDFCreator.print_unwriteable_margin_right: 0
print.printer_PDFCreator.print_unwriteable_margin_top: 0
privacy.cpd.offlineApps: true
privacy.cpd.sessions: false
privacy.cpd.siteSettings: true
security.sandbox.content.tempDirSuffix: {bce188b2-5a7f-4fb4-a41e-15e8ffb9f07e}
services.sync.declinedEngines:
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1473796672
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.13 Beta
Version in use: 4.13 Beta

NSS
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

NSSSMIME
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

NSSSSL
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

NSSUTIL
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 2
I forgot to say that this issue got worse after 52.0a1 update. When the browser doesn't crash it shows only video playback and black screen or the page shows kinda weird. (Screenshoots attached)
Attached image Img4.jpg
Attached image Img5.jpg
What can we do to move forward on this? This crash, along with bug 1292923 (same bug really), is actually our #1 top crash on Nightly when you add up all the different signatures...
Priority: P3 → P1
(In reply to josetaborda from comment #20)
> Created attachment 8794216 [details]
> Img4.jpg

I had this problem exhibiting as a driver reset but no crash. It was happening continuously for me until I installed the latest driver from Intel. Windows is still shipping with the busted driver. I had put it down to having a 4k display. My GPU is an HD 4600.
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #23)
> (In reply to josetaborda from comment #20)
> > Created attachment 8794216 [details]
> > Img4.jpg
> 
> I had this problem exhibiting as a driver reset but no crash. It was
> happening continuously for me until I installed the latest driver from
> Intel. Windows is still shipping with the busted driver. I had put it down
> to having a 4k display. My GPU is an HD 4600.

I already have installed the latest driver for Intel HD Graphics 3000 for 2nd generation Intel Core Processors as shown on http://www.intel.com/content/www/us/en/support/graphics-drivers/intel-hd-graphics-3000-for-2nd-generation-intel-core-processors.html but this doesn't have solved anything.

Description: Intel(R) HD Graphics 3000
Vendor ID: 0x8086
Device ID: 0x0116
Driver Version: 9.17.10.4229
Driver Date: 5-28-2015
OS: Windows 8.1 x64
Correlations for signatures starting with 'igd10umd64.dll':

(100.0% in signature vs 28.41% overall) cpu_arch = amd64
(100.0% in signature vs 63.67% overall) ipc_channel_error = None
(100.0% in signature vs 63.80% overall) adapter_vendor_id = 0x8086
(41.39% in signature vs 07.07% overall) reason = EXCEPTION_ACCESS_VIOLATION_WRITE
(57.62% in signature vs 24.34% overall) reason = EXCEPTION_ACCESS_VIOLATION_READ
(40.79% in signature vs 09.09% overall) address = 0x0
(32.87% in signature vs 03.72% overall) cpu_info = family 6 model 42 stepping 7 | 4
(30.89% in signature vs 03.21% overall) cpu_info = family 6 model 58 stepping 9 | 4
(44.95% in signature vs 17.94% overall) url = ''
(33.27% in signature vs 07.81% overall) adapter_driver_version = 9.17.10.4229
(33.86% in signature vs 09.00% overall) adapter_device_id = 0x0166
(29.70% in signature vs 06.68% overall) adapter_device_id = 0x0116
(01.39% in signature vs 23.41% overall) url = None
(26.93% in signature vs 47.39% overall) useragent_locale = en-US
(16.24% in signature vs 34.13% overall) bios_manufacturer = American Megatrends Inc.
(17.62% in signature vs 01.35% overall) app_init_dlls = nvinitx.dll
(17.23% in signature vs 00.99% overall) cpu_info = family 6 model 42 stepping 7 | 2
(19.60% in signature vs 04.14% overall) GFX_ERROR "(gfxWindowsPlatform) Detected device reset: "
(19.21% in signature vs 04.04% overall) GFX_ERROR "(gfxWindowsPlatform) Finished device reset."
Comment on attachment 8782094 [details] [diff] [review]
reuse-decoder-device-pref

Review of attachment 8782094 [details] [diff] [review]:
-----------------------------------------------------------------

Matt, this is in the context of being able to run a telemetry experiment, and see if disabling reusing decoder device makes a difference in these (or other) crashes.  Does the patch give us that answer, or do we need to change more code when "reusing is disabled"?
Attachment #8782094 - Flags: review?(matt.woodrow)
Comment on attachment 8782094 [details] [diff] [review]
reuse-decoder-device-pref

Review of attachment 8782094 [details] [diff] [review]:
-----------------------------------------------------------------

Depending on exactly what you want, the answer might be yes.

Setting this pref stops us from using the compositor device for decoding video and makes sure we use a dedicated one instead.

Previously we had one dedicated decoder device per video, so that's considerably more devices than this pref tests.

We also had the ImageBridge device that was used for various things (texture upload, WebGL), and that change won't be covered by this either.
Attachment #8782094 - Flags: review?(matt.woodrow) → review+
After the today's update (Nightly 52.0a1 Build 20160929030426) everything seems to be going ok. There has been no crashes on any page with video playback (like Facebook, Weather.com, Vimeo, etc.)
Flags: needinfo?(milan)
See Also: → 1292923
This sounds similar to bug 1294748, bug 1310600, 1308863. They started on 50, but the timing is similar.
These appear to have mostly disappeared. The October 8th Nightly was the last one to have significant numbers. In the Nightly builds since then we've had very few, e.g. 0 or 1 of the top 50 crash signatures have involved this DLL.

And I see now that bug 1292923, the companion bug to this one, was fixed then. So I will mark this bug as a duplicate of that one.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1292923
You need to log in before you can comment on or make changes to this bug.