Closed Bug 1300740 Opened 4 years ago Closed 2 years ago

Changing FxA password causes device registration to be lost

Categories

(Firefox for iOS :: Firefox Accounts, defect)

Unspecified
iOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1483606

People

(Reporter: pb, Unassigned)

References

Details

(Whiteboard: [fxa-waffle])

This is the iOS peer to bug 1296328 and bug 1300297.

I don't have an iOS device to test on, so it's not clear to me whether this is actually a problem right now or not. But given that it was/is a problem on desktop and Android, I wanted to raise it here to capture the possibility of it happening at least.

When a user changes their password in FxA, the server destroys the device record. This means that, if there is a signed-in Sync session after the password is changed, it won't show up in the user's list of connected devices. To resolve that, clients must re-register the device (including the device id in the request) after handling the `fxaccounts:change_password` web-channel notification.
Component: FxAccounts → Firefox Accounts
Product: Core → Firefox for iOS
see duplicate bug
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1483606
You need to log in before you can comment on or make changes to this bug.