Closed Bug 1300821 Opened 3 years ago Closed 3 years ago

This "survey" is super obnoxious

Categories

(support.mozilla.org :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: sole, Unassigned)

References

()

Details

(Keywords: DevAdvocacy)

Attachments

(2 files)

I just went to sumo by clicking through a Duck Duck go result. It immediately showed me this "take survey" overlay. What kind of survey is it that thinks itself worthy of being between me and my intentions? I haven't even had a chance to read the article or stay on the site for long. If it wasn't because I had a task to do, I would close the tab immediately.

Most of our users would be really embarrassed that we're using this kind of annoying practice.

Personally, I am embarrassed, and annoyed.

Can we please not do this? Or at least place the survey elsewhere with a bit more of tact, say, when the user has finished doing whatever it is that brought them to the page?

This is about *supporting* users. Not about *interrupting* them, specially if they are somewhat frustrated as I am right now having to downgrade Firefox because there has been a performance regression and my stuff doesn't work in up-to-date Firefox.

Please.
Patrick: Is this survey still in use on SUMO? If not can it be disabled easily?
Flags: needinfo?(pmcclard)
I think, it can be disabled easily by the waffle flag. Will check code and write up here
This was setup during Kadir's time. If Safwan can't figure out how to disable it he should be able to chime in with instructions.
Flags: needinfo?(pmcclard) → needinfo?(a.topal)
So deactivating the "surveygizmo" flag from the admin panel should remove the survey I believe.

I can instruct through IRC or here if instruction is needed
OK let's validate it is OK to turn off the survey before we flip the flag. 

I honestly do not know what it is currently used for so lets have Patrick verify and sign off before we do anything.
See Also: → 1241970
Patrick please sign this off and I'll go ahead and disable the survey.
Flags: needinfo?(a.topal) → needinfo?(pmcclard)
Go ahead and disable this survey.
Flags: needinfo?(pmcclard)
Survey disabled.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
I was able to reproduce the surveys still appearing on 9/24 but was lazy in reporting that. Sorry. At that time I grabbed this info from the Dev Tools Network tab:
https://www.surveygizmo.com/s3/1002970/23736447dcb0
https://www.surveygizmo.com/2016.09.23.00/runtimejs/dist/survey/js/survey.js
https://d2bnxibecyz4h5.cloudfront.net/runtimejs/intercept/intercept.js
https://surveygizmobeacon.s3.amazonaws.com/beaconconfigs/MjgwNDktQUYyRDQ3ODk0MjY1NEVFNUIwNTI3MjhFMDk2QTE3RDU%3D.json

That probably doesn't say much other than the survey is being called by some code still active in Kitsune.

To see the survey, browse the KB. I can trigger it in less than 5 random article visits.
Testing url:
https://support.mozilla.org/en-US/products/firefox/basic-browsing-firefox/bookmarks

Giorgos also confirmed that the survey is still shown & believes that the waffle flag is only for the mobile survey.

Kadir, sorry to bother you as I know you're busy with MDN but I was wondering if you had any tips to offer here since you were the "master of surveys" at the time. :) Thanks in advance!
Status: RESOLVED → REOPENED
Flags: needinfo?(a.topal)
Resolution: FIXED → ---
I confirm that the survey still appears, it seems that the waffle flag disabled only affects the mobile view. 

Kadir, is it possible to disable any surveys in surveygizmo? I'd prefer this compared to pushing new code to delete surveygizmo, since Kitsune is in code freeze.

Thanks!
Kadir provided surveygizmo creds and I closed all SUMO related surveys. This should be fixed for good now. 

Noah can you please verify?
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Flags: needinfo?(krystaiceman)
Resolution: --- → FIXED
Almost Giorgios! I really liked your approach here to getting rid of the surveys. 

http://i.imgur.com/H9CqMMG.png or see attachment above
^ But closing the surveys only appear to have removed the survey option from the popup but haven't killed the popup itself. This got me digging into the Kitsune code and I found 3 survey files:
https://github.com/mozilla/kitsune/blob/master/kitsune/sumo/static/sumo/js/surveygizmo.js
https://github.com/mozilla/kitsune/blob/master/kitsune/kpi/surveygizmo_utils.py
https://github.com/mozilla/kitsune/blob/master/kitsune/kpi/tests/test_surveygizmo_utils.py

I believe the KPI related ones are harmless as that's used for stats but the first file has has a link to the d2bnxibecyz4h5.cloudfront.net/runtimejs/intercept/intercept.js file I mentioned in comment #9.

So I believe deleting the master/kitsune/sumo/static/sumo/js/surveygizmo.js file or modifying it in some way should kill the popup. :) I'll NI Mike just to ask if what I'm saying makes sense. Apologies for bringing you back into a SUMO bug. I'd just really appreciate your input if you have the time to spare. Thanks!

Outer HTML of the survey popup (in case it helps):
<div style="display: block;" class="sg-b-p"><div class="sg-b-p-h"><button type="button" class="sg-b-p-c">×</button></div><div style="display: none;" class="sg-b-p-t"><p class="sg-b-t">We would love to get your opinion on your experience with our site with a short survey</p><a class="sg-b-l-t" href="javascript:void(0);">Take Survey</a><a class="sg-b-l-m" href="//www.surveygizmo.com/s3/1002970/23736447dcb0" target="_blank">Take Survey</a></div><iframe src="//www.surveygizmo.com/s3/1002970/23736447dcb0" class="sg-b-p-i" style="display: block;" frameborder="0"></iframe></div>
Flags: needinfo?(krystaiceman) → needinfo?(mcooper)
The place I would disable this is in the templates. The template variable SURVEY_GIZMOS controls this. It is defined in several places: https://github.com/mozilla/kitsune/search?utf8=%E2%9C%93&q=SURVEY_GIZMOS .  Removing reference to it in all but the base template and setting it to always an empty list in the base template should do the trick.

That leaves some zombie code lying around in the form of surveygizmo.js. That can probably be removed too.

The python files are for reading data *from* survey gizmo, and aren't related to putting out the surveys. I'd leave those in place.
Flags: needinfo?(mcooper)
Cool, thanks for the tips. I'll work on this on monday.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: needinfo?(a.topal)
Fixed as suggested in comment #13

https://github.com/mozilla/kitsune/commit/1506a15a7aad99db7c698479a103e74f49fddcdb
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Confirming this is fixed! Tested opening 20 articles across 2 separate sessions and no survey popup. :) Special thanks to Kadir and Mike for helping out. And to Giorgos as well for not giving up. :D
Status: RESOLVED → VERIFIED
Thank you! 
See Also: → 1173014
Looking at this again, it is at 20% for all users. There is a cookie that prevents it from showing it to users that have already took it. 
Patrick from Wed/Thurs's stand up, how many people mentioned this?
Flags: needinfo?(pmcclard)
Flags: needinfo?(pmcclard)

Still not fixed. Screen flashes due to modal loading.

You need to log in before you can comment on or make changes to this bug.